[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / monitoring

File: [cvs.NetBSD.org] / pkgsrc / sysutils / monitoring / Makefile (download)

Revision 1.11, Mon Sep 2 13:20:09 2019 UTC (4 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.10: +2 -2 lines

Changed PYTHON_VERSIONS_INCOMPATIBLE to PYTHON_VERSIONS_ACCEPTED; needed for future Python 3.8

# $NetBSD: Makefile,v 1.11 2019/09/02 13:20:09 adam Exp $

VERSION=		e518a90eade4ca538468b6640dccb651e6034b9e
DISTNAME=		${VERSION}
PKGNAME=		monitoring-0.9.5
PKGREVISION=		1
CATEGORIES=		sysutils
MASTER_SITES=		https://github.com/sebastien/monitoring/archive/

MAINTAINER=		imil@NetBSD.org
HOMEPAGE=		https://github.com/sebastien/monitoring
COMMENT=		API with DSL feel to write monitoring daemons in Python
LICENSE=		modified-bsd

WRKSRC=			${WRKDIR}/monitoring-${VERSION}

REPLACE_PYTHON+=	Sources/monitoring.py Scripts/monitoring
PYTHON_VERSIONS_ACCEPTED=	27 # not yet ported as of 0.9.5

DOCDIR=			${PREFIX}/share/doc/monitoring
EXPDIR=			${PREFIX}/share/examples/monitoring

INSTALLATION_DIRS+=	${DOCDIR}
INSTALLATION_DIRS+=	${EXPDIR}

post-install:
	${INSTALL_DATA} ${WRKSRC}/Examples/*.py ${DESTDIR}${EXPDIR}
	${INSTALL_DATA} ${WRKSRC}/README.rst ${DESTDIR}${DOCDIR}

.include "../../lang/python/application.mk"
.include "../../lang/python/distutils.mk"
.include "../../mk/bsd.pkg.mk"