[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / mate-system-monitor

File: [cvs.NetBSD.org] / pkgsrc / sysutils / mate-system-monitor / Makefile (download)

Revision 1.23, Mon Aug 24 04:41:41 2020 UTC (3 years, 7 months ago) by gutteridge
Branch: MAIN
Changes since 1.22: +2 -2 lines

mate*: remove unintentional linkage against pkgsrc gettext-libs

As of 1.24, MATE requires GNU-specific msgfmt features. meta-pkgs/mate/
Makefile.common r. 1.10 expressed this tool dependency using
USE_BUILTIN.gettext=no, but this exposed pkgsrc gettext-libs in the
build environment as well, which some MATE packages then linked
against, but gettext-libs didn't end up being declared as a run-time
dependency, so binary package installations were broken (with the
workaround of manually installing the undeclared gettext-libs
dependency). Express this dependency differently, so GNU msgfmt is
used as a tool without exposing pkgsrc gettext-libs.

(The pkgsrc tooling infrastruture could be altered to provide a
distinct "gmsgfmt" tool, same with "gxgettext", and perhaps others.
Here I'm just immediately concerned with fixing this packaging issue.)

Addresses PR pkg/55503 by Jay Patel.

# $NetBSD: Makefile,v 1.23 2020/08/24 04:41:41 gutteridge Exp $

PKGREVISION= 6
.include "../../meta-pkgs/mate/Makefile.common"

DISTNAME=	mate-system-monitor-1.22.2
CATEGORIES=	sysutils

COMMENT=	MATE system monitor

TOOL_DEPENDS+=	itstool-[0-9]*:../../textproc/itstool
TOOL_DEPENDS+=	libxml2-[0-9]*:../../textproc/libxml2 # for xmllint

USE_LANGUAGES=	c c++11

.include "../../devel/glib2/schemas.mk"

.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/glibmm/buildlink3.mk"
.include "../../devel/libwnck3/buildlink3.mk"
.include "../../graphics/librsvg/buildlink3.mk"
.include "../../sysutils/libgtop/buildlink3.mk"
.include "../../sysutils/dbus-glib/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../x11/gtkmm3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"