[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / liblogging

File: [cvs.NetBSD.org] / pkgsrc / sysutils / liblogging / Makefile (download)

Revision 1.4, Tue Mar 24 15:55:19 2020 UTC (3 years, 5 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.3: +3 -3 lines

liblogging: Update to 1.0.6

v1.0.6 2017-03-06
- fix small memory leaks in libstdlog
  each open/close leaked a couple of bytes; this was no problem, except if
  they were called very often. However, it was a problem when using memory
  debuggers, which rightfully complained.
- fix BSD build
- enhancement:  sigsafe_printf now recognizes the "j" length modifier
  Thanks to David A. Bright for implementing this
- fix: build_file_line and build_syslog_frame call the __stdlog_print_*
  functions incorrectly
  Change these functions so that they call the __stdlog_print_* functions
  with the correct buffer size.
  see also: https://github.com/rsyslog/liblogging/issues/33
  Thanks to David A. Bright for the patch.
- Implement a STDLOG_PID option
  ... to specify that each log message should be tagged with the process
  identifier as well as the ident.
  Thanks to David A. Bright for implementing this
- bugfix: potentialSEGV in the stdlog_sigsafe_string formatter
  if NULL pointer was passed in
  Thanks to David A. Bright for the patch
- bugfix: stdlog_sigsafe_printf mis-handles an int or unsigned int
  Thanks to David A. Bright for the patch
- build system: auto-detect presence of journal libraries
  simplifies build for most users. Many complained on mailing list
  about missing journal dependency. Now by default we disable it if
  the libs are not found, what usually is the right thing to do.

# $NetBSD: Makefile,v 1.4 2020/03/24 15:55:19 nia Exp $

DISTNAME=	liblogging-1.0.6
CATEGORIES=	sysutils
MASTER_SITES=	https://download.rsyslog.com/liblogging/

MAINTAINER=	fhajny@NetBSD.org
HOMEPAGE=	http://www.liblogging.org/
COMMENT=	Easy to use logging library
LICENSE=	2-clause-bsd

GNU_CONFIGURE=	yes
USE_LIBTOOL=	yes
USE_TOOLS+=	pkg-config

PKGCONFIG_OVERRIDE+=	rfc3195/liblogging-rfc3195.pc.in
PKGCONFIG_OVERRIDE+=	stdlog/liblogging-stdlog.pc.in

CONFIGURE_ARGS+=	--disable-journal
CONFIGURE_ARGS+=	--enable-stdlog

.include "../../mk/bsd.pkg.mk"