File:  [cvs.NetBSD.org] / pkgsrc / sysutils / hexyl / Makefile
Revision 1.4: download - view: text, annotated - select for diffs
Mon Dec 5 11:22:39 2022 UTC (2 years ago) by pin
Branches: MAIN
CVS tags: HEAD
sysutils/hexyl: update to 0.11.0

Features
 - Significantly improved performance, see #173 and #176 (@sharifhsn)
 - Added variable panels through the --panels and --terminal-width flags,
   see #13 and #164 (@sharifhsn)
 - Added new --group-bytes/-g option, see #104 and #170 (@RinHizakura)
 - Added new --base B option (where B can be binary, octal, decimal or
   hexadecimal), see #147 and #178 (@sharifhsn)
 - Show actual zero bytes as ⋄ in the character panel (previously: 0), in
   order not to confuse them with ASCII
 - 0 bytes if colors are deactivated. Closes #166 (@sharkdp)

hexyl as a library
 - Breaking change: Printer::new is deprecated as a part of the public API.
   Alternatively, you can now construct a Printer using the PrinterBuilder
   builder API, see #168. (@sharifhsn)

Other
 - More tests for the squeezing feature, see #177 (@mkatychev)

Thank you
 - Special thanks go to @sharifhsn, not just for the new features, bugfixes
   and performance improvements. But also for many internal improvements of
   the code base and other maintenance tasks.

# $NetBSD: Makefile,v 1.4 2022/12/05 11:22:39 pin Exp $

DISTNAME=	hexyl-0.11.0
CATEGORIES=	sysutils
MASTER_SITES=	${MASTER_SITE_GITHUB:=sharkdp/}
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/sharkdp/hexyl/
COMMENT=	Command-line hex viewer
LICENSE=	apache-2.0

.include "cargo-depends.mk"

INSTALLATION_DIRS=	bin

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/target/release/${PKGBASE} \
		${DESTDIR}${PREFIX}/bin

.include "../../lang/rust/cargo.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>