[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / gnome-vfs2

Annotation of pkgsrc/sysutils/gnome-vfs2/Makefile.common, Revision 1.1

1.1     ! jmmv        1: # $NetBSD$
        !             2: #
        !             3:
        !             4: DISTNAME=              gnome-vfs-2.6.0
        !             5: PKGNAME=               ${DISTNAME:S/vfs/vfs2/}
        !             6: CATEGORIES=            sysutils gnome
        !             7: MASTER_SITES=          ${MASTER_SITE_GNOME:=sources/gnome-vfs/2.6/}
        !             8: EXTRACT_SUFX=          .tar.bz2
        !             9:
        !            10: MAINTAINER=            jmmv@NetBSD.org
        !            11: HOMEPAGE=              http://www.gnome.org/
        !            12: COMMENT=               GNOME Virtual File System (v2)
        !            13:
        !            14: BUILD_USES_MSGFMT=     YES
        !            15:
        !            16: DISTINFO_FILE=         ${.CURDIR}/../../sysutils/gnome-vfs2/distinfo
        !            17: PATCHDIR=              ${.CURDIR}/../../sysutils/gnome-vfs2/patches
        !            18:
        !            19: GNU_CONFIGURE=         YES
        !            20: USE_BUILDLINK3=                YES
        !            21: USE_PKGLOCALEDIR=      YES
        !            22: USE_GNU_TOOLS+=                make
        !            23: USE_LIBTOOL=           YES
        !            24: USE_PKGINSTALL=                YES
        !            25:
        !            26: CONFIGURE_ARGS+=       --disable-fam
        !            27: CONFIGURE_ARGS+=       --disable-gtk
        !            28: CONFIGURE_ARGS+=       --disable-samba
        !            29: CONFIGURE_ARGS+=       --enable-platform-gnome-2
        !            30: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFBASEDIR}
        !            31: CONFIGURE_ARGS+=       --with-html-dir=${PREFIX}/share/doc/html
        !            32: CONFIGURE_ENV+=                openssl_libs=yes
        !            33:
        !            34: CPPFLAGS+=             -DPREFIX=\"\\\"${PREFIX}\\\"\"
        !            35: CPPFLAGS+=             -DPKGLOCALEDIR=\"\\\"${PKGLOCALEDIR}\\\"\"
        !            36:
        !            37: PKG_SYSCONFSUBDIR=     gnome-vfs-2.0
        !            38:
        !            39: EGDIR=                 ${PREFIX}/share/examples/gnome-vfs-2.0
        !            40: .for f in ${EGFILES}
        !            41: CONF_FILES+=           ${EGDIR}/$f ${PKG_SYSCONFDIR}/$f
        !            42: .endfor
        !            43: .undef f
        !            44:
        !            45: #
        !            46: # The following stuff is to allow easy building of modules distributed within
        !            47: # gnome-vfs2 as independent packages.
        !            48: #
        !            49: # GNOME_VFS2_NAME - Name of the module beeing built.  Will be added to the
        !            50: #                   package name, and also used as the library name.
        !            51: # GNOME_VFS2_FLAG - Base name of the flag passed to configure to enable the
        !            52: #                   module.
        !            53: #
        !            54: .if defined(GNOME_VFS2_NAME) && !empty(GNOME_VFS2_NAME)
        !            55: GNOME_VFS2_FLAG?=      ${GNOME_VFS2_NAME}
        !            56:
        !            57: PKGNAME:=              ${PKGNAME:S/gnome-vfs2/gnome-vfs2-${GNOME_VFS2_NAME}/}
        !            58: CONFIGURE_ARGS:=       ${CONFIGURE_ARGS:S/--disable-${GNOME_VFS2_FLAG}/--enable-${GNOME_VFS2_FLAG}/}
        !            59: COMMENT+=              - ${GNOME_VFS2_NAME} plugin
        !            60:
        !            61: ALL_TARGET=            lib${GNOME_VFS2_NAME}.la
        !            62: BUILD_DIRS=            ${WRKSRC}/modules
        !            63:
        !            64: # Fix paths to already installed libraries (by the gnome-vfs2 package).
        !            65: SUBST_CLASSES+=         libs
        !            66: SUBST_MESSAGE.libs=     "Fixing path to dependent libraries."
        !            67: SUBST_STAGE.libs=       pre-configure
        !            68: SUBST_FILES.libs=       modules/Makefile.in
        !            69: SUBST_SED.libs=         -e 's|../libgnomevfs/libgnomevfs-2.la|${BUILDLINK_PREFIX.gnome-vfs2}/lib/libgnomevfs-2.la|g'
        !            70:
        !            71: BUILDLINK_DEPENDS.gnome-vfs2+= gnome-vfs2>=2.6.0nb1
        !            72: .include "../../sysutils/gnome-vfs2/buildlink3.mk"
        !            73:
        !            74: PRINT_PLIST_AWK+=      /^@dirrm lib\/gnome-vfs-2.0\/modules$$/ \
        !            75:                                { print "@comment in gnome-vfs2: " $$0; next; }
        !            76: PRINT_PLIST_AWK+=      /^@dirrm share\/examples\/gnome-vfs-2.0$$/ { next; }
        !            77: PRINT_PLIST_AWK+=      /^@dirrm share\/examples\/gnome-vfs-2.0\/modules$$/ \
        !            78:                                { print "@comment in gnome-vfs2: " $$0; next; }
        !            79:
        !            80: do-install:
        !            81:        cd ${WRKSRC}/modules && ${LIBTOOL} --mode=install \
        !            82:                ${INSTALL_DATA} lib${GNOME_VFS2_NAME}.la \
        !            83:                        ${PREFIX}/lib/gnome-vfs-2.0/modules
        !            84:        cd ${WRKSRC}/modules && ${LIBTOOL} --mode=finish \
        !            85:                        ${PREFIX}/lib/gnome-vfs-2.0/modules
        !            86: .endif
        !            87:
        !            88: .include "../../devel/pkgconfig/buildlink3.mk"
        !            89: .include "../../textproc/intltool/buildlink3.mk"

CVSweb <webmaster@jp.NetBSD.org>