[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / dust

File: [cvs.NetBSD.org] / pkgsrc / sysutils / dust / Makefile (download)

Revision 1.8, Sun Feb 27 20:33:27 2022 UTC (12 months, 3 weeks ago) by pin
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.7: +4 -3 lines

sysutils/dust: update to 0.8.0

-Feature/Bugfix: Allow multiple regexs to be used.
 The -e and -v flags allow multiple values. Before values after the first
 were ignored. This change allows the user to specify multiple regexs and
 have them all applied.
-Feature: Implement ISO output.
-Fix: Add assert for low terminal width.
 If terminal is not wide enought to print text, then print an error message.
-Fix: Bug: names may be shortened unnecessarily.
 The code calculating the width of a row to use vs the width of the terminal
 wasn't quite right.

# $NetBSD: Makefile,v 1.8 2022/02/27 20:33:27 pin Exp $

DISTNAME=	dust-0.8.0
CATEGORIES=	sysutils
MASTER_SITES=	${MASTER_SITE_GITHUB:=bootandy/}
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pin@NetBSD.org
HOMEPAGE=	https://github.com/bootandy/dust/
COMMENT=	More intuitive version of du in rust
LICENSE=	apache-2.0

.include "cargo-depends.mk"

INSTALLATION_DIRS=	bin

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/target/release/dust \
		${DESTDIR}${PREFIX}/bin

.include "../../lang/rust/cargo.mk"
.include "../../mk/bsd.pkg.mk"