[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / dtpstree

File: [cvs.NetBSD.org] / pkgsrc / sysutils / dtpstree / Makefile (download)

Revision 1.1.1.1 (vendor branch), Sun Aug 15 09:07:11 2010 UTC (13 years, 8 months ago) by obache
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.1: +0 -0 lines

Import dtpstree-1.0.3 as sysutils/dtpstree.
Based on PR#43661 by Douglas William Thrift.

DT PS Tree shows running processes as a tree. It is a reimplementation of
pstree from PSmisc for FreeBSD, NetBSD, OpenBSD, DragonFly BSD, and possibly
other modern BSD variants. It also works without /proc and will show the full
set of processes in a jail even if init is not present.

# $NetBSD: Makefile,v 1.1.1.1 2010/08/15 09:07:11 obache Exp $
#

DISTNAME=	dtpstree-1.0.3
CATEGORIES=	sysutils
MASTER_SITES=	http://code.douglasthrift.net/files/dtpstree/ \
		http://apt.douglasthrift.net/files/dtpstree/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	douglas@douglasthrift.net
HOMEPAGE=	http://code.douglasthrift.net/trac/dtpstree
COMMENT=	Display a tree of processes
LICENSE=	apache-2.0

PKG_DESTDIR_SUPPORT=	user-destdir

ONLY_FOR_PLATFORM=	DragonFly-*-* FreeBSD-*-* NetBSD-*-* OpenBSD-*-*

GNU_CONFIGURE=	yes
USE_LANGUAGES=	c c++
USE_TOOLS+=	gmake
MAKE_FILE=	GNUmakefile

.include "options.mk"

.include "../../mk/bsd.pkg.mk"