[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / dbus-glib

File: [cvs.NetBSD.org] / pkgsrc / sysutils / dbus-glib / Makefile (download)

Revision 1.4, Tue Jan 24 07:32:33 2006 UTC (18 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.3: +2 -1 lines

Bump BUILDLINK_RECOMMENDED of textproc/expat to 2.0.0 because
of the shlib major bump.
PKGREVISION++ for the dependencies.

# $NetBSD: Makefile,v 1.4 2006/01/24 07:32:33 wiz Exp $
#

DBUS_INTERFACE=	glib
DBUS_DIRS=	dbus glib tools

.include "../../sysutils/dbus/Makefile.common"
PKGREVISION=	1

# We can't install from within the 'dbus' nor 'tools' directory automatically
# because we'd get a lot of other stuff installed (overriding files in the
# dbus package).
INSTALL_DIRS=	${WRKSRC}/glib

INSTALLATION_DIRS=	bin lib/pkgconfig man/man1

PRINT_PLIST_AWK+=	/^@dirrm include\/dbus-1.0\/dbus$$/ \
				{ print "@comment in dbus: " $$0; next; }

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/include/dbus-1.0/dbus
	${INSTALL_DATA} ${WRKSRC}/dbus/dbus-glib*.h \
		${PREFIX}/include/dbus-1.0/dbus
	${INSTALL_DATA} ${WRKSRC}/dbus-glib-1.pc \
		${PREFIX}/lib/pkgconfig/dbus-glib-1.pc
	cd ${WRKSRC}/tools && ${LIBTOOL} --mode=install \
		${INSTALL_PROGRAM} dbus-monitor ${PREFIX}/bin/dbus-monitor
	${INSTALL_DATA} ${WRKSRC}/tools/dbus-monitor.1 \
		${PREFIX}/man/man1/dbus-monitor.1

.include "../../devel/glib2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"