[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / cfengine2

File: [cvs.NetBSD.org] / pkgsrc / sysutils / cfengine2 / Attic / Makefile (download)

Revision 1.23, Sun Dec 9 22:45:13 2007 UTC (16 years, 4 months ago) by rhaen
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4
Changes since 1.22: +7 -6 lines

- updated to 2.2.3
- new maintainer
- PKG_DESTDIR_SUPPORT
- ok by joerg
2.2.3
        Feedback release after 2.2.2 and LISA 07, minor tweaks and bug fixes

        "Harmless features"

        IgnoreInterfaceRegex( "vm.*" ) added to control
        function added for removing data from special interfaces from class data

        Option checkroot=true/false added to copy directive. This switches
        on/off the change in 2.2.2 about setting permissions on the
        destination root when recursively copying files. Default is now
        false.

        Can escape colons in the strings now to avoid confusion with
        expansion separator.

        cfenvgraph --erasehistory users,www_in etc will now set the
        average and variance of learned cfenvd data to zero. The current
        week's trace is not affected.

        audit=true/false flag added to most actions

2.2.2

        The build procedure for cfengine changes in this version to
        incorporate an intermediate library. The default behaviour is now
        to build a static library which will be used by cfengine 3 and
        other application interfaces. To build a shared library, use

        --enable-shared=yes

        NOTE to developers: if running from the compiled code you now need
        to delete the files cfagent cfservd etc and recompile to see changes
        appear in the code. This is due to the libtool build process.

        libtoolizing compilation process for migration to cfengine shared library
        (this is to support mulitple interfaces in future, and cf 3)

        --

        XML and HTML output options added to equip the internal instrumentation
        with readable output in cfshow e.g.

           cfshow --performance --html > output.html
           firefox output.html

        provides an easier summary and searchability in browser function

        Instrumentation changed to use realtime functions where possible. Standard
        unix timer is too insensitive to measure performance.

        The beginning of an integrated auditing system has been added. See references
        to AuditLog() in the code. This logs to a compressed database and can be extracted
        in ascii, html, xml using cfshow, e.g. cfshow  --audit --html > output.html
        Auditing is switched on by

        control:
         cfinputs_version = ( 1.2.1 ) # record this version in log, e.g. cvs revision
         Auditing = true

        --

        cfshow --classes

        also shows the relative frequencies of classes
        that have occurred on the system and the last time these were
        observed.

        cfshow -f cfagent.conf --regex "lin.*"

        displays all rules in the named file whose classes match the named
        regular expression. Note that the class "any" is not automatically matched
        and the search is based on the class text from the file. The output is not
        related to which classes are currently defined, and it will not recognise
        the history of classes implicit through class-restricted imported files.

        --

        SCLI interface modifications.

        --

        Intermittency entropy code added to the copy instrumentation for
        automatic host reliability measurements.

        Special variable

           IgnoreFriendRegex = ( regex )

        prevents last-seen warnings about hosts matching the named regex

        --

        UserExists("name") and GroupExists("name") functions added to builtin functions.

        ClassMatch function added in classes/groups to match regular expressions of other classes

        --

        Additional octet variables added on default IPv4 address, for convenience:

        e.g.
           590  : ipv4_2[eth1]=192.168
           1895 : ipv4[eth1]=192.168.1.101
           2100 : ipv4_1[eth1]=192
           4049 : ipv4_3[eth1]=192.168.1


        Methods can now expand some list variables, one list only per argument set.
        This is a limited compromise pending cfengine 3. A patch for expansion of
        variables in the control part of a program in methods has also been added.

        Bug fix and code simplication of variable expansion.

        -----

        tied variable expansion added. Allows method workaround for file dissemination
        by name, e.g. copy from

        host1.conf -> /dir/host1/file.conf
        host2.conf -> /dir/host2/file.conf  e.g. for virtual or diskless machines

        -----

        Major changes to package manager code by Jo Rhett. Variable expansion
        fixed by Mark.

        -----

        Option "best" added to checksum= in files action, this allows cross checking
        of the two best known hash algorithms for each file. Currently this is md5 and sha
        due to limitations in OpenSSL libcrypto.

        UnCommentToLineMatching regex added

2.2.1
        scli: type section added. This is a special case of shellcommands, which
        send commands to the special shell scli by Juergen Schoenwaelder for
        communicating with snmp devices.

        Code refactoring for package management.
        Bug fixes for problems introduced in 2.2.0.

        Copy directory would not set owner correctly on root

2.2.0
        Apart from minor changes, this version is about structural internal
        changes that ease the eventual confluence with cfengine 3 and the work
        going on behind the scenes there. Every effort is being made to
        make this change easy for users and existing installations. New features
        will be introduced into 2.2.x gradually, and the new front-end will
        eventually merge into this.

        This version accompanies a new introduction to cfengine published as
        a SAGE Short Topics book.

        * Some changes

        EMANICS extensions and reference testing for context sensitive
        network navigation patterns using voluntary cooperation contracts.

        PrintFile("name") function added to alerts

        !! List expansion in editfiles actions. This is an important change
        because it can potentially affect existing configurations that contain
        variables with a list separator in them. EditSplit is used for this.

        elsdefine fixed in tidy

        processes with action=warn only install fix

        ifelapsed/expireafter fixed in editfiles

        Instrumentation of copy/shellcommands measuring time/averages
        use cfshow --performance

        background=true in shellcommands was not implemented! (Fixed)

        SLES10 recognition
        RedHat/Fedora further classes

        SELinux support begun by Jeff Sheltren UCSB, who notes.
        > Currently, I have editfiles and copy working with selinux security
        > contexts, although so far copy only has support for regular files; I
        > haven't worked on links, etc. yet.
        > Use --enable-selinux during compilation

        Bug / misleading error message in ReadArray fixed

        HostRange bug for numericals in hostname fixed by Steve Radar.

# $NetBSD: Makefile,v 1.23 2007/12/09 22:45:13 rhaen Exp $
#

.include "../../sysutils/cfengine2/Makefile.common"

COMMENT=	Automate configuration and administration of large systems

GNU_CONFIGURE=		YES
PTHREAD_OPTS+=		require

BUILD_DEFS+=		IPV6_READY

CONFIGURE_ARGS+=	--with-berkeleydb=${BUILDLINK_PREFIX.db4}
CONFIGURE_ARGS+=	--with-openssl=${BUILDLINK_PREFIX.openssl}
USE_TOOLS+=		flex perl:run
REPLACE_PERL=		contrib/cfdoc
PKG_DESTDIR_SUPPORT=	user-destdir

RCD_SCRIPTS=		cfexecd cfservd cfenvd

post-install:
	${INSTALL_MAN_DIR} ${DESTDIR}/${PREFIX}/${PKGMANDIR}/man8
	${INSTALL_MAN} ${WRKSRC}/doc/*.8 ${DESTDIR}/${PREFIX}/${PKGMANDIR}/man8
	${INSTALL_DATA_DIR} ${DESTDIR}/var/cfengine/inputs

.include "../../mk/pthread.buildlink3.mk"
.include "../../databases/db4/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"