File:  [cvs.NetBSD.org] / pkgsrc / sysutils / bacula-doc / Makefile
Revision 1.25: download - view: text, annotated - select for diffs
Sun Dec 26 18:39:46 2010 UTC (14 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, HEAD
Changes 5.0.3:
This 5.0.3 version is significant bug fix update to version 5.0.2.
It includes new code and some new features.
There is no database change since prior versions of 5.0.

Compatibility:
--------------
As always, both the Director and Storage daemon must be upgraded at
the same time.

Older 5.0.x and 3.0.x File Daemons are compatible with the 5.0.3
Director and Storage daemons. There should be no need to upgrade older File
Daemons.

Changes and New Features:
- If a VSS (Windows) snapshot fails, the whole Job is failed, previously
  it printed a warning message and continued.
- New editing codes %b = Job Bytes and %f = Job Files for runscripts
- Any non-Bacula project plugins (i.e. third party plugins)
  must be upgraded to specify AGPLv3 in place of the GPLv2 used previously
  for the PLUGIN_LICENSE.
- The bat Media page text columns can be sorted by clicking on the column.
- If possible, the SD will automatically update the catalog Volume size if
  it does not match the Volume size. The mismatch between the Volume sizes
  typically occurs when the FD has a comm line drop or the FD crashes.

# $NetBSD: Makefile,v 1.25 2010/12/26 18:39:46 adam Exp $

DISTNAME=	bacula-docs-5.0.3
PKGNAME=	${DISTNAME:S/docs/doc/}
CATEGORIES=	sysutils
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=bacula/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.bacula.org/
COMMENT=	Documentation for Bacula - The Network Backup Solution

PKG_DESTDIR_SUPPORT=	user-destdir

NO_CONFIGURE=		yes
NO_BUILD=		yes

DOCDIR=			share/doc/bacula

INSTALLATION_DIRS=	${DOCDIR}
INSTALLATION_DIRS+=	${DOCDIR}/console
INSTALLATION_DIRS+=	${DOCDIR}/developers
INSTALLATION_DIRS+=	${DOCDIR}/main
INSTALLATION_DIRS+=	${DOCDIR}/misc
INSTALLATION_DIRS+=	${DOCDIR}/problems
INSTALLATION_DIRS+=	${DOCDIR}/utility

do-install:
	${INSTALL_DATA} ${WRKSRC}/manuals/en/console/console/* ${DESTDIR}${PREFIX}/${DOCDIR}/console/
	${INSTALL_DATA} ${WRKSRC}/manuals/en/developers/developers/* ${DESTDIR}${PREFIX}/${DOCDIR}/developers/
	${INSTALL_DATA} ${WRKSRC}/manuals/en/main/main/* ${DESTDIR}${PREFIX}/${DOCDIR}/main/
	${INSTALL_DATA} ${WRKSRC}/manuals/en/misc/misc/* ${DESTDIR}${PREFIX}/${DOCDIR}/misc/
	${INSTALL_DATA} ${WRKSRC}/manuals/en/problems/problems/* ${DESTDIR}${PREFIX}/${DOCDIR}/problems/
	${INSTALL_DATA} ${WRKSRC}/manuals/en/utility/utility/* ${DESTDIR}${PREFIX}/${DOCDIR}/utility/

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>