[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / bacula-clientonly

File: [cvs.NetBSD.org] / pkgsrc / sysutils / bacula-clientonly / Makefile (download)

Revision 1.23, Tue Jan 14 10:58:17 2014 UTC (10 years, 3 months ago) by markd
Branch: MAIN
Changes since 1.22: +1 -3 lines

Update bacula to 5.2.13

Important changes since last release:

19Feb13
 - Fix build/configure problems with bpluginfo.c
 - Refactor lock_volumes so most lock a vol rather than globally
 - Add virtualfull-extreme test
 - Apply patch for chio-changer-openbsd  -- Implements listall
 - Add bat Mac patch
 - Fix bug cannot run Copy/Migrate jobs from bat
 - Fix loading of bat translations.
 - Fix text input in bat.
 - Remove Device from show command as it is not used or updated
 - Fix update enabled keyword in help command
 - Fix update_postgresql_tables 10 to 11
 - Clean after building doc binaries
 - Require Qt version 4.8.4
 - Fix bug that OK to run? does not retry on bad response
 - Backport new lock calls + debug for SD
 - Fix bug new label ignored when first is duplicate.
 - Pull src/lib changes from master
 - Pull SD files from master
 - Turn off prune-test
 - Add logdir and bsrdir to regression config
 - Add bsrdir and logdir to regress-config
 - Changed default directories from /var/bacula to /opt/bacula
 - Make spool size max message more explicit
 - Display more info when maximum spool size is reached
 - Fix TERM defs for Solaris 11 in conio.c
 - Allow group to cd to sysconfdir
 - Make sysconfdir belong to Bacula user/group and exclude others
 - Fix Virtual Full file close bug -- race condition
 - Enhance mount message to include read/append
 - Improve vol_mgr swap messages
 - Enhance output of Using Device to include for read/write
 - Add jobid to Pmsg output
 - Fix bug input validation on delete of jobs.
 - Fix bug Authorization Errors false
 - Add workaround for where autoprune and reload are in deadlock
 - Allow conf file quoted strings to be used in a list
 - Make bfgets handle very long lines
 - Avoid seg fault by checking for NULL client -- reported by Arno
 - Fix bug MailOnSuccess get executed on error.
 - Fix missing index on Media table
 - Fix bug no message storage on closed database connection.
 - Fix bug Fix problem with MySQL with big Base jobs.
 - Reduce wait time in regression RunScripts
 - Implement a timeout on regression tests of 15 minutes
 - Fix .bvfs_lsfiles and .bvfs_restore to handle deleted files
 - Fix spooldata, accurate and ingnoreduplicate run argument
 - Fix messages segfault
 - fix about PATH_MAX on hurd
 - fix about MAXPATHLEN on hurd
 - Fix bug OpenBSD autochanger example script
 - Fix about MaxRunTime canceling the job too early
 - Fix bug Wrong values at media list in BAT
 - Fix race condition in close_msg that causes seg fault
 - Fix double unlink
 - More tests for freeing NULL pointers
 - Add MaximumConcurrentReadJobs directive to Storage resource
 - Add ujobid to .bvfs_get_jobids
 - Avoid problem when stripping a relative path
 - Fix about HIDDEN attribute set to parent directory during restore

# $NetBSD: Makefile,v 1.23 2014/01/14 10:58:17 markd Exp $

PKGNAME=		${DISTNAME:S/-/-clientonly-/}
COMMENT=		The Network Backup Solution (client only)

CONFLICTS=		bacula-[0-9]* bacula-client-[0-9]*

DISTINFO_FILE=		${.CURDIR}/../../sysutils/bacula/distinfo
PATCHDIR=		${.CURDIR}/../../sysutils/bacula/patches
FILESDIR=		${.CURDIR}/../../sysutils/bacula/files

PLIST_SRC=		${.CURDIR}/../../sysutils/bacula/PLIST.common

CONFIGURE_ARGS+=	--enable-client-only

OWN_DIRS_PERMS+=	${BACULA_WORKINGDIR} root ${BACULA_GROUP} 770

PKG_GROUPS=		${BACULA_GROUP}

CONF_FILES+=		${EXAMPLESDIR}/bacula-fd.conf ${PKG_SYSCONFDIR}/bacula-fd.conf
CONF_FILES+=		${EXAMPLESDIR}/bconsole.conf ${PKG_SYSCONFDIR}/bconsole.conf

RCD_SCRIPTS=		bacula-fd

.include "../../sysutils/bacula/Makefile.common"

post-install:
	${INSTALL_DATA} ${WRKSRC}/src/dird/query.sql ${DESTDIR}${PREFIX}/libexec/bacula/query.sql

.include "options.mk"

.include "../../mk/bsd.pkg.mk"