[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / apcupsd

Annotation of pkgsrc/sysutils/apcupsd/Makefile, Revision 1.24

1.24    ! grant       1: # $NetBSD: Makefile,v 1.23 2003/07/17 22:53:27 grant Exp $
1.1       bouyer      2:
1.21      bouyer      3: DISTNAME=              apcupsd-3.8.6
1.22      wiz         4: PKGREVISION=           1
1.2       jlam        5: CATEGORIES=            sysutils
1.21      bouyer      6: MASTER_SITES=          ${MASTER_SITE_SOURCEFORGE:=apcupsd/}
1.2       jlam        7:
1.23      grant       8: MAINTAINER=            bouyer@NetBSD.org
1.3       wiz         9: HOMEPAGE=              http://www.sibbald.com/apcupsd/
1.7       wiz        10: COMMENT=               UPS power management for APCC Products
1.2       jlam       11:
1.8       hubertf    12: BUILD_USES_MSGFMT=     yes
1.2       jlam       13:
1.20      jlam       14: USE_BUILDLINK2=                yes
                     15: USE_PKGINSTALL=                yes
                     16: USE_GMAKE=             yes
1.2       jlam       17:
1.20      jlam       18: GNU_CONFIGURE=         yes
1.2       jlam       19:
1.18      bouyer     20: PKG_SYSCONFSUBDIR= apcupsd
                     21:
1.13      lukem      22: # Thread support is needed to for http support, and to compile powerflute,
                     23: # which has a curses interface
1.2       jlam       24: #
1.13      lukem      25: #CONFIGURE_ARGS+=      --enable-http           # include http support
1.24    ! grant      26: #.include "../../mk/curses.buildlink2.mk"
1.2       jlam       27: #CONFIGURE_ARGS+=      --enable-threads        # compile threading code
                     28: #CONFIGURE_ARGS+=      --enable-powerflute     # compile powerflute program
                     29:
                     30: CONFIGURE_ARGS+=       --with-catgets          # use catgets functions
                     31: CONFIGURE_ARGS+=       --enable-nls            # i18n support
1.18      bouyer     32: CONFIGURE_ARGS+=       --with-lock-dir=/var/spool/lock
                     33: CONFIGURE_ARGS+=       --with-serial-dev=/dev/tty01
                     34: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR}
                     35: # configure sets sbindir to '${prefix}/sbin' without expanding $prefix
                     36: # this breaks .in files that uses @sbindir@
                     37: CONFIGURE_ARGS+=       --sbindir=${PREFIX}/sbin
                     38:
                     39: EGDIR=          ${PREFIX}/share/examples/apcupsd
                     40:
                     41: CONF_FILES_PERMS+=     ${EGDIR}/apcupsd.master.conf ${PKG_SYSCONFDIR}/apcupsd.conf ${ROOT_USER} ${ROOT_GROUP} 644
                     42: CONF_FILES_PERMS+= ${EGDIR}/changeme ${PKG_SYSCONFDIR}/changeme ${ROOT_USER} ${ROOT_GROUP} 755
                     43: CONF_FILES_PERMS+= ${EGDIR}/commfailure ${PKG_SYSCONFDIR}/commfailure ${ROOT_USER} ${ROOT_GROUP} 755
                     44: CONF_FILES_PERMS+= ${EGDIR}/commok ${PKG_SYSCONFDIR}/commok ${ROOT_USER} ${ROOT_GROUP} 755
                     45: CONF_FILES_PERMS+= ${EGDIR}/onbattery ${PKG_SYSCONFDIR}/onbattery ${ROOT_USER} ${ROOT_GROUP} 755
                     46: CONF_FILES_PERMS+= ${EGDIR}/mainsback ${PKG_SYSCONFDIR}/mainsback ${ROOT_USER} ${ROOT_GROUP} 755
                     47: SUPPORT_FILES_PERMS=  ${EGDIR}/apccontrol ${PKG_SYSCONFDIR}/apccontrol ${ROOT_USER} ${ROOT_GROUP} 755
                     48: RCD_SCRIPTS=   apcupsd
                     49:
1.2       jlam       50: # we should probably allow the tty to be set in /etc/mk.conf too
                     51: #
                     52: post-build:
1.18      bouyer     53:        ${SED} -e 's|@@PREFIX@@|${PREFIX}|' \
                     54:                ${WRKSRC}/examples/apcupsd.master.conf > \
                     55:                ${WRKDIR}/apcupsd.master.conf
                     56:        ${SED} -e 's|@@PREFIX@@|${PREFIX}|' \
                     57:                ${WRKSRC}/examples/apcupsd.slave.conf > \
                     58:                ${WRKDIR}/apcupsd.slave.conf
                     59:        ${SED} -e 's|@@PREFIX@@|${PREFIX}|'\
                     60:             -e 's|@@SYSCONFDIR@@|${PKG_SYSCONFDIR}|' \
                     61:             ${WRKSRC}/doc/apcupsd.man > ${WRKSRC}/doc/apcupsd.8
1.2       jlam       62:
1.18      bouyer     63: DOCS=  README.BackUPS          \
                     64:        README.BackUPS-Pro      \
1.2       jlam       65:        README.NewerBackUPS-Pro \
                     66:        README.Share-UPS        \
                     67:        README.SmartUPS-VS      \
                     68:        README.apcaccess        \
                     69:        README.autoconfig       \
                     70:        README.cable            \
                     71:        Statement.APCC          \
1.18      bouyer     72:        apcupsd-bug-1           \
                     73:        apcupsd-bug-2           \
                     74:        minicom.txt             \
1.2       jlam       75:        port.gif
                     76:
1.18      bouyer     77: HTMLDOCS= apcaccess.html apcnisd.html apctest.html apcupsd-styles.css \
                     78:         apcupsd.book apcupsd.gif apcupsd.html batteries.html bugs.html \
                     79:         cables.html cgiprogs.html charging.gif config-examples.html \
                     80:         configure.html data.html eprom.html events.html faq.html index.html \
                     81:         install.html invoking.html kernel_config.html license.html \
                     82:         logging.html master-slave.html multiUPS.html multimon.gif \
                     83:         new_features_3_7_0.html new_features_3_8_0.html \
                     84:         new_features_3_8_1.html new_features_3_8_2.html \
                     85:         new_features_3_8_3.html new_features_3_8_4.html \
                     86:         new_features_3_8_5.html oldversions.html onbatt.gif online.gif \
                     87:         security.html shutdown.html status.gif status.html stopping.html \
                     88:         testing.html thanks.gif thanks.html troubles.html \
                     89:         upgrading_to_3_7_0.html upsbible.html usb.html win32.html \
                     90:         wininstall1.gif wininstall2.gif wininstall3.gif wininstall4.gif \
                     91:         wininstall5.gif wininstall6.gif wininstall7.gif
                     92:
1.2       jlam       93: post-install:
1.18      bouyer     94:        ${INSTALL_DATA} ${WRKDIR}/apcupsd.master.conf \
                     95:                ${PREFIX}/share/examples/apcupsd
                     96:        ${INSTALL_DATA} ${WRKDIR}/apcupsd.slave.conf \
                     97:                ${PREFIX}/share/examples/apcupsd
                     98:        ${INSTALL_SCRIPT} ${WRKSRC}/distributions/netbsd/apcupsd \
                     99:                ${PREFIX}/etc/rc.d
1.2       jlam      100:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/apcupsd
                    101: .for file in ${DOCS}
                    102:        ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/apcupsd
                    103: .endfor
1.18      bouyer    104:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/html/apcupsd
                    105: .for file in ${HTMLDOCS}
                    106:        ${INSTALL_DATA} ${WRKSRC}/doc/manual/${file} \
                    107:                ${PREFIX}/share/doc/html/apcupsd
                    108: .endfor
1.2       jlam      109:
1.17      wiz       110: .include "../../devel/gettext-lib/buildlink2.mk"
1.1       bouyer    111: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>