The NetBSD Project

CVS log for pkgsrc/sysutils/amanda-common/Makefile.common

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / amanda-common

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.45 / (download) - annotate - [select for diffs], Mon Nov 4 21:28:40 2019 UTC (3 years, 2 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, HEAD
Changes since 1.44: +4 -4 lines
Diff to previous 1.44 (colored)

sysutils: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

Manually excluded consolekit and dc-tools since pkglint didn't get the
formatting correct.

Revision 1.44 / (download) - annotate - [select for diffs], Sun Nov 25 20:20:57 2018 UTC (4 years, 2 months ago) by spz
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.43: +2 -1 lines
Diff to previous 1.43 (colored)

make amanda-security.conf be treated as a config file
make sure amanda finds amanda-security.conf in PKG_SYSCONFDIR

Revision 1.43 / (download) - annotate - [select for diffs], Wed Jul 4 13:40:36 2018 UTC (4 years, 6 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.42: +2 -2 lines
Diff to previous 1.42 (colored)

*: Move SUBST_STAGE from post-patch to pre-configure

Performing substitutions during post-patch breaks tools such as mkpatches,
making it very difficult to regenerate correct patches after making changes,
and often leading to substituted string replacements being committed.

Revision 1.42 / (download) - annotate - [select for diffs], Mon Feb 29 05:50:40 2016 UTC (6 years, 11 months ago) by mlelstv
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.41: +2 -1 lines
Diff to previous 1.41 (colored)

Add support for NetBSD wedge names.
Bump versions.

Revision 1.41 / (download) - annotate - [select for diffs], Wed Nov 25 12:53:29 2015 UTC (7 years, 2 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.40: +4 -4 lines
Diff to previous 1.40 (colored)

Remove mk/find-prefix.mk usage from the sysutils category.

The find-prefix infrastructure was required in a pkgviews world where
packages installed from pkgsrc could have different installation
prefixes, and this was a way for a dependency prefix to be determined.

Now that pkgviews has been removed there is no longer any need for the
overhead of this infrastructure.  Instead we use BUILDLINK_PREFIX.pkg
for dependencies pulled in via buildlink, or LOCALBASE/PREFIX where the
dependency is coming from pkgsrc.

Provides a reasonable performance win due to the reduction of `pkg_info
-qp` calls, some of which were redundant anyway as they were duplicating
the same information provided by BUILDLINK_PREFIX.pkg.

Revision 1.40 / (download) - annotate - [select for diffs], Thu Sep 25 21:47:06 2014 UTC (8 years, 4 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.39: +3 -1 lines
Diff to previous 1.39 (colored)

SunOS needs -lsocket.

Revision 1.39 / (download) - annotate - [select for diffs], Tue Jun 10 15:51:37 2014 UTC (8 years, 7 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.38: +7 -1 lines
Diff to previous 1.38 (colored)

Move fix for swig/bool mess to Makefile.common.

With this, amanda-client, amanda-server and amanda-plot also build.

Revision 1.38 / (download) - annotate - [select for diffs], Wed Jan 23 17:58:19 2013 UTC (10 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.37: +4 -2 lines
Diff to previous 1.37 (colored)

Fix build with automake-1.13.

Revision 1.37 / (download) - annotate - [select for diffs], Mon Jul 30 07:21:11 2012 UTC (10 years, 6 months ago) by sbd
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.36: +67 -4 lines
Diff to previous 1.36 (colored)

Update amanda to 3.3.1

Changes in release 3.3.1

   * amrecover
       o New 'settransalte' command.
   * amanda.conf
       o new '$s' substitution in autolabel.
       o new 'max-dle-by-volume' global option.
       o new 'eject-volume' global option.
   * diskfile
       o new 'includefile' option.
   * amcheck
       o new '--client-verbose' argument.
   * All programs have a new '--version' argument.
   * ampgsql can take property from server configuration.
   * amgetconf can print one property of a section.
   * s3 device
       o new S3_SERVER_SIDE_ENCRYPTION property.
       o use multiple thread to speedup deleting a volume.
   * Many bug fix.

Changes in release 3.3.0

   * The default auth is changed to "bsdtcp", if you are using the default bsd
     then you must add it to your configuration.
       o in amanda.conf
       o in amanda-client.conf
       o in dumptype/disklist
       o in xinetd (if no '-auth' argument to amandad)
   * amdump trap crtl-c, it still send the report and do cleanup if you do
     one crtl-c, do it more than once to abort the run.
   * s3 device
       o use multiple threads to speedup the transfer
       o can connect to eucalytus.
       o new NB_THREADS_BACKUP property
       o new NB_THREADS_RECOVERY property
       o new S3_HOST property
       o new S3_SERVICE_PATH property
       o new S3_SUBDOMAIN property
   * chg-aggregate: new changer that use other changer sequentially.
   * meta-volume
   * Add meta label in tapelist file
   * chg-disk:
       o support for removable disk
       o new NUM-SLOT property
       o new AUTO-CREATE-SLOT property
       o new REMOVABLE property
       o new MOUNT property
       o new UMOUNT property
       o new UMOUNT-LOCKFILE property
       o new UMOUNT-IDLE property
   * new taperscan algorithm:
       o oldest: this algorithm try to run through the volumes in the oldest
	 order
       o lexical: this algorithm try to run through the volumes in the natural
	 order
   * Change in amanda.conf
       o new meta-autolabel option
       o autolabel can include org, config, barcode, meta in the label
       o new client-name option in appication and script.
   * application and script in amanda-client.conf can be used to set default
     properties for application or script.
   * amlabel
       o The label argument is no longer required, an autolabel can be
	 generated
       o new --meta option
       o new --barcode option
       o new --assign option
   * amgtar, amstar: The path must be specified, it will not works with a
     device.
   * amrecover: decompression and decryption are now done on the client if
		compression/encryption was done on the client.
   * amtape: inventory print the current slot
   * amanda.conf:
       o autoflush have value "no|yes|all"
       o script have single-execution setting.
       o Add pre-amcheck, post-amcheck, pre-estimate, post-estimate, pre-backup
         and post-backup to execute-on of script.
       o Add taperscan and interactivity section.
       o add 'server' value in recovery-limit.
       o add dump-limit in a dumptype.
   * amanda-client.conf
       o add amdump-server setting.
   * script are searched in $APPLICATION_DIR, $CONFIG_DIR/<conf>/application
     and $CONFIG_DIR/application
   * amservice
       o add -s argument
       o is also installed on client
   * new amdumpd server service, if enable, it allow client to start a backup
     of itself.
   * new amdump_client program, it is use on client to start a backup of itself
   * implement restore command amzfs-sendrecv, it can be use with amrecover.

Changes in release 3.2.2

   * Do not restore the NUL padding bytes, some program fail with them.
   * Fix driver doing nothing if taper crash early.
   * Fix taperalog *FIT no going to second volume.
   * Fix amrestore '-p' not going to next file.
   * flush even if flush threshold are not met if it save tape space.
   * fix crash in amtrmidx due to memory leak.
   * amsamba use 'Use smbclient -TF' for restore.

Changes in release 3.2.1

   * barcode are added to the tapelist file.
   * Faster 'amadmin find', improve speed on many programs.
   * device-output-buffer-size default to a minimum of 4*block_size.
   * ssh auth use the client-port
   * Bug fixed:
      o "Can't opendata output stream: Connection refused".
      o Better handling of dump to tape.
      o Corrupted 'amdump' log file, amstatus not showing correct state.
      o Execute subprocess with the config overwrite.
      o tape-device allow to set LEOM.
      o Crash in robot changer.
      o Script output property are not sent to application.

Changes in release 3.2.0

   * Support for multiple simultaneous writes to storage devices
      o Can write to all available drives in parallel.
      o Works only with the new changer API.
      o Useful if two or more volumes are used in a single run.
      o dump direct to tape can be scheduled any time during the run,
        previously they were done sequencially after all dump to holding disk.
      o enabled with the new 'taper-parallel-write' configuration option.
   * Support for LEOM in storage devices
      o allows splitting without partial parts, saving space
      o much more efficient, since parts need not be cached on disk in most
        cases
   * new, simpler splitting commands in the tapetype section:
     part-size, part-cache-type, part-cache-dir, part-cache-max-size; see
     amanda.conf(5) for details
   * Amanda server configuration file changes (amanda.conf)
      o new configuration keyword:
         + taper-parallel-write -- How many drive amanda can write to
                                   in parallel.
      o deprecated configuration keywords:
         + amrecover_do_fsf
         + amrecover_check_label
   * the CONFIG parameter to amidxtaped is now required; this means that
     versions of amrecover older than 2.4.3 will be unable to recover from
     servers running Amanda-3.2 and later.
   * The new dumptype and global parameters 'recovery-limit' can be used to
     limit which hosts may recover from a particular DLE.  See amanda.conf(5)
     and amanda-auth(7) for more information.
   * Several old changers have been removed - these changers will work with
     Amanda for the forseeable future, but are no longer included in the
     distribution.
      o chg-chio
      o chg-chs
      o chg-iomega
      o chg-juke
      o chg-mcutil
      o chg-mtx
      o chg-null (use the new "chg-null:")
      o chg-rait (use the new "chg-rait:{dev1,dev2}")
      o chg-rth
      o chg-scsi-chio
      o chg-scsi
   * Amdump change:
      o new '--no-taper' option to start the run in degraded mode
   * Amvault is much improved, but still experimental:
      o supports assembling split parts on the source volume and re-splitting
        them on the destination
      o supports filtering dumps with the same syntax as amfetchdump
      o a --fulls-only option skips all incremental dumps on the source
      o an --export option tries to move tertiary volumes to import/export
        slots when completed
      o command-line syntax has changed incompatibly; see manpage or
        'amvault --help'
   * Rewritten and improved:
      o amoverview
      o amcheckdump

Changes in release 3.1.0

   * Deprecated old changers; see amanda-changers(7) for replacements.  These
     changers are still available in the distribution, but will be removed in a
     future release.
      o chg-null
      o chg-zd-mtx
      o chg-rait
      o chg-disk
      o chg-multi
   * Although chg-zd-mtx is still supported, we recommend that all users upgrade
     to the more efficient chg-robot.  See contrib/convert-zd-mtx-to-robot.sh
     for a useful conversion script.
   * Amanda server configuration file changes (amanda.conf)
      o deprecated configuration keywords:
	 + label_new_tapes
      o keywords deprecated in 2.6.1:
         + rawtapedev
	 + tapebufs
	 + file-pad
      o new configuration keyword
         + autolabel   -- replace label_new_tapes
         + columnspec  -- can specify a precision.
         + order       -- in script, to specify script order execution.
         + client_port -- in dumptype, to specify which port to connect on
                          the client.
         + estimate    -- in dumptype, can specify multiple estimate method.
      o accept 'define' keyword for defining an holdingdisk
   * Amanda client configuration file changes (amanda-client.conf)
      o new configuration keyword
         + debug_days  -- how many days to keep debug files.
         + client_port -- use by amrecover, specify which port to connect on
                          the server.
   * Removed compile-time default --with-changer-device: specify a device
     explicitly in amanda.conf instead
   * amtape behavior has changed:
      o 'device' subcommand removed
      o 'slot advance' subcommand removed
      o 'update' subcommand no longer displays each slot as it is updated, and
        is not supported by all changers
      o taperscan output has changed
      o new 'inventory' subcommand
   * amrmtape rewrite
      o use long option
         + --changer    -- Specify which changer to use
         + --cleanup    -- Remove logs and indexes associated with label
         + --dryrun     -- do not update the original copies.
         + --erase      -- Attempt to erase the data contained on the volume
         + --keep-label -- Do not remove label from the tapelist
         + --quiet      -- Opposite of --verbose
         + --verbose    -- List backups of hosts and disks that are being
                           discarded.
   * amdevcheck
      o new --label option.
      o new --properties option.
   * Device API
      o changed wildcard setting for S3_BUCKET_LOCATION from "" to "*"
      o new 'ndmp:' device to write to a tape on an ndmp server.
      o new 'dvdrw:' device to write to a dvd drive.
   * Application API
      o new properties to many applications
      o amgtar
         + new ACLS, SELINUX and XATTRS properties
      o amsamba
         + Allow '\' in diskname and amandapass.
         + new ALLOW-ANONYMOUS property.
      o new applications:
         + ampgsql  -- Backup PostgreSQL using continuous WAL archiving
         + amsuntar -- Backup filesytem with the SUN tar
         + amraw    -- Backup only one directory entry
   * New taper, with DirectTCP support, changed tape and catalog format:
      o all dumpfiles are now F_SPLIT_DUMPFILE
      o all on-tape dumpfiles have numparts=-1, since it's no longer possible
        to calculate this value in advance
      o there is no logging or reporting of zero-byte, successful parts (this
        may cause gaps in filenums in the catalog)
   * Redesigned amreport
      o much more natural command-line interface (just run 'amreport $config')
      o experimental XML output
   * configuration override for dumptype works with inheritance.

Changes in release 2.6.1p2
   * amtapetype: new -p option
   * Bugs fixed
      o S3 device driver
      o amcheckdump
      o file not removed from holding disk
      o sendbackup compatibility with a 2.4.2 server
      o handle EROFS error from tape device.
      o zfs snapshot name us the diskname.
      o fix fd allocation in amandad
      o crash in amflush

Changes in release 2.6.1p1

   * amplot: better output
   * Don't include genversion.h in distribution tarballs.
   * Bugs fixed
      o S3 device driver
      o rait device driver
      o amstatus
      o configure
      o application-api
      o compilation on some platform
      o others small bug

Changes in release 2.6.1

   * Amanda server configuration file changes (amanda.conf)
      o deprecated configuration keywords:
         + rawtapedev
	 + tapebufs
	 + file-pad
   * Application API: Allow to easily write wrappers around any backup program,
     See the 'amanda-applications' man page.
      o amgtar: Use GNU tar, it is a lot more configurable than the GNUTAR
        program. See 'amgtar' man page.
      o amstar: Use star to do a backup, it work only on a partition. See
        'amstar' man page.
      o amsamba: Use smbclient to backup a cifs share, see amsamba man page.
      o amzfs-sendrecv: Do a backup of a ZFS filesystem with 'zfs send'.
   * Script API: Allow to run script before and after amanda process, see the
     'amanda-scripts' man page.
      o amzfs-snapshot: Do a snapshot of a ZFS filesystem, then 'amgtar'
        application will backup the snapshot. See 'amzfs-snapshot' man page.
      o script-email: Simple script to send email. see 'script-email' man page.
   * Changer API v2.0: perl-based changer interface supporting concurrent
     use of multiple devices and changers.
      o currently operating in "compatibility mode," calling old changer
        shell scripts.
      o under active development.
   * Xfer API: generic library to move and filter data with maximal efficiency
      o can read from and write to arbitrary devices, files, etc.
      o only used in some applications.
   * Amanda archive format: A simple archive format that an application can
     use to create backup image.
   * 'amarchiver' program to manipulate file in amanda archive format.
   * Many improvements to report better error message to user.
   * amtape subcommands 'slot prev' and 'slot last' are removed.
   * Dozens more perl libraries, with more stable interfaces.
   * Many bugs fixed and improvement.
   * amgetconf '--client' option to retrieve config from
     amanda-client.conf on a client.
   * Amanda configuration file changes
       o new application-tool section
       o new script-tool section
       o new device section
       o new changer section

Changes in release 2.6.0

   * configure --disable-shared doesn't work because perl modules require
     shared libraries.  Use configure --with-static-binaries to build
     statically linked binaries.
   * 'amverify' and 'amverifyrun' are deprecated and replaced with the
     new, more flexible 'amcheckdump'
   * 'amdd' and 'ammt' are deprecated.
   * Some Amanda files are now installed in new "amanda/" subdirectories:
     libraries are now installed in $libdir/amanda and internal programs
     are now installed in $libexecdir/amanda.
   * The amandates file, previously at /etc/amandates, is now at
     $localstatedir/amanda/amandates.  You may want to move your existing
     /etc/amandates when you upgrade Amanda.
   * New 'amcryptsimple', 'amgpgcrypt' - encryption plugins based on gpg.
   * New 'amserverconfig', 'amaddclient' - Initial Amanda configuration tools
     these tools make assumptions, please see man page.
   * Many bugs fixed and code rewrite/cleanup
   * glib is required to compile and run amanda.
   * Device API: pluggable interface to storage devices, supporting tapes,
     vtapes, RAIT, and Amazon S3
   * New perl modules link directly to Amanda, to support writing Amanda
     applications in Perl. Perl module are installed by default in the perl
     installsitelib directory. It can be changed with
     'configure --with-amperldir'.
   * New 'local' security driver supports backups of the amanda server
     without any network connection or other configuration.
   * Almost 200 unit tests are available via 'make installcheck'.
   * Amanda configuration file changes
         o amanda.conf changes
               + flush-threshold-dumped
               + flush-threshold-scheduled
               + taperflush
               + device_property
               + usetimestamps default to yes

Revision 1.36 / (download) - annotate - [select for diffs], Mon Jul 30 07:04:29 2012 UTC (10 years, 6 months ago) by sbd
Branch: MAIN
Changes since 1.35: +6 -1 lines
Diff to previous 1.35 (colored)

Add SPECIAL_PERMS entries for binaries the need special perms.
Because of the above change switch all amanda packages to user-destdir
support.

Revision 1.35 / (download) - annotate - [select for diffs], Mon Jul 30 07:03:04 2012 UTC (10 years, 6 months ago) by sbd
Branch: MAIN
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

+ Change the AMANADA_USER to 'amandabackup' to be consistent with other
  packages (and because I think its a good idea).
+ Set the AMANDA_USER's home directory to AMANDA_VAR.
+ Update the AMANDA_USER's gecos comment.

Revision 1.34 / (download) - annotate - [select for diffs], Mon Jul 30 07:02:17 2012 UTC (10 years, 6 months ago) by sbd
Branch: MAIN
Changes since 1.33: +8 -1 lines
Diff to previous 1.33 (colored)

Add some new configure args to bring the config in-line with other binary
distributions:

	+ Add bsd-security, bsdtcp-security, bsdudp-security.
	+ Set default index and tape server to localhost
	+ Build with assertions.
	+ Use a debugging log directory (and add it to OWN_DIRS_PERMS
          in amanda-common)

Revision 1.33 / (download) - annotate - [select for diffs], Mon Jul 30 07:00:12 2012 UTC (10 years, 6 months ago) by sbd
Branch: MAIN
Changes since 1.32: +8 -9 lines
Diff to previous 1.32 (colored)

Miscellaneous makefile clean up.

Revision 1.32 / (download) - annotate - [select for diffs], Mon Jul 30 06:57:21 2012 UTC (10 years, 6 months ago) by sbd
Branch: MAIN
Changes since 1.31: +5 -3 lines
Diff to previous 1.31 (colored)

Add a version.mk file with AMANDA_VERSION in it and use that in all amanda
packages (including the meta-package) and in the buildlink.

Revision 1.31 / (download) - annotate - [select for diffs], Thu Jul 19 07:30:55 2012 UTC (10 years, 6 months ago) by sbd
Branch: MAIN
Changes since 1.30: +2 -2 lines
Diff to previous 1.30 (colored)

Correctly set Amanda license.

Revision 1.30 / (download) - annotate - [select for diffs], Sun May 20 11:13:35 2012 UTC (10 years, 8 months ago) by sbd
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.29: +1 -11 lines
Diff to previous 1.29 (colored)

Convert AMANDA_SSH and AMANFA_FQDN to pkg options and enable amanda-ssh.

Revision 1.29 / (download) - annotate - [select for diffs], Fri Feb 19 18:55:56 2010 UTC (12 years, 11 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.28: +2 -2 lines
Diff to previous 1.28 (colored)

Use REAL_ROOT_USER here.

Revision 1.28 / (download) - annotate - [select for diffs], Mon Dec 14 23:33:01 2009 UTC (13 years, 1 month ago) by heinz
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.27: +2 -1 lines
Diff to previous 1.27 (colored)

LICENSE for the Amanda packages is basically the same as modified-bsd.

Revision 1.27 / (download) - annotate - [select for diffs], Tue Jul 29 17:21:39 2008 UTC (14 years, 6 months ago) by pgoyette
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, cube-native-xorg-base, cube-native-xorg
Changes since 1.26: +3 -1 lines
Diff to previous 1.26 (colored)

Disable IPv6 by default, since this doesn't work on systems which are
configured for IPv4 only.  IPv6 can still be enabled via PKG_OPTIONS.

Fixes my PR pkg/38957

ok gdt@

Revision 1.26 / (download) - annotate - [select for diffs], Fri Feb 15 16:23:09 2008 UTC (14 years, 11 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, cwrapper
Changes since 1.25: +18 -6 lines
Diff to previous 1.25 (colored)

Update to 2.5.2p1, provided by Nick Goffee of BBN.

[bugfixes and minor improvements omitted; see NEWS]

Changes in release 2.5.2

   * krb5 auth is working
   * Works with IPv6 address
   * Amanda configuration file changes
         o amanda.conf changes
               + debugging is enabled in the config file
                 see all debug_* config option
               + tapetype 'readblocksize', if maxtapeblocksize is set too
                 larger for your hardware
   * Amanda command changes
         o amadmin: new 'holding list' and 'holding delete' subcommand.

Changes in release 2.5.1p3

   * Works with tar-1.16 and exit status of 1.

Changes in release 2.5.1p2

   * amoverview is working
   * dumptype starttime is working

   * Amanda command changes
         o amtape accept the -o arguments
         o amgetconf --list to list all tapetype, dumptype, holdingdisk
           or interface
         o amgetconf can return a value of a specific tapetype, dumptype,
           holdingdisk or interface

Changes in release 2.5.1p1

   * Remove contrib/sst.

Changes in release 2.5.1

   * Defects found by Coverity scan and Klocwork K7 analysis tools fixed.
   * Works with GNU tar 1.15.91 - work with new gtar state file format.
   * Open SSL encryption support
   * Two new authentication methods: bsdtcp, bsdudp.
   * Unlimited number of DLEs on a client with bsdtcp, rsh and ssh
     authentication methods.
   * Recovery process amrecover uses Secure API. amoldrecover command
     (same syntax and functionality as amrecover command) is provided for
     compatibility with old Amanda releases. amoldrecover command uses old
     amidxtaped/amindexd protocol.
   * Amanda debug files are separated into client/server/amandad and
     are also classified based on Amanda configuration name.

   * Amanda command changes
         o amfetchdump -o is replaced by -O.
         o amcheck -w option does all tests including the tape writable test.
           Use amcheck -t -w to do only the tape writable test.
         o -o command option to override Amanda configuration. See amanda man
           page for details.
         o amgetconf command doesn't write the BUGGY message when a entry
           is not found in the configuration file.

   * Amanda configuration file changes
         o amanda.conf changes
               + amrecover_do_fsf in amanda.conf defaults to yes
               + amrecover_check_label in amanda.conf defaults to yes
               + usetimestamps in amanda.conf to support multiple
                 backup runs in a calendar day.
               + holdingdisk in amanda.conf supports new values:
                 NEVER, AUTO, REQUIRED.
               + amandad_path, client_username and ssh_keys in
                 amanda.conf for ssh/rsh authentication.
         o New amanda client configuration file - amanda-client.conf.
           Different client configuration file can be used for each Amanda
           configuration.
               + gnutar_list-dir and amandates can be specified in
                 Amanda client configuration file - amanda-client.conf
         o .amandahosts format changes to allow use of secure API for recovery.
         o Amanda service entries in xinetd configuration has changed.

Changes in release 2.5.0p1

* Add the 'amtape update' command.

Changes in release 2.5.0

* Communication security/authentication: Kerberos 4/5, OpenSSH
* Data security: Symmetric/Assymetric encrytion algorithms (aesutil
  and gpg encryption),  Encryption can be done on server or client,
  Custom encryption utilities can be used.
* Compression: Ability to add custom compression tools. This is a
  really useful feature especially since it can specified for a DLE.  You
  can use different compression algorithm for images, binaries, ascii files
  and so on.
* Dump images spanning multiple media volumes - Dump images are no
  longer restricted to a single media volume (tape or vtape).  Data restoration
  can be done using amrecover and amfetchdump commands.
* Auto tape labelling - This optional feature is good for disk backups.

Change in release 2.4.5

* new displayunit global option to select the unit use to display number
  k=kilo, m=mega, g=giga, t=tera.
* new amoverview -skipmissed option.

Change in release 2.4.5b1

* holding disk disk use timestamped directory.
* autoflush flush today's dump.
* new bumppercent global option, this should improve bumping criteria,
  the bumpsize is set to a fixed value which can be adequate for small
  and large disk.
* bumpsize, bumppercent, bumpdays and bumpmult can be in a dumptype.
* calcsize support include and exclude like gnutar.
* new 'estimate' dumptype option to select estimate type:
    CLIENT: estimate by the dumping program.
    CALCSIZE: estimate by the calcsize program, a lot faster but less acurate.
    SERVER: estimate based on statistic from previous run, take second but
            can be wrong on the estimate size.

Revision 1.25 / (download) - annotate - [select for diffs], Wed Jul 4 20:54:59 2007 UTC (15 years, 7 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.24: +4 -3 lines
Diff to previous 1.24 (colored)

Make it easier to build and install packages "unprivileged", where
the owner of all installed files is a non-root user.  This change
affects most packages that require special users or groups by making
them use the specified unprivileged user and group instead.

(1) Add two new variables PKG_GROUPS_VARS and PKG_USERS_VARS to
    unprivileged.mk.  These two variables are lists of other bmake
    variables that define package-specific users and groups.  Packages
    that have user-settable variables for users and groups, e.g. apache
    and APACHE_{USER,GROUP}, courier-mta and COURIER_{USER,GROUP},
    etc., should list these variables in PKG_USERS_VARS and PKG_GROUPS_VARS
    so that unprivileged.mk can know to set them to ${UNPRIVILEGED_USER}
    and ${UNPRIVILEGED_GROUP}.

(2) Modify packages to use PKG_GROUPS_VARS and PKG_USERS_VARS.

Revision 1.24 / (download) - annotate - [select for diffs], Fri Jan 5 12:47:27 2007 UTC (16 years ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

Use MASTER_SITE_SOURCEFORGE.

Revision 1.23 / (download) - annotate - [select for diffs], Mon Oct 2 21:05:44 2006 UTC (16 years, 4 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.22: +10 -8 lines
Diff to previous 1.22 (colored)

Fixed pkglint warnings.

Revision 1.22 / (download) - annotate - [select for diffs], Wed Jul 19 19:14:39 2006 UTC (16 years, 6 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3
Changes since 1.21: +1 -2 lines
Diff to previous 1.21 (colored)

Drop support for LTCONFIG_OVERRIDE.  For quite a long time, pkgsrc
had actually been ignoring LTCONFIG_OVERRIDE anyway and just using
the default LIBTOOL_OVERRIDE to replace libtool scripts in packages.
This just formalizes the fact that LTCONFIG_OVERRIDE is not used
meaningfully by pkgsrc.

Revision 1.21 / (download) - annotate - [select for diffs], Fri May 26 13:19:38 2006 UTC (16 years, 8 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.20: +1 -2 lines
Diff to previous 1.20 (colored)

Remove explicit GNU tar dependency. It is an unnecessary alternative
and the tools framework already does the right thing. Bump revisions.

Revision 1.20 / (download) - annotate - [select for diffs], Sat Mar 4 21:30:40 2006 UTC (16 years, 11 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

Revision 1.19 / (download) - annotate - [select for diffs], Mon Dec 5 23:55:19 2005 UTC (17 years, 1 month ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.18: +7 -7 lines
Diff to previous 1.18 (colored)

Ran "pkglint --autofix", which corrected some of the quoting issues in
CONFIGURE_ARGS.

Revision 1.18 / (download) - annotate - [select for diffs], Mon Dec 5 20:50:59 2005 UTC (17 years, 1 month ago) by rillig
Branch: MAIN
Changes since 1.17: +3 -3 lines
Diff to previous 1.17 (colored)

Fixed pkglint warnings. The warnings are mostly quoting issues, for
example MAKE_ENV+=FOO=${BAR} is changed to MAKE_ENV+=FOO=${BAR:Q}. Some
other changes are outlined in

    http://mail-index.netbsd.org/tech-pkg/2005/12/02/0034.html

Revision 1.17 / (download) - annotate - [select for diffs], Tue Aug 2 09:26:06 2005 UTC (17 years, 6 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.16: +6 -1 lines
Diff to previous 1.16 (colored)

Prevent paths of the build directories from being included in all amanda
packages. Set runtime dependencies on GNU tar and gzip for all amanda
packages.

Bump PKGREVISIONs to 1 for amanda-client and amanda-plot, to 2 for
amanda-common and amanda-server.

Revision 1.16 / (download) - annotate - [select for diffs], Tue Dec 28 09:10:50 2004 UTC (18 years, 1 month ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2005Q2-base, pkgsrc-2005Q2, pkgsrc-2005Q1-base, pkgsrc-2005Q1
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Use VARBASE.

Revision 1.15 / (download) - annotate - [select for diffs], Tue Dec 28 09:06:42 2004 UTC (18 years, 1 month ago) by minskim
Branch: MAIN
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Use ROOT_USER instead of hardcoding root.

Revision 1.14 / (download) - annotate - [select for diffs], Sat Nov 20 23:10:32 2004 UTC (18 years, 2 months ago) by kim
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.13: +5 -2 lines
Diff to previous 1.13 (colored)

Add AMANDA_TMP

Revision 1.13 / (download) - annotate - [select for diffs], Fri Nov 12 12:13:44 2004 UTC (18 years, 2 months ago) by mjl
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Update amanda to 2.4.4p4

Bug fix release and minor improvements:

new chg-iomega changer script.
amanda will not use a tape if it's label is not in the tapelist file.
amflush.c: Don't start a driver if nothing to flush.
amadmin.c: Call check_dumpuser() as soon as posible.
amadmin.c: Don't core dump if DUMPCYLE is too  big.
dumper.c: Parse warning message.

Revision 1.12 / (download) - annotate - [select for diffs], Wed May 12 18:45:25 2004 UTC (18 years, 8 months ago) by bouyer
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.11: +9 -1 lines
Diff to previous 1.11 (colored)

Update the amanda packages to 2.4.4p2. From Paul Shupak in pkg/24550,
with some additionnal fixes by me.

Revision 1.11 / (download) - annotate - [select for diffs], Sat Feb 14 15:29:15 2004 UTC (18 years, 11 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.10: +1 -3 lines
Diff to previous 1.10 (colored)

CONFIG_{GUESS,SUB}_OVERRIDE are now relative to ${WRKSRC} and will
automatically substitute for any config.{guess,sub} files found up to a
directory depth of 2.

Revision 1.10 / (download) - annotate - [select for diffs], Sun Oct 20 03:20:34 2002 UTC (20 years, 3 months ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2003Q4-base, pkgsrc-2003Q4, netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.9: +2 -1 lines
Diff to previous 1.9 (colored)

honour PKG_SYSCONFDIR.

fixes pkg/18530 from Hauke Fath <hf@tangro.de>.

Revision 1.9 / (download) - annotate - [select for diffs], Thu Sep 5 18:07:54 2002 UTC (20 years, 4 months ago) by jschauma
Branch: MAIN
Changes since 1.8: +4 -5 lines
Diff to previous 1.8 (colored)

Changes to make amanda* work nicely on Linux:
 - do not depend on gtar; GNU/Linux tar is gtar, obviously
 - set AMANDA_GROUP as on NetBSD and Darwin

Revision 1.8 / (download) - annotate - [select for diffs], Sun Aug 25 21:50:54 2002 UTC (20 years, 5 months ago) by jlam
Branch: MAIN
Changes since 1.7: +1 -1 lines
Diff to previous 1.7 (colored)

Merge packages from the buildlink2 branch back into the main trunk that
have been converted to USE_BUILDLINK2.

Revision 1.6.2.1 / (download) - annotate - [select for diffs], Sun Aug 25 21:21:20 2002 UTC (20 years, 5 months ago) by jlam
Branch: buildlink2
Changes since 1.6: +5 -1 lines
Diff to previous 1.6 (colored) next main 1.7 (colored)

Merge changes in the main trunk into the buildlink2 branch for those
packages that have been converted to USE_BUILDLINK2.

Revision 1.7 / (download) - annotate - [select for diffs], Sun Jul 21 19:07:32 2002 UTC (20 years, 6 months ago) by schmonz
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews, netbsd-1-6-RELEASE-base, netbsd-1-6, buildlink2-base
Changes since 1.6: +5 -1 lines
Diff to previous 1.6 (colored)

Add a default AMANDA_GROUP for Darwin, and use canonical pkgsrc
config.guess and config.sub. Noted by Randy Beaudreault
<maccult@pacbell.net> in private mail.

Revision 1.6 / (download) - annotate - [select for diffs], Fri Oct 19 09:44:10 2001 UTC (21 years, 3 months ago) by veego
Branch: MAIN
CVS Tags: netbsd-1-5-PATCH003
Branch point for: buildlink2
Changes since 1.5: +3 -3 lines
Diff to previous 1.5 (colored)

Use AMANDA_GROUP?= instead of AMANDA_GROUP=, so you can overwrite the
default amanda group.

Revision 1.5 / (download) - annotate - [select for diffs], Thu Jun 14 21:54:36 2001 UTC (21 years, 7 months ago) by jlam
Branch: MAIN
Changes since 1.4: +12 -10 lines
Diff to previous 1.4 (colored)

- Migrate BUILD_DEFS to Makefile.common
- Apply the patch from pkg/13188 by Ron Roskens <roskens@elfin.net> to
  fix problems with hard-coding /var/amanda.
- Remove USE_X11 from amanda-server since amanda-plot has already been
  split out.
- Don't explicitly look for headers in ${PREFIX}/include.

Revision 1.4 / (download) - annotate - [select for diffs], Fri Sep 15 15:59:33 2000 UTC (22 years, 4 months ago) by skrll
Branch: MAIN
CVS Tags: netbsd-1-5-RELEASE, netbsd-1-5-PATCH001, netbsd-1-4-PATCH003
Changes since 1.3: +2 -1 lines
Diff to previous 1.3 (colored)

Use pkgsrc libtool not internal one.
Remove unnecessary versionsuffix dependency on libamclient.

Revision 1.3 / (download) - annotate - [select for diffs], Thu Aug 17 02:26:29 2000 UTC (22 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

USE_PKGLIBTOOL -> USE_LIBTOOL.
While I'm here, convert it from addnerd to user.

Revision 1.2 / (download) - annotate - [select for diffs], Thu Jun 1 11:23:41 2000 UTC (22 years, 8 months ago) by rh
Branch: MAIN
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

s/USE_LIBTOOL/USE_PKGLIBTOOL/
Add a new USE_LIBTOOL definition that uses the libtool package instead of
pkglibtool which is now considered outdated.
USE_PKGLIBTOOL is available for backwards compatibility with old packages
but is deprecated for new packages.

Revision 1.1 / (download) - annotate - [select for diffs], Mon Sep 6 19:30:20 1999 UTC (23 years, 4 months ago) by bad
Branch: MAIN
CVS Tags: netbsd-1-4-PATCH002, comdex-fall-1999

Split out the common code in the amanda make files into
amanda-common/Makefile.common.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>