[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / shells / zsh

Annotation of pkgsrc/shells/zsh/Makefile.common, Revision 1.37

1.37    ! wiz         1: # $NetBSD: Makefile.common,v 1.36 2006/10/09 12:52:36 joerg Exp $
1.1       uebayasi    2:
1.37    ! wiz         3: DISTNAME=      zsh-${ZSH_VERSION}
1.1       uebayasi    4: CATEGORIES=    shells
1.37    ! wiz         5: MASTER_SITES=  ftp://sunsite.dk/pub/unix/shells/zsh/ \
1.1       uebayasi    6:                ftp://ftp.fu-berlin.de/pub/unix/shells/zsh/ \
                      7:                ftp://ftp.funet.fi/pub/unix/shells/zsh/ \
                      8:                http://www.math.technion.ac.il/pub/zsh/ \
                      9:                ftp://ftp.zsh.org/zsh/
                     10: EXTRACT_SUFX=  .tar.bz2
                     11:
                     12: MAINTAINER=    ${ZSH_MAINTAINER}
1.35      wiz        13: HOMEPAGE=      http://zsh.dotsrc.org/
1.1       uebayasi   14: COMMENT=       The Z shell
                     15:
1.36      joerg      16: PKG_DESTDIR_SUPPORT=   user-destdir
                     17:
1.22      adam       18: GNU_CONFIGURE=         yes
1.2       grant      19:
1.31      rillig     20: CONFIGURE_ARGS+=       --enable-etcdir=${PKG_SYSCONFDIR:Q}
1.30      uebayasi   21:
1.33      jlam       22: USE_TOOLS+=            makeinfo
1.34      jlam       23: INFO_FILES=            # PLIST
1.18      taca       24: TEXINFO_REQD=          4.0
1.1       uebayasi   25:
1.11      cube       26: PKG_INSTALLATION_TYPES=        overwrite pkgviews
                     27:
1.1       uebayasi   28: .include "../../mk/bsd.prefs.mk"
                     29:
1.12      salo       30: BUILD_DEFS+=   ZSH_STATIC
                     31:
                     32: .if defined(ZSH_STATIC) && !empty(ZSH_STATIC:M[Yy][Ee][Ss])
1.16      tron       33: CONFIGURE_ARGS+=       --disable-dynamic
1.14      tron       34:
1.15      tron       35: NETBSD_SHLINKER=       /libexec/ld.elf_so
1.16      tron       36: NETBSD_SHLIBDIR=       /lib
1.15      tron       37:
1.16      tron       38: .  if ${OPSYS} == "NetBSD" && ${OBJECT_FMT} == "ELF" && \
1.15      tron       39:       defined(MKDYNAMICROOT) && !empty(MKDYNAMICROOT:M[Yy][Ee][Ss]) && \
1.16      tron       40:       exists(${NETBSD_SHLINKER}) && exists(${NETBSD_SHLIBDIR})
1.15      tron       41: #
                     42: # Built a dynamically linked "zsh" binary on NetBSD systems which use
                     43: # dynamically linked binaries on the root filesystem. The binary will
                     44: # only depend on the run-time link-editor and shared libraries on the
                     45: # root filesystem. We use "-rpath" below by purpose because the
                     46: # buildlink 3 framework won't filter it out.
                     47: #
1.16      tron       48: BUILDLINK_PASSTHRU_RPATHDIRS+= ${NETBSD_SHLIBDIR}
                     49:
                     50: LDFLAGS+=      -Wl,-dynamic-linker=${NETBSD_SHLINKER} -Wl,-R${NETBSD_SHLIBDIR}
1.15      tron       51: .  else
1.1       uebayasi   52: LDFLAGS+=      -static
1.14      tron       53: .  endif
1.1       uebayasi   54: .else
1.2       grant      55: .  if ${OPSYS} == "SunOS"
1.1       uebayasi   56: PLIST_SRC=     ${PKGDIR}/PLIST.dynamic ${PKGDIR}/PLIST
1.2       grant      57: .  else
1.17      jlam       58: LDFLAGS+=      ${COMPILER_RPATH_FLAG}${PREFIX}/lib/zsh
1.26      hiramats   59:
                     60: .    if ${OPSYS} == "Linux" || ${OPSYS} == "IRIX" || ${OPSYS} == "OpenBSD"
1.37    ! wiz        61: PLIST_SRC+=    ${PKGDIR}/PLIST.terminfo
1.27      joerg      62: .    elif ${OPSYS} == "Interix" || ${OPSYS} == "DragonFly"
1.37    ! wiz        63: PLIST_SRC+=    ${PKGDIR}/PLIST.terminfo ${PKGDIR}/PLIST.shlibs
1.20      tv         64: .    else
1.37    ! wiz        65: PLIST_SRC+=    ${PKGDIR}/PLIST.shlibs
1.21      jschauma   66: .    endif
1.26      hiramats   67:
1.21      jschauma   68: PLIST_SRC+=    ${PKGDIR}/PLIST.dynamic ${PKGDIR}/PLIST
1.2       grant      69: .  endif
1.1       uebayasi   70: .endif
                     71:
1.19      uebayasi   72: .if ${OPSYS} == "Interix"
1.20      tv         73: CONFIGURE_ARGS+=--without-tcsetpgrp
1.21      jschauma   74: .elif ${OPSYS} == "IRIX"
                     75: CONFIGURE_ARGS+=--with-tcsetpgrp
1.19      uebayasi   76: .endif
                     77:
1.1       uebayasi   78: .undef MANZ
                     79:
1.25      jlam       80: PKG_SHELL=     bin/zsh
1.1       uebayasi   81:
1.3       seb        82: INSTALL_TARGET=        install install.info
                     83:
1.27      joerg      84: pre-install:
1.28      rillig     85:        @cd ${WRKSRC}/Completion; ${FIND} . -name \*.orig -exec ${RM} \{\} \;
1.27      joerg      86:
1.1       uebayasi   87: post-install:
1.36      joerg      88:        ${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/zsh
                     89:        cd ${WRKSRC}/Etc && ${INSTALL_DATA} BUGS FAQ    \
                     90:                ${DESTDIR}${PREFIX}/share/doc/zsh
                     91:        cd ${WRKSRC} && ${INSTALL_DATA} FEATURES NEWS   \
                     92:                ${DESTDIR}${PREFIX}/share/doc/zsh
1.1       uebayasi   93:
                     94: # Utilize Zsh's test framework.
1.8       recht      95: # Testing of dynamic shell only works after install has been done
1.1       uebayasi   96: #
                     97: .PHONY: do-test do-su-test real-su-test
                     98:
                     99: do-test: do-su-test
                    100:
                    101: do-su-test:
                    102:        @${_PKG_SILENT}${_PKG_DEBUG}                                    \
                    103:        ${ECHO_MSG} "*** Warning: This test needs to be run as root"
                    104:        @${_PKG_SILENT}${_PKG_DEBUG}                                    \
                    105:        realtarget="real-su-test";                                      \
                    106:        action="install";                                               \
                    107:        ${_SU_TARGET}
                    108:
                    109: real-su-test:
                    110:        @${_PKG_SILENT}${_PKG_DEBUG}                                    \
                    111:        ${ECHO_MSG} "${_PKGSRC_IN}> Testing for ${PKGNAME}"
                    112:        @cd ${WRKSRC} && ${MAKE} check
                    113:        @cd ${WRKSRC}/Test && ${MAKE} clean

CVSweb <webmaster@jp.NetBSD.org>