[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / shells / zsh

Annotation of pkgsrc/shells/zsh/Makefile.common, Revision 1.20

1.20    ! tv          1: # $NetBSD: Makefile.common,v 1.19 2005/01/18 12:44:53 uebayasi Exp $
1.1       uebayasi    2:
                      3: DISTNAME=       zsh-${ZSH_VERSION}
                      4: CATEGORIES=    shells
                      5: MASTER_SITES=   ftp://sunsite.dk/pub/unix/shells/zsh/ \
                      6:                ftp://ftp.fu-berlin.de/pub/unix/shells/zsh/ \
                      7:                ftp://ftp.lysator.liu.se/pub/unix/zsh/ \
                      8:                ftp://ftp.funet.fi/pub/unix/shells/zsh/ \
                      9:                http://www.math.technion.ac.il/pub/zsh/ \
                     10:                ftp://ftp.zsh.org/zsh/
                     11: EXTRACT_SUFX=  .tar.bz2
                     12:
                     13: MAINTAINER=    ${ZSH_MAINTAINER}
                     14: HOMEPAGE=      http://sunsite.dk/zsh/
                     15: COMMENT=       The Z shell
                     16:
1.10      snj        17: USE_BUILDLINK3=                YES
1.2       grant      18: USE_PKGINSTALL=                YES
                     19: GNU_CONFIGURE=         YES
                     20:
1.3       seb        21: USE_MAKEINFO=          YES
1.1       uebayasi   22: INFO_FILES=            zsh.info
1.18      taca       23: TEXINFO_REQD=          4.0
1.1       uebayasi   24:
1.11      cube       25: PKG_INSTALLATION_TYPES=        overwrite pkgviews
                     26:
1.1       uebayasi   27: .include "../../mk/bsd.prefs.mk"
                     28:
1.12      salo       29: BUILD_DEFS+=   ZSH_STATIC
                     30:
                     31: .if defined(ZSH_STATIC) && !empty(ZSH_STATIC:M[Yy][Ee][Ss])
1.16      tron       32: CONFIGURE_ARGS+=       --disable-dynamic
1.14      tron       33:
1.15      tron       34: NETBSD_SHLINKER=       /libexec/ld.elf_so
1.16      tron       35: NETBSD_SHLIBDIR=       /lib
1.15      tron       36:
1.16      tron       37: .  if ${OPSYS} == "NetBSD" && ${OBJECT_FMT} == "ELF" && \
1.15      tron       38:       defined(MKDYNAMICROOT) && !empty(MKDYNAMICROOT:M[Yy][Ee][Ss]) && \
1.16      tron       39:       exists(${NETBSD_SHLINKER}) && exists(${NETBSD_SHLIBDIR})
1.15      tron       40: #
                     41: # Built a dynamically linked "zsh" binary on NetBSD systems which use
                     42: # dynamically linked binaries on the root filesystem. The binary will
                     43: # only depend on the run-time link-editor and shared libraries on the
                     44: # root filesystem. We use "-rpath" below by purpose because the
                     45: # buildlink 3 framework won't filter it out.
                     46: #
1.16      tron       47: BUILDLINK_PASSTHRU_RPATHDIRS+= ${NETBSD_SHLIBDIR}
                     48:
                     49: LDFLAGS+=      -Wl,-dynamic-linker=${NETBSD_SHLINKER} -Wl,-R${NETBSD_SHLIBDIR}
1.15      tron       50: .  else
1.1       uebayasi   51: LDFLAGS+=      -static
1.14      tron       52: .  endif
1.1       uebayasi   53: .else
1.2       grant      54: .  if ${OPSYS} == "SunOS"
1.1       uebayasi   55: PLIST_SRC=     ${PKGDIR}/PLIST.dynamic ${PKGDIR}/PLIST
1.2       grant      56: .  else
1.17      jlam       57: LDFLAGS+=      ${COMPILER_RPATH_FLAG}${PREFIX}/lib/zsh
1.20    ! tv         58: .    if exists(${PKGDIR}/PLIST.${OPSYS})
        !            59: PLIST_SRC=     ${PKGDIR}/PLIST.${OPSYS}
        !            60: .    else
        !            61: PLIST_SRC=     # empty
        !            62: .    endif
        !            63: PLIST_SRC+=    ${PKGDIR}/PLIST.shlibs ${PKGDIR}/PLIST.dynamic ${PKGDIR}/PLIST
1.2       grant      64: .  endif
1.1       uebayasi   65: .endif
                     66:
1.19      uebayasi   67: .if ${OPSYS} == "Interix"
1.20    ! tv         68: CONFIGURE_ARGS+=--without-tcsetpgrp
1.19      uebayasi   69: .endif
                     70:
1.1       uebayasi   71: .undef MANZ
                     72:
                     73: PKG_SHELL=     ${PREFIX}/bin/zsh
                     74:
1.3       seb        75: INSTALL_TARGET=        install install.info
                     76:
1.1       uebayasi   77: post-install:
                     78:        @${INSTALL_DATA_DIR} ${PREFIX}/share/doc/zsh
1.13      recht      79:        @cd ${WRKSRC}/Etc; ${INSTALL_DATA} BUGS FAQ     \
                     80:                ${PREFIX}/share/doc/zsh
                     81:        @cd ${WRKSRC}; ${INSTALL_DATA} FEATURES NEWS    \
1.1       uebayasi   82:                ${PREFIX}/share/doc/zsh
                     83:
                     84: # Utilize Zsh's test framework.
1.8       recht      85: # Testing of dynamic shell only works after install has been done
1.1       uebayasi   86: #
                     87: .PHONY: do-test do-su-test real-su-test
                     88:
                     89: do-test: do-su-test
                     90:
                     91: do-su-test:
                     92:        @${_PKG_SILENT}${_PKG_DEBUG}                                    \
                     93:        ${ECHO_MSG} "*** Warning: This test needs to be run as root"
                     94:        @${_PKG_SILENT}${_PKG_DEBUG}                                    \
                     95:        realtarget="real-su-test";                                      \
                     96:        action="install";                                               \
                     97:        ${_SU_TARGET}
                     98:
                     99: real-su-test:
                    100:        @${_PKG_SILENT}${_PKG_DEBUG}                                    \
                    101:        ${ECHO_MSG} "${_PKGSRC_IN}> Testing for ${PKGNAME}"
                    102:        @cd ${WRKSRC} && ${MAKE} check
                    103:        @cd ${WRKSRC}/Test && ${MAKE} clean

CVSweb <webmaster@jp.NetBSD.org>