[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / shells / standalone-tcsh

File: [cvs.NetBSD.org] / pkgsrc / shells / standalone-tcsh / Makefile (download)

Revision 1.38, Thu Dec 9 19:55:39 2021 UTC (2 years, 3 months ago) by kim
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.37: +1 -2 lines

{,standalone-,static-}tcsh: Update to 6.23.01

Changes since 6.23.00:

  8. V6.23.01 - 20211209
  7. add \cc and \Uhhh, and document escape sequences
  6. add $'string with escapes' ("dollar-single-quotes") (Kimmo Suominen)
  5. don't glob the filetest builtin arguments twice
  4. remove the duplicate echo escape parsing code and use parseescape
  3. add \x{hh} \xhh \uhhh (H.Merijn Brand)
  2. fix and document ln=target
  1. Merge in patches from pkgsrc:
     - Modernize the installation targets so that they use INSTALL_DATA,
       INSTALL_PROGRAM, and MKDIR_P.
     - Enable SYSMALLOC and SHORT_STRINGS on NetBSD.
     - Enable NO_FIX_MALLOC and SHORT_STRINGS on OpenBSD.

For pkgsrc, items 1, 2, and 5 had already been applied via patches.

# $NetBSD: Makefile,v 1.38 2021/12/09 19:55:39 kim Exp $
#

# FIXME: This is because of PREFIX=/ below.
CHECK_FILES_SUPPORTED=	no
NOT_FOR_UNPRIVILEGED=	yes

PKGNAME=		standalone-${DISTNAME}

PATCHDIR=		../../shells/tcsh/patches
PKGDIR=			../../shells/tcsh
DESCR_SRC=		../../shells/tcsh/DESCR DESCR

# This package only makes sense on platforms that don't themselves ship tcsh
# in /bin. Otherwise it clobbers the native copy, which really isn't what
# anyone wants.
ONLY_FOR_PLATFORM+=	NetBSD-*-* OpenBSD-*-* SunOS-*-*

.include "../../mk/bsd.prefs.mk"

.if ${OS_VARIANT} == "OmniOS"
NOT_FOR_PLATFORM+=	SunOS-*-*
.endif

.include "../../shells/tcsh/Makefile.common"
.include "../../mk/bsd.pkg.mk"

COMMENT:=		Standalone version of the Extended C-shell
MAINTAINER=		agc@NetBSD.org

# FIXME: Packages shall only install into ${LOCALBASE} or a subdirectory.
PREFIX=			/
PKGMANDIR=		usr/share/man
EGDIR=			usr/share/examples/tcsh
NLSDIR=			usr/share/nls
NOT_FOR_BULK_PLATFORM=	*-*-*

CONFIGURE_ARGS+=	--prefix=${PREFIX:Q}
CONFIGURE_ARGS+=	--bindir=${PREFIX:S/\/$//:Q}/bin
CONFIGURE_ARGS+=	--localedir=${PREFIX:S/\/$//:Q}/${NLSDIR}
CONFIGURE_ARGS+=	--mandir=${PREFIX:S/\/$//:Q}/${PKGMANDIR}

PLIST_AWK+=		-f ${.CURDIR}/plist-examples.awk
PLIST_AWK_ENV+=		EGDIR=${EGDIR}

PLIST_AWK+=		-f ${.CURDIR}/plist-nls.awk
PLIST_AWK_ENV+=		NLSDIR=${NLSDIR}