Up to [cvs.NetBSD.org] / pkgsrc / shells / shellcheck
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
recursive revbump after patching lang/ghc910
Bump all Haskell packages after switching the default compiler.
shells/shellcheck: Fix build with GHC 9.10
Recursive revbump after changing the default Haskell compiler
shells/shellcheck: Fix build with GHC 9.8 This breaks build with the currently default GHC 9.6. Please bear with me until I switch the default compiler.
shellcheck: update to version 0.10.0 Changelog: ## v0.10.0 - 2024-03-07 ### Added - Precompiled binaries for macOS ARM64 (darwin.aarch64) - Added support for busybox sh - Added flag --rcfile to specify an rc file by name. - Added `extended-analysis=true` directive to enable/disable dataflow analysis (with a corresponding --extended-analysis flag). - SC2324: Warn when x+=1 appends instead of increments - SC2325: Warn about multiple `!`s in dash/sh. - SC2326: Warn about `foo | ! bar` in bash/dash/sh. - SC3012: Warn about lexicographic-compare bashism in test like in [ ] - SC3013: Warn bashism `test _ -op/-nt/-ef _` like in [ ] - SC3014: Warn bashism `test _ == _` like in [ ] - SC3015: Warn bashism `test _ =~ _` like in [ ] - SC3016: Warn bashism `test -v _` like in [ ] - SC3017: Warn bashism `test -a _` like in [ ] ### Fixed - source statements with here docs now work correctly - "(Array.!): undefined array element" error should no longer occur
Revbump all Haskell after updating lang/ghc96
shells/shellcheck: Fix build with GHC 9.6
Bump Haskell packages after updating lang/ghc94
revbump all the Haskell packages after modifying the runtime system of lang/ghc94
shellcheck: update to version 0.9.0 ChangeLog: v0.9.0 - 2022-12-12 Added SC2316: Warn about 'local readonly foo' and similar (thanks, patrickxia!) SC2317: Warn about unreachable commands SC2318: Warn about backreferences in 'declare x=1 y=$x' SC2319/SC2320: Warn when $? refers to echo/printf/[ ]/[[ ]]/test SC2321: Suggest removing ((..))inarray[((idx))]=val SC2322: Suggest collapsing double parentheses in arithmetic contexts SC2323: Suggest removing wrapping parentheses in a[(x+1)]=val Fixed SC2086: Now uses DFA to make more accurate predictions about values SC2086: No longer warns about values declared as integer with declare -i Changed ShellCheck now has a Data Flow Analysis engine to make smarter decisions based on control flow rather than just syntax. Existing checks will gradually start using it, which may cause them to trigger differently (but more accurately). Values in directives/shellcheckrc can now be quoted with '' or ""
hs*: recursive bump for new dependencies needed for hs-aeson, hs-vector
Bump all Haskell packages after enabling "split sections" in mk/haskell.mk
revbump after changing the default Haskell compiler
Update to shellcheck-0.8.0 v0.8.0 - 2021-11-06 Added * disable=all now conveniently disables all warnings * external-sources=true directive can be added to .shellcheckrc to make shellcheck behave as if -x was specified. * Optional check-extra-masked-returns for pointing out commands with suppressed exit codes (SC2312). * Optional require-double-brackets for recommending [[ ]] (SC2292). * SC2286-SC2288: Warn when command name ends in a symbol like /.)'" * SC2289: Warn when command name contains tabs or linefeeds * SC2291: Warn about repeated unquoted spaces between words in echo * SC2292: Suggest [[ over [ in Bash/Ksh scripts (optional) * SC2293/SC2294: Warn when calling eval with arrays * SC2295: Warn about "\({x#\)y}" treating $y as a pattern when not quoted * SC2296-SC2301: Improved warnings for bad parameter expansions * SC2302/SC2303: Warn about loops over array values when using them as keys * SC2304-SC2306: Warn about unquoted globs in expr arguments * SC2307: Warn about insufficient number of arguments to expr * SC2308: Suggest other approaches for non-standard expr extensions * SC2313: Warn about read with unquoted, array indexed variable Fixed * SC2102 about repetitions in ranges no longer triggers on [[ -v arr[xx] ]] * SC2155 now recognizes typeset and local read-only declare statements * SC2181 now tries to avoid triggering for error handling functions * SC2290: Warn about misused = in declare & co, which were not caught by SC2270+ * The flag --color=auto no longer outputs color when TERM is "dumb" or unset Changed * SC2048: Warning about $* now also applies to ${array[*]} * SC2181 now only triggers on single condition tests like [ $? = 0 ]. * Quote warnings are now emitted for declaration utilities in sh * Leading _ can now be used to suppress warnings about unused variables * TTY output now includes warning level in text as well as color Removed * SC1004: Literal backslash+linefeed in '' was found to be usually correct
Bump packages that depends on GHC
*: Bump PKGREVISION for ghc-9.0.1
Update to ShellCheck-0.7.2 No change logs are provided by the upstream.
shellcheck: add $HOMEPAGE
shellcheck: Import version 0.7.1. ShellCheck is a GPLv3 tool that gives warnings and suggestions for bash/sh shell scripts. The goals of ShellCheck are: * To point out and clarify typical beginner's syntax issues that cause a shell to give cryptic error messages. * To point out and clarify typical intermediate level semantic problems that cause a shell to behave strangely and counter-intuitively. * To point out subtle caveats, corner cases and pitfalls that may cause an advanced user's otherwise working script to fail under future circumstances.