The NetBSD Project

CVS log for pkgsrc/shells/pdksh/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / shells / pdksh

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.27 / (download) - annotate - [select for diffs], Mon Oct 26 10:10:54 2020 UTC (3 years, 4 months ago) by schmonz
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, HEAD
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

Use archive.org for HOMEPAGE.

Revision 1.26 / (download) - annotate - [select for diffs], Sat Apr 21 13:38:07 2018 UTC (5 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.25: +1 -3 lines
Diff to previous 1.25 (colored)

*: gd.tuwien.ac.at/ftp.tuwien.ac.at is gone, remove it from various mastersites

Revision 1.25 / (download) - annotate - [select for diffs], Thu Jan 19 18:52:25 2017 UTC (7 years, 1 month ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.24: +5 -5 lines
Diff to previous 1.24 (colored)

Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

Revision 1.24 / (download) - annotate - [select for diffs], Sun Jun 5 04:44:56 2016 UTC (7 years, 9 months ago) by richard
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

PR/51142: address for/select loop compatibility with ksh93 in pdksh

Revision 1.23 / (download) - annotate - [select for diffs], Mon Sep 7 06:43:48 2015 UTC (8 years, 6 months ago) by dsainty
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

On Linux, Bash is fine if you don't mind your package builds spending 50% of
their time compiling, and 50% spinning in shell scripts.  If you'd rather
spend your power bill on useful gcc cycles though, you might desire to use a
different shell for running build scripts - like pdksh, which is conveniently
available at bootstrap time.

But what if pdksh does this to you?

pdksh -c 'f=`pdksh -c set | wc -l`; f=$((f+1)); while ((f < 100000)); do f=$((f+1)); eval "v_${f}=0"; echo "$f"; done'|tail -1
 13106
segmentation fault (core dumped)  pdksh -c

Well that's annoying, isn't it.

% echo $(((13106*10+7)/8))
16383

... that's a magical number.  Coincidence?  Well, no.

tp->nfree = 8*nsize/10; /* table can get 80% full */

This particularly ugly overflow happens because tp->size is a short.  When
texpand() does:

  p = &ntblp[hash(tblp->name) & (tp->size-1)];

tp->size-1 will, given enough variables (80% of 2^15), type coerce into a
sign-extended 32-bit value of:

info registers $ecx
ecx            0xffff7fff       -32769

That hash() function does more or less what you guess, it's a 32 bit unsigned
value.  The chances of the final pointer pointing inside the valid allocated
block of memory are very low indeed.

The least-change solution is to change tp->size to a 32 bit value.  I've left
it signed because that matches, for example, the size parameter passed to
texpand().  But really this code would be more correct with a liberal
sprinkling of "unsigned", and perhaps a bit of "size_t".

This change allows ffmpeg's configure script, as interpreted by pdksh, to
produce more usable output than a core file.

Bump PKGREVISION for code change.

Revision 1.22 / (download) - annotate - [select for diffs], Thu Oct 9 14:06:56 2014 UTC (9 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.21: +1 -2 lines
Diff to previous 1.21 (colored)

Remove pkgviews: don't set PKG_INSTALLATION_TYPES in Makefiles.

Revision 1.21 / (download) - annotate - [select for diffs], Tue Sep 11 23:25:09 2012 UTC (11 years, 6 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.20: +1 -2 lines
Diff to previous 1.20 (colored)

"user-destdir" is default these days

Revision 1.20 / (download) - annotate - [select for diffs], Fri May 7 12:02:44 2010 UTC (13 years, 10 months ago) by jmmv
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Bump PKGREVISION to reflect the recent change in pkginstall/shells to use
etcutils to update /etc/shells.

Revision 1.19 / (download) - annotate - [select for diffs], Thu Apr 9 00:48:15 2009 UTC (14 years, 11 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.18: +1 -2 lines
Diff to previous 1.18 (colored)

Remove redundant NO_CHECKSUM and EXTRACT_ONLY definitions.

Revision 1.17.10.1 / (download) - annotate - [select for diffs], Mon Feb 23 13:18:56 2009 UTC (15 years ago) by tron
Branch: pkgsrc-2008Q4
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored) next main 1.18 (colored)

Pullup ticket #2706 - requested by adrianp
pdksh: bug fix

Revisions pulled up:
- shells/pdksh/Makefile				1.18
- shells/pdksh/files/c_ulimit.c			1.4
- shells/pdksh/files/lex.c			1.4
---
Module Name:	pkgsrc
Committed By:	tnn
Date:		Sat Feb 21 20:06:30 UTC 2009

Modified Files:
	pkgsrc/shells/pdksh: Makefile
	pkgsrc/shells/pdksh/files: c_ulimit.c lex.c

Log Message:
Merge the following revisions from NetBSD src:
c_ulimit.c 1.9: avoid sign extension problem
lex.c 1.13: bugfix related to nested quotes
Bump PKGREVISION.

Revision 1.18 / (download) - annotate - [select for diffs], Sat Feb 21 20:06:30 2009 UTC (15 years ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2009Q1-base, pkgsrc-2009Q1
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

Merge the following revisions from NetBSD src:
c_ulimit.c 1.9: avoid sign extension problem
lex.c 1.13: bugfix related to nested quotes
Bump PKGREVISION.

Revision 1.17 / (download) - annotate - [select for diffs], Thu Jun 19 18:36:51 2008 UTC (15 years, 9 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q4-base, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Branch point for: pkgsrc-2008Q4
Changes since 1.16: +2 -1 lines
Diff to previous 1.16 (colored)

Add a marker for bootstrap packages to allow special cases them during
bulk builds.

Revision 1.16 / (download) - annotate - [select for diffs], Sat May 31 16:51:10 2008 UTC (15 years, 9 months ago) by tnn
Branch: MAIN
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Bump the PKGREVISION for NetBSD-current bugfix merge.

Revision 1.15 / (download) - annotate - [select for diffs], Fri May 23 17:27:09 2008 UTC (15 years, 9 months ago) by tnn
Branch: MAIN
Changes since 1.14: +14 -2 lines
Diff to previous 1.14 (colored)

- Adapt to use local distribution.
- Add DESTDIR support.

Revision 1.14 / (download) - annotate - [select for diffs], Sun Dec 2 12:29:02 2007 UTC (16 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4
Changes since 1.13: +2 -3 lines
Diff to previous 1.13 (colored)

Remove Ex-MASTER_SITE. From Zafer Aydogan.

Revision 1.13 / (download) - annotate - [select for diffs], Mon Nov 12 20:05:38 2007 UTC (16 years, 4 months ago) by heinz
Branch: MAIN
Changes since 1.12: +1 -2 lines
Diff to previous 1.12 (colored)

Removed ftp.rge.com from MASTER_SITES, doesn't resolve anymore
in DNS. Mentioned by Zafer Aydogan in PR pkg/37321.

Revision 1.12 / (download) - annotate - [select for diffs], Thu Dec 29 06:22:12 2005 UTC (18 years, 2 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.11: +1 -2 lines
Diff to previous 1.11 (colored)

Remove USE_PKGINSTALL from pkgsrc now that mk/install/pkginstall.mk
automatically detects whether we want the pkginstall machinery to be
used by the package Makefile.

Revision 1.11 / (download) - annotate - [select for diffs], Sun Oct 23 15:26:30 2005 UTC (18 years, 4 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.10: +3 -3 lines
Diff to previous 1.10 (colored)

Fixed pkglint warning.

Revision 1.10 / (download) - annotate - [select for diffs], Tue Sep 20 04:23:49 2005 UTC (18 years, 6 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Teach the +SHELLS helper script to not create an /etc/shells file if
one doesn't exist.  From now on, we only add the listed PKG_SHELL to
the /etc/shells file if it already exists.  This fixes PR pkg/27162.

Revision 1.9 / (download) - annotate - [select for diffs], Fri Jul 29 18:32:18 2005 UTC (18 years, 7 months ago) by jlam
Branch: MAIN
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

* Separate out the shell registration into a separately unpacked script
  +SHELL.

* Turn PKG_REGISTER_SHELLS into a variable that can be set in the shell
  environment so that admins can make a choice when installing from
  binary packages.

* PKG_SHELL is now a list of paths, and if the path is relative, then it
  is taken to be relative to ${PREFIX}.  Convert packages that set
  PKG_SHELL to take advantage of this new feature by changing the full
  paths to the shells into relative paths.

Revision 1.8 / (download) - annotate - [select for diffs], Mon Apr 11 21:47:21 2005 UTC (18 years, 11 months ago) by tv
Branch: MAIN
CVS Tags: pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.7: +1 -2 lines
Diff to previous 1.7 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.7 / (download) - annotate - [select for diffs], Mon Jan 5 12:36:41 2004 UTC (20 years, 2 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1, pkgsrc-2004Q4-base, pkgsrc-2004Q4, pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2, pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.6: +4 -2 lines
Diff to previous 1.6 (colored)

bl3ify

Revision 1.6 / (download) - annotate - [select for diffs], Sat Oct 4 10:23:16 2003 UTC (20 years, 5 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.5: +2 -6 lines
Diff to previous 1.5 (colored)

pdksh is no longer used to bootstrap buildlink2.

Revision 1.5 / (download) - annotate - [select for diffs], Thu Jul 17 22:53:23 2003 UTC (20 years, 8 months ago) by grant
Branch: MAIN
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

s/netbsd.org/NetBSD.org/

Revision 1.4 / (download) - annotate - [select for diffs], Wed Jul 16 14:10:11 2003 UTC (20 years, 8 months ago) by jmmv
Branch: MAIN
Changes since 1.3: +7 -2 lines
Diff to previous 1.3 (colored)

Add several mirrors to MASTER_SITES.

Revision 1.3 / (download) - annotate - [select for diffs], Tue Jan 28 22:04:12 2003 UTC (21 years, 1 month ago) by jlam
Branch: MAIN
CVS Tags: netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Instead of including bsd.pkg.install.mk directly in a package Makefile,
have it be automatically included by bsd.pkg.mk if USE_PKGINSTALL is set
to "YES".  This enforces the requirement that bsd.pkg.install.mk be
included at the end of a package Makefile.  Idea suggested by Julio M.
Merino Vidal <jmmv at menta.net>.

Revision 1.2 / (download) - annotate - [select for diffs], Thu Nov 28 07:42:05 2002 UTC (21 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.1: +10 -4 lines
Diff to previous 1.1 (colored)

Bump PKGREVISION of shells/pdksh to 1: rename installed shell to "pdksh",
as this isn't really the real Korn shell, and "pdksh" is a more accurate
name for it.  Also don't use buildlink2 so that this shell may be used to
bootstrap buildlink2.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Thu Nov 28 07:12:09 2002 UTC (21 years, 3 months ago) by schmonz
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Import pdksh-5.2.14 into the NetBSD Packages Collection.

PD-ksh is a mostly complete AT&T ksh look-alike.  Work is mostly
finished to make it fully compatible with both POSIX and AT&T ksh
(when the two don't conflict). Since pdksh is free and compiles
and runs on most common unix systems, it is very useful in creating
a consistent user interface across multiple machines.

Revision 1.1 / (download) - annotate - [select for diffs], Thu Nov 28 07:12:09 2002 UTC (21 years, 3 months ago) by schmonz
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>