[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / shells / nushell

File: [cvs.NetBSD.org] / pkgsrc / shells / nushell / Makefile (download)

Revision 1.10, Thu Oct 7 11:48:48 2021 UTC (2 years, 6 months ago) by pin
Branch: MAIN
Changes since 1.9: +6 -4 lines

shells/nushell: update to 0.38.0

Today, we're releasing 0.38 of Nu. This release includes polish to the user
interface, improvements to how columns are passed, lots of bug fixes, and
updates on the upcoming engine.

What's New
-Quickly jump to a shell (tw4452852)
If you've used shells, you've no doubt used the n and p commands to quickly jump
between them. This can be a big time saver when you're working in multiple
directories.

In this release, we've added a g command that helps you quickly jump to a
particular shell. This helps in the cases where you end up with more than two
shells open and you already know what shell you want to jump to.

Additional improvements
-Improvements in updated table cell values
-update cells command now can take a list of columns
-You can now also pass a list of columns to select
-Improvements in how html table scraping works and also
-Fix to compiling on nightly
-Removed unused deps
-Completions now can complete inside of an argument
-We now expand tilde when reading plugin directories
-We also turn off ansi colors when not in a TTY
-Fixed some of the wasm deps
-Fixed a leak of a let-binding
-Use SIMD-enabled compiler flags
-Updated polars dependency to 0.16
-Updates to how path join works
-Moved nu-path tests into integration tests
-New support for converting to column paths
-Cleanup fixes to make tests more resilient
-Internal improvement to make working with spans easier
-Fix to gitpod
-Fix to big int handling in to
-Fixed a typo
-Fixed some typos in the tutor
-Removed the experimental scrolling support as it had broken

# $NetBSD: Makefile,v 1.10 2021/10/07 11:48:48 pin Exp $

DISTNAME=	nushell-0.38.0
CATEGORIES=	shells
MASTER_SITES=	${MASTER_SITE_GITHUB:=nushell/}

MAINTAINER=	pin@NetBSD.org
HOMEPAGE=	https://www.nushell.sh/
COMMENT=	New type of shell
LICENSE=	mit

# sys-info crate doesn't currently build on 32bit cpus
# see, https://github.com/FillZpp/sys-info-rs/issues/80
ONLY_FOR_PLATFORM=	*-*-x86_64

.include "cargo-depends.mk"

USE_TOOLS+=	pkg-config

INSTALLATION_DIRS=	bin

MAKE_ENV+=	OPENSSL_DIR=${BUILDLINK_PREFIX.openssl:Q}
RUSTFLAGS+=	-C link-arg=${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.openssl}/lib
RUSTFLAGS+=	-C link-arg=${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.libX11}/lib
RUSTFLAGS+=	-C link-arg=-L${BUILDLINK_PREFIX.libX11}/lib

CARGO_NO_DEFAULT_FEATURES=	YES
CARGO_FEATURES+=		default tree inc textview

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/target/release/nu ${DESTDIR}${PREFIX}/bin
	${INSTALL_PROGRAM} ${WRKSRC}/target/release/nu_plugin_core_inc ${DESTDIR}${PREFIX}/bin
	${INSTALL_PROGRAM} ${WRKSRC}/target/release/nu_plugin_core_match ${DESTDIR}${PREFIX}/bin
	${INSTALL_PROGRAM} ${WRKSRC}/target/release/nu_plugin_core_textview ${DESTDIR}${PREFIX}/bin

.include "../../lang/rust/cargo.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"