File:  [cvs.NetBSD.org] / pkgsrc / shells / etsh / Makefile
Revision 1.1: download - view: text, annotated - select for diffs
Mon Jul 4 08:31:43 2022 UTC (2 years, 9 months ago) by pin
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, HEAD
shells/etsh: import package

Packaged in wip by Paolo Vincenzo Olivo.

Etsh provides two ports of the original /bin/sh from Version 6 (V6) UNIX
(circa 1975).

Etsh(1) is an enhanced, backward-compatible port of the V6 Thompson shell.
Tsh(1) is an unenhanced port of the shell, and glob(1) is a port of its
global command.  Together, tsh and glob provide a user interface which
is backward compatible with that provided by the V6 Thompson shell and
global command, but without the obvious enhancements found in etsh.

The original Thompson shell was principally written by Ken Thompson
of Bell Labs.

This package also includes the following shell utilities:

- if(1) - conditional command (ported from V6 UNIX)
- goto(1) - transfer command (ported from V6 UNIX)
- fd2(1) - redirect from/to file descriptor 2

# $NetBSD: Makefile,v 1.1 2022/07/04 08:31:43 pin Exp $

DISTNAME=	etsh-5.4.0
CATEGORIES=	shells
MASTER_SITES=	https://etsh.nl/src/etsh_5.4.0/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	vms@retrobsd.ddns.net
HOMEPAGE=	https://etsh.nl/
COMMENT=	Enhanced port of Thompson shell from V6 UNIX
LICENSE=	original-bsd AND modified-bsd AND 2-clause-bsd

HAS_CONFIGURE=	yes

PKG_SHELL=	bin/etsh

EXPDIR:=	${PREFIX}/share/examples/etsh
DOCDIR:=	${PREFIX}/share/doc/etsh

MAKEFLAGS+=	PREFIX=${PREFIX}
MAKEFLAGS+=	DESTDOCDIR=${DESTDIR}${DOCDIR}
MAKEFLAGS+=	DESTEXPDIR=${DESTDIR}${EXPDIR}
MAKEFLAGS+=	MANGRP:='' BINGRP:=''

SUBST_CLASSES+=		paths
SUBST_STAGE.paths=	pre-configure
SUBST_FILES.paths+=	libexec.etsh/etshdir
SUBST_FILES.paths+=	libexec.etsh/history
SUBST_FILES.paths+=	libexec.etsh/pev
SUBST_SED.paths=	-e 's|/usr/bin/env |${PREFIX}/bin/|'

post-build:
	cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} exp

post-install:
	cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} install-exp \
	install-doc

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>