[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / tripwire

File: [cvs.NetBSD.org] / pkgsrc / security / tripwire / Makefile (download)

Revision 1.19, Tue Dec 9 15:56:56 2003 UTC (20 years, 3 months ago) by ben
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.18: +2 -2 lines

In include/config.h, uint32 was by default defined as an unsigned long.
However (because of -DTW_TYPE32='int' being added to CFLAGS for an LP64 fix
in revision 1.3 of patches/patch-aa) uint32 is defined as an unsigned int.
This caused two problems:
1) The format string in include/tripwire.h was not updated to match.
2) On NetBSD, off_t is __int64_t.

I am changing the format string in tripwire.h to match uint32.  I also
changed the type of the variable "size" from uint32 to off_t, and changed
its format string to match intmax_t.

This fixes the sparc64 coredump mentioned in PR 19391.

# $NetBSD: Makefile,v 1.19 2003/12/09 15:56:56 ben Exp $
#

DISTNAME=	tripwire-1.2
PKGREVISION=	3
CATEGORIES=	security
MASTER_SITES=	ftp://ftp.fu-berlin.de/unix/security/tripwire/old/

MAINTAINER=	tech-pkg@NetBSD.org
HOMEPAGE=	http://www.cerias.purdue.edu/coast/coast-library.html
COMMENT=	File and directory integrity checker

ONLY_FOR_PLATFORM=	NetBSD-*-* FreeBSD-*-* SunOS-*-*

USE_BUILDLINK2=	YES
USE_PKGINSTALL=	YES

PKG_SYSCONFSUBDIR=	tripwire
OWN_DIRS=		${PKG_SYSCONFDIR}/databases
EGDIR=			${PREFIX}/share/examples/tripwire
CONF_FILES=		${EGDIR}/tripwire.conf ${PKG_SYSCONFDIR}/tripwire.conf

post-extract:
	cd ${WRKDIR} && ${PAX} -O -rf T1.2.tar
	${CP} ${FILESDIR}/conf-${LOWER_OPSYS}.h ${WRKSRC}/configs

pre-configure:
	${MV} ${WRKSRC}/include/config.h ${WRKSRC}/include/config.h.in
	${SED} -e 's|@localbase@|${LOCALBASE}|g'			\
		-e 's|@LOWER_OPSYS@|${LOWER_OPSYS}|g'			\
		-e 's|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g'		\
		${WRKSRC}/include/config.h.in > ${WRKSRC}/include/config.h

PRE_ROOT_CMD=	${CHMOD} -R go+rwx ${WRKDIR}

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/tripwire
	${INSTALL_DATA_DIR} ${EGDIR}
	${INSTALL_DATA} ${WRKSRC}/docs/designdoc.ps ${PREFIX}/share/doc/tripwire
	${SED} -e 's|@localbase@|${LOCALBASE}|g' -e 's|@x11base@|${X11BASE}|g' \
		${FILESDIR}/tw.conf.${LOWER_OPSYS} > ${EGDIR}/tripwire.conf

.include "../../mk/bsd.pkg.mk"