[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / stunnel

File: [cvs.NetBSD.org] / pkgsrc / security / stunnel / Makefile (download)

Revision 1.21, Fri Aug 10 14:41:18 2001 UTC (22 years, 8 months ago) by martin
Branch: MAIN
Changes since 1.20: +2 -2 lines

Update stunnel to version 3.19.
Based on PR pkg/13679 by Martti Kuparinen.

Changelog for version 3.19, 2001.08.10, urgency: MEDIUM:

* Critical section added around non MT-safe TCP Wrappers code.
* Problem with "select: Interrupted system call" error fixed.
* errno replaced with get_last_socket_error() for Win32.
* Some FreeBSD/NetBSD patches to ./configure from Martti Kuparinen.
* Local mode process pid logged.
* Default FQDN (localhost) removed from stunnel.cnf
* ./configure changed to recognize POSIX threads library on OSF.
* New -O option to set socket options.

# $NetBSD: Makefile,v 1.21 2001/08/10 14:41:18 martin Exp $
#

DISTNAME=		stunnel-3.19
CATEGORIES=		security
MASTER_SITES=		ftp://ftp.fu-berlin.de/pub/unix/security/stunnel/ \
			ftp://stunnel.mirt.net/stunnel/ \
			http://www.stunnel.org/download/stunnel/src/

MAINTAINER=		martin@NetBSD.ORG
HOMEPAGE=		http://www.stunnel.org/
COMMENT=		Universal SSL tunnel

BUILD_DEPENDS+=		autoconf-2.13:../../devel/autoconf

USE_BUILDLINK_ONLY=	# defined
USE_SSL=		# defined
GNU_CONFIGURE=		# defined
CONFIGURE_ARGS+=	--with-ssl=${SSLBASE} \
			--with-cert-dir="${SSLCERTS}" \
			--with-pem-dir="${SSLCERTS}" \
			--with-tcp-wrappers

pre-configure:
	cd ${WRKSRC} && ${LOCALBASE}/bin/autoreconf

.include "../../security/openssl/buildlink.mk"
.include "../../mk/bsd.pkg.mk"