[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / ssh

Annotation of pkgsrc/security/ssh/Makefile, Revision 1.87

1.87    ! wiz         1: # $NetBSD: Makefile,v 1.86 2001/02/13 12:49:07 is Exp $
1.1       hubertf     2: # FreeBSD Id: Makefile,v 1.47 1997/11/10 22:04:42 dima Exp
                      3: #
                      4:
1.79      itojun      5: # We do not upgrade to 1.2.28 and beyond, intentionally.  There was license
                      6: # change between 1.2.27 and 1.2.28, and the new license prohibits us from
                      7: # modifying/redistributing it.
                      8: #
1.44      bouyer      9: DISTNAME=              ssh-1.2.27
1.86      is         10: PKGNAME=               ssh-1.2.27nb1
1.13      frueauf    11: CATEGORIES=            security net
                     12: MASTER_SITES=          ftp://ftp.cs.hut.fi/pub/ssh/ \
1.34      kim        13:                        ftp://ftp.funet.fi/pub/unix/security/login/ssh/ \
1.35      kim        14:                        ftp://ftp.cert.dfn.de/pub/tools/net/ssh/
1.60      kim        15: DISTFILES=             ${DISTNAME}${EXTRACT_SUFX}
1.1       hubertf    16:
1.62      tron       17: MAINTAINER=            packages@netbsd.org
1.33      tsarna     18: HOMEPAGE=              http://www.cs.hut.fi/ssh/
1.87    ! wiz        19: COMMENT=               Secure shell client and server (remote login program)
1.73      itojun     20:
1.77      itojun     21: CONFLICTS=             openssh-[0-9]* ssh6-[0-9]*
1.26      tron       22:
1.82      fredb      23: CRYPTO=                        YES
1.48      agc        24: LICENSE=               no-commercial-use
1.84      fredb      25: USE_RSAREF2=           NO
1.11      mrg        26:
1.81      hubertf    27: EXTRACT_ONLY=          ${DISTNAME}${EXTRACT_SUFX}
1.13      frueauf    28: CFLAGS=                        -O2
                     29: GNU_CONFIGURE=         YES
1.11      mrg        30:
1.21      agc        31: .include "../../mk/bsd.prefs.mk"
1.11      mrg        32:
                     33: # Use SSH_CONF_DIR from /etc/mk.conf, if defined; otherwise default to /etc
1.13      frueauf    34: SSH_CONF_DIR?=         /etc
1.1       hubertf    35:
1.78      veego      36: CONFIGURE_ARGS+=       --with-etcdir=${SSH_CONF_DIR}
                     37:
                     38: .if ${OPSYS} == "NetBSD"
                     39: CONFIGURE_ARGS+=       --with-libwrap
                     40: .endif
                     41:
                     42: .if ${OPSYS} == "SunOS"
                     43: DEPENDS+=              zlib-*:../../devel/zlib
                     44: CONFIGURE_ENV+=                X_CFLAGS="-I${LOCALBASE}/include"
                     45: .endif
1.1       hubertf    46:
                     47: #Uncomment if all your users are in their own group and their homedir
                     48: #is writeable by that group.  Beware the security implications!
1.14      tv         49: #CONFIGURE_ARGS+=      --enable-group-writeability
1.1       hubertf    50:
                     51: #Uncomment if you want to allow ssh to emulate an unencrypted rsh connection
                     52: #over a secure medium.  This is normally dangerous since it can lead to the
                     53: #disclosure keys and passwords.
1.13      frueauf    54: #CONFIGURE_ARGS+=      --with-none
1.1       hubertf    55:
1.14      tv         56: .if defined(USE_RSAREF2) && ${USE_RSAREF2} == YES
1.66      jonb       57: DEPENDS+=              rsaref-2.0p3:../../security/rsaref
1.32      tv         58: CONFIGURE_ARGS+=       --with-rsaref="${LOCALBASE}/lib"
                     59: CONFIGURE_ENV+=                LDFLAGS="-Wl,-R${LOCALBASE}/lib"
                     60: CFLAGS+=               -I${LOCALBASE}/include
1.1       hubertf    61: .endif
                     62:
                     63: # Include support for the SecureID card
                     64: # Warning: untested !
                     65: .if defined(USE_SECUREID) && ${USE_SECUREID} == YES
1.13      frueauf    66: CONFIGURE_ARGS+=       --with-secureid
1.64      abs        67: .endif
1.71      wiz        68:
1.64      abs        69: # If rsh is elsewhere to /usr/bin/rsh
                     70: .if defined(SSH_RSHPATH)
                     71: CONFIGURE_ARGS+=       --with-rsh=${SSH_RSHPATH}
1.1       hubertf    72: .endif
                     73:
1.70      jlam       74: # By default, use IDEA.  IDEA can be freely used for non-commercial use.
                     75: # However, commercial use may require a license in a number of countries.
                     76: #
                     77: USE_IDEA?=             YES
                     78:
                     79: # Handle deprecated option SSH_DONT_USE_IDEA.
                     80: #
1.63      agc        81: .if defined(SSH_DONT_USE_IDEA) && ${SSH_DONT_USE_IDEA} == YES
1.70      jlam       82: USE_IDEA=              NO
                     83: .endif
                     84:
                     85: .if ${USE_IDEA} != "YES"
1.13      frueauf    86: CONFIGURE_ARGS+=       --without-idea
1.1       hubertf    87: .endif
                     88:
1.11      mrg        89: # Include SOCKS firewall support
1.23      agc        90: .if defined(USE_SOCKS) && (${USE_SOCKS} == 4 || ${USE_SOCKS} == 5)
1.32      tv         91: CONFIGURE_ARGS+=       --with-socks${USE_SOCKS}="-L${LOCALBASE}/lib -lsocks${USE_SOCKS}"
                     92: CFLAGS+=               -I${LOCALBASE}/include
1.23      agc        93: .if ${USE_SOCKS} == 4
                     94: DEPENDS+=              socks4-2.2:../../net/socks4
                     95: .else
                     96: DEPENDS+=              socks5-1.0.2:../../net/socks5
                     97: .endif
1.49      mrg        98: .endif
                     99:
1.67      kim       100: # The original Kerberos v4 patches were fetched from
1.60      kim       101: # http://www.monkey.org/~dugsong/ssh-afs/
1.67      kim       102: # PATCH_SITES+=                ftp://ftp.monkey.org/pub/users/dugsong/
                    103: # PATCHFILES+=         ssh-1.2.27-afs-kerberos.patch-1
1.68      kim       104: # MD5 (ssh-1.2.27-afs-kerberos.patch-1) = d440f74958d9c3805b76dbc13e97e87d
1.67      kim       105:
1.60      kim       106: .if defined(KERBEROS) && ${KERBEROS} == 4
                    107: USE_KERBEROS=          yes
                    108: CONFIGURE_ARGS+=       --with-krb4=/usr
                    109: .endif
                    110:
1.80      thorpej   111: # XXX KERBEROS 5 SUPPORT BROKEN WITH HEIMDAL
                    112: #.if defined(KERBEROS) && ${KERBEROS} == 5
                    113: #USE_KERBEROS= yes
                    114: #CONFIGURE_ARGS+=--with-krb5=/usr
                    115: #.else
                    116: #CONFIGURE_ARGS+=--without-krb5
                    117: #.endif
1.60      kim       118:
1.49      mrg       119: # Find X11 libraries with xpkgwedge
                    120: .if defined(USE_LOCALBASE_FOR_X11)
                    121: CONFIGURE_ARGS+=       --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
1.41      simonb    122: .endif
                    123:
                    124: # Enable support for TIS authentication server
                    125: .if defined(USE_TIS) && ${USE_TIS} == YES
                    126: CONFIGURE_ARGS+=       --with-tis=${LOCALBASE}
1.20      tron      127: .endif
                    128:
                    129: # Don't install "ssh" setuid
1.27      tron      130: .if !defined(SSH_SUID) || ${SSH_SUID} != YES
1.20      tron      131: CONFIGURE_ARGS+=       --disable-suid-ssh
1.15      tv        132: .endif
                    133:
                    134: # Make libwrap also compare against forwards (off by default)
                    135: .if defined(LIBWRAP_FWD) && ${LIBWRAP_FWD} == YES
                    136: CFLAGS+=               -DLIBWRAP_FWD
1.36      is        137: .endif
                    138:
1.38      is        139: # be more effective on M68060 machines
                    140: .if defined(M68060)
                    141: CONFIGURE_ARGS+=       --disable-asm
                    142: CFLAGS+=               -m68060
                    143: .endif
                    144:
1.78      veego     145: .if ${OPSYS} == "SunOS"
                    146: ROOT_GROUP?=   root
                    147: .else
                    148: ROOT_GROUP?=   wheel
                    149: .endif
                    150:
1.43      tron      151: DEINSTALL_FILE=        ${WRKDIR}/DEINSTALL
                    152: PLIST_SRC=     ${WRKDIR}/PLIST
1.85      wiz       153: PLIST_SUBST+=  INSTALL="${INSTALL}"            \
                    154:                ROOT_GROUP="${ROOT_GROUP}"
                    155: MESSAGE_SUBST+=        SSH_CONF_DIR="${SSH_CONF_DIR}"
1.19      tron      156:
1.1       hubertf   157: pre-patch:
                    158:        @${MV} -f ${WRKSRC}/make-ssh-known-hosts.pl \
                    159:            ${WRKSRC}/make-ssh-known-hosts.pl.in
1.67      kim       160:        @# SSH DES and AFS/Kerberos DES conflict.
                    161:        @${MV} -f ${WRKSRC}/des.h ${WRKSRC}/ssh-des.h
1.1       hubertf   162:
                    163: fetch-depends:
1.14      tv        164: .if !defined(USE_RSAREF2) || ${USE_RSAREF2} != YES && ${USE_RSAREF2} != NO
                    165:        @${ECHO}
1.39      wrstuden  166:        @${ECHO} The variable USE_RSAREF2 must be set to either YES or NO
                    167:        @${ECHO} in order to build this package.  USA residents that are
1.42      abs       168:        @${ECHO} not licensees of the RSA algorithm MUST set this variable
1.39      wrstuden  169:        @${ECHO} to YES.  Users outside the USA MUST set this variable to
                    170:        @${ECHO} NO.  Licensees may choose -- NO is faster.
1.9       hubertf   171:        @${ECHO}
1.70      jlam      172:        @${ECHO} You may also want to set USE_IDEA to NO if this program
1.14      tv        173:        @${ECHO} will be used for a commercial purpose.  There are other
                    174:        @${ECHO} configure options\; look at the pkg Makefile for more info.
1.13      frueauf   175:        @${FALSE}
1.1       hubertf   176: .endif
1.26      tron      177:
1.47      tv        178: post-patch:
1.67      kim       179:        @# Make sure that "automake" is never run.
1.72      wiz       180:        @${FIND} ${WRKSRC} -name Makefile.in -print | xargs ${TOUCH} ${TOUCH_FLAGS}
1.1       hubertf   181:
1.19      tron      182: post-build:
1.43      tron      183:        @cd ${PKGDIR}; \
1.85      wiz       184:        for FILE in DEINSTALL PLIST ${FILESDIR}/sshd.sh; do \
1.43      tron      185:          ${SED} -e 's#@SSH_CONF_DIR@#${SSH_CONF_DIR}#g' \
                    186:            -e 's#@PREFIX@#${PREFIX}#g' \
                    187:            <$${FILE} >${WRKDIR}/`basename $${FILE}`; \
                    188:        done
1.45      tron      189:        @if [ -x ${WRKSRC}/ssh-askpass ]; then \
                    190:          ${ECHO} bin/ssh-askpass >>${PLIST_SRC}; \
                    191:          ${ECHO} bin/ssh-askpass1 >>${PLIST_SRC}; \
                    192:        fi
1.11      mrg       193:
1.1       hubertf   194: post-install:
1.11      mrg       195:        @${MKDIR} ${PREFIX}/share/examples/ssh
                    196:        @${MKDIR} ${WRKDIR}${SSH_CONF_DIR}
                    197:        (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_PROGRAM} ${MAKE_FLAGS} \
1.25      tv        198:                -f ${MAKEFILE} install_prefix=${WRKDIR} install-configs)
1.11      mrg       199:        ${INSTALL_DATA} ${WRKDIR}${SSH_CONF_DIR}/ssh_config \
                    200:                ${WRKDIR}${SSH_CONF_DIR}/sshd_config ${PREFIX}/share/examples/ssh
1.19      tron      201:        @${RM} -rf ${WRKDIR}${SSH_CONF_DIR}
1.11      mrg       202:        @if [ ! -f ${SSH_CONF_DIR}/ssh_host_key ]; then \
1.9       hubertf   203:                ${ECHO} "Generating a secret host key..."; \
1.11      mrg       204:                ${PREFIX}/bin/ssh-keygen \
                    205:                        -f ${SSH_CONF_DIR}/ssh_host_key -N ""; \
1.1       hubertf   206:        fi
1.83      jlam      207:        ${INSTALL_SCRIPT} ${WRKDIR}/sshd.sh ${PREFIX}/etc/rc.d/sshd
1.52      agc       208:
1.75      jlam      209: BUILD_DEFS+=           USE_IDEA SSH_CONF_DIR SSH_SUID USE_RSAREF2
1.76      itojun    210: BUILD_DEFS+=           LIBWRAP_FWD M68060 USE_SOCKS
1.1       hubertf   211:
1.16      agc       212: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>