[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / snortsnarf

File: [cvs.NetBSD.org] / pkgsrc / security / snortsnarf / Makefile (download)

Revision 1.25, Tue Aug 1 14:59:05 2017 UTC (6 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.24: +2 -2 lines

Follow some http -> https redirects.

# $NetBSD: Makefile,v 1.25 2017/08/01 14:59:05 wiz Exp $
#

DISTNAME=	SnortSnarf-050314.1
PKGNAME=	${DISTNAME:S/SnortSnarf-/snortsnarf-20/}
PKGREVISION=	5
CATEGORIES=	security net
MASTER_SITES=	https://www.snort.org/dl/contrib/data_analysis/snortsnarf/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.silicondefense.com/software/snortsnarf/
COMMENT=	Generate HTML report summaries from snort incident alerts

DEPENDS+=	p5-Time-modules>=101.062101:../../time/p5-Time-modules

NO_BUILD=	YES

USE_TOOLS+=	pax perl:run
REPLACE_PERL=	snortsnarf.pl include/ann_xml.pl include/web_utils.pl	\
		include/xml_help.pl

SUBST_CLASSES+=		paths
SUBST_STAGE.paths=	post-patch
SUBST_FILES.paths=	snortsnarf.pl
SUBST_SED.paths=	-e "s|./include|${PREFIX}/share/snortsnarf|g"
SUBST_MESSAGE.paths=	Fixing paths.

INSTALLATION_DIRS=	bin share/snortsnarf share/doc/snortsnarf

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/snortsnarf.pl ${DESTDIR}${PREFIX}/bin/snortsnarf.pl
	cd ${WRKSRC}/include && pax -rw -pm * ${DESTDIR}${PREFIX}/share/snortsnarf
	${INSTALL_DATA} ${WRKSRC}/README ${DESTDIR}${PREFIX}/share/doc/snortsnarf
	${INSTALL_DATA} ${WRKSRC}/Usage ${DESTDIR}${PREFIX}/share/doc/snortsnarf

.include "../../mk/bsd.pkg.mk"