[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / qca2-gnupg

File: [cvs.NetBSD.org] / pkgsrc / security / qca2-gnupg / Makefile (download)

Revision 1.25, Thu Apr 25 23:35:28 2019 UTC (4 years, 11 months ago) by markd
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.24: +1 -2 lines

qca2*: update to 2.2.1

Changes in 2.2
- support for openssl 1.1
- support for AES GCM and AES CCM modes
- new base64 convenience functions
- new botan2 support
- new hkdf support
- various build improvements and (deprecation) cleanups

There may be trouble building this release on windows. Feedback/input
would be very welcome.

(2.2.0 was not announced due to defects noticed after tagging)

# $NetBSD: Makefile,v 1.25 2019/04/25 23:35:28 markd Exp $

PKGNAME=	qca2-gnupg-${DISTNAME:C/.*-//}

COMMENT=	Cross-platform crypto API for QT - GnuPG plugin

.include "../../security/qca2/Makefile.common"

DEPENDS+=	gnupg2-[0-9]*:../../security/gnupg2

BUILD_DIRS=	plugins/qca-gnupg

CMAKE_ARGS+=	-DQT4_BUILD=ON
CMAKE_ARGS+=	-DBUILD_PLUGINS=gnupg
CMAKE_ARGS+=	-DBUILD_TOOLS=OFF
CMAKE_ARGS+=	-DINST_QCA_LIB_NAME=-lqca

SUBST_CLASSES+=		libname
SUBST_STAGE.libname=	pre-configure
SUBST_MESSAGE.libname=	Use installed lib.
SUBST_FILES.libname=	plugins/qca-gnupg/CMakeLists.txt
SUBST_SED.libname=	-e 's:{QCA_LIB_NAME}:{INST_QCA_LIB_NAME}:'

.include "../../security/qca2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"