The NetBSD Project

CVS log for pkgsrc/security/py-tlslite/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / security / py-tlslite

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2019Q1-base


Revision 1.15 / (download) - annotate - [select for diffs], Sun Jul 23 22:30:03 2017 UTC (6 years, 8 months ago) by schmonz
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.14: +3 -3 lines
Diff to previous 1.14 (colored)

Update to 0.4.9. From the commit log:

- Fix IndexError on junk message (CVE-2015-3220).
- Fix unit-test failure (disable sha256 mac if maxversion < 1.2)
- Merge pull request #98 from davidben/chromium-patches-2
- Fix bug in SRP hashing.
- Merge pull request #106 from tomato42/name-fixes-trevp
- rename description_name
- rename level_name
- rename type_name
- rename cert_types
- rename _server_extensions
- rename _universal_extensions
- rename host_names
- rename server_names
- rename server_type
- rename ext_data
- rename ext_type
- Merge pull request #104 from tomato42/sni-fix
- fix parsing server side server_name extension
- travis.yml: follow redirects, debugging info logging
- Correctly enforce cipher suite version constraints.
- Fix Fault-based test framework.
- Fix client auth for TLS 1.2.
- If ignoreAbrubtClose is set, write failures don't break sessions.
- Fix CertificateRequest initialization.
- Merge pull request #93 from tomato42/gitignore
- ignore coverage html output folder
- Merge pull request #88 from tomato42/handshakesettings-fixes
- promote HandshakeSettings._getCertificateTypes to public
- add check for interdependance of minKeySize and maxKeySize
- unit tests for HandshakeSettings
- promote HandshakeSettings._filter() to public
- adding acknowledgements
- Merge pull request #87 from davidben/chromium-patches-1
- Apply minimal padding.
- Implement FALLBACK_SCSV.
- Fix #! line in httpsserver.sh.
- Fix executable bits on files.
- Merge pull request #86 from tomato42/tests-with-deps-3
- Merge pull request #85 from tomato42/clienthello-tests
- remove BadNextProtos
- test ClientHello.parse with SSLv2 ClientHello
- Fix compatibility issues with pycrypto and gmpy
- fix setting ClientHello.server_name multiple times
- clientHello.supports_npn test
- ClientHello.tack test
- ClientHello.srp_username test
- Merge pull request #84 from tomato42/messages-tests
- test coverage for getExtension and certificate_types
- test coverage for Alert
- Fix test failure on OSX.
- Adding acknowledgements for Mirko.
- Merge pull request #83 from MirkoDziadzka/session-cache
- remove unneeded import
- add tests to reproduce the problem
- fix session cache problem
- Merge pull request #82 from tomato42/test-coverage
- RecordHeader3 test coverage
- test coverage to RecordHeader2
- Trying this coveralls things for test coverage.
- Merge pull request #80 from tomato42/coverage
- add coverage checks to test-dev
- measure coverage in travis-ci
- Merge pull request #78 from tomato42/test-intermediate-10
- add check for code style
- Merge pull request #77 from tomato42/merged-2
- fix all problems with tests
- Merge pull request #68 from tomato42/fix-6568ad9
- fix bug introduced in 6568ad9
- Merge pull request #57 from tomato42/test-intermediate-3
- run tests for every commit in pull request or push [v2]
- make-based tests
- Merge pull request #54 from tomato42/revert-53-test-intermediate
- Revert "More detailed CI"
- Merge pull request #53 from tomato42/test-intermediate
- run tests for every commit in pull request or push
- Merge pull request #51 from tomato42/python26-fix
- add unittest2 import
- Trying travis
- Merge pull request #43 from tomato42/tests-fixes
- Merge pull request #46 from tomato42/cleanup
- don't pollute global namespace with `sieve` temporary variable
- characterisation tests for isPrime
- don't pollute global namespace with `length`
- Merge pull request #45 from tomato42/test-coverage-2
- fix pylint reported formatting issues
- fix missing import in tlslite.extensions
- better test coverage for TACKExtension
- don't use explicit short-circuit in compare
- better test coverage for __eq__ in TLSExtension
- remove duplicate check
- unit tests compatibility with Python2.6
- run self tests using both python2 and python3
- python 2.7.9 compatibility
- change certificate to self signed
- strict is deprecated and removed in 3.4
- deal with unclean socket shutdown
- Merge pull request #40 from tomato42/debugging-aids
- Merge pull request #42 from tomato42/docstring
- fix addExtension docstring
- add __repr__ to ClientHello
- add __str__ to ClientHello
- add __repr__ support to Alert
- add __str__ support to Alert
- add __repr__ to extensions
- add __repr__ to ServerHello
- add __str__ to ServerHello
- add __repr__ to RecordHeader3
- add __str__ handling to RecordHeader3
- Merge pull request #37 from tomato42/server-extensions-4
- Merge pull request #38 from tomato42/parsePEMKey-fixes
- be more precise in naming libraries
- make comment more descriptive in OpenSSL_RSAKey.parse()
- make OpenSSL wrapper handle PKCS#8 files
- characterisation tests for parsePEMKey
- Merge pull request #36 from tomato42/comments
- use extension parsers and serialisers in server hello
- convert server hello to using extensions list
- implement server side version of TACK extension
- fix typo in ClientHello docs
- remove some code duplication in ClientHello
- don't use reserved keyword for name of ServerName type field
- extend note about backwards compatibility for certificate_types
- extend extension handler to ServerHello extensions
- implement server side version of cert type extension
- add tests for cert_type and NPN ServerHello extensions
- Merge branch 'writer-fixes' of git://github.com/tomato42/tlslite-1
  into tomato42-writer-fixes
- Merge pull request #34 from tomato42/new-extensions-3
- raise exception when overflowing integers
- Writer characterisation tests
- rename tlsextension to extensions
- harmonise get_extension method name with other method names
- tests for the new extensions variable
- use array to store ClientHello extensions
- make TLSExtension parse() into a factory function
- implement the ClientHello version of cert_type extension
- implement SRP extension
- implement NextProtocolNegotiation extension
- codec: method to return remaining buffer size
- implement class for ServerNameIndication extension
- add class handling generic TLS Extensions
- Merge pull request #32 from tomato42/client-hello-ext-parser-tests
- add parser tests for extensions in ClientHello
- clean up also in unit_tests directory
- Merge pull request #30 from tomato42/epydoc-fixes
- Merge pull request #31 from tomato42/parser-fixes
- fix getFixBytes boundary checking
- add characterisation tests for Parser
- add graphs to generated documentation
- add docs/ directory to .gitignore
- add test for epydoc to test-dev target
- fix epydoc warnings
- Merge pull request #29 from tomato42/test-suite-2
- ServerHello unit tests
- simple unit tests for ClientHello class (v3)
- remove dead code

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>