[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / py-m2crypto

File: [cvs.NetBSD.org] / pkgsrc / security / py-m2crypto / Attic / Makefile (download)

Revision 1.18, Sat Mar 4 21:30:38 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.17: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.18 2006/03/04 21:30:38 jlam Exp $
#

DISTNAME=		m2crypto-0.13
PKGNAME=		${PYPKGPREFIX}-${DISTNAME}.1
PKGREVISION=		1
CATEGORIES=		security python
MASTER_SITES=		http://sandbox.rulemaker.net/ngps/Dist/
EXTRACT_SUFX=		.zip

PATCH_SITES=		${MASTER_SITES}
PATCHFILES=		0.13p1.patch

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://sandbox.rulemaker.net/ngps/m2/
COMMENT=		Crypto and SSL toolkit for Python

PYDISTUTILSPKG=			yes
PYTHON_VERSIONS_ACCEPTED=	24 23 22 21

# constness is very different between openssl versions,
# it seems, and 0.9.7i is the version which currently is
# in pkgsrc and against which I fixed m2crypto to compile.
# -- wiz 20060115
BUILDLINK_DEPENDS.openssl+=	openssl-0.9.7i{,nb*}

.include "../../lang/python/extension.mk"
.include "../../devel/swig/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"