File:  [cvs.NetBSD.org] / pkgsrc / security / py-ecdsa / distinfo
Revision 1.9: download - view: text, annotated - select for diffs
Sat Oct 3 06:13:27 2020 UTC (4 years, 2 months ago) by adam
Branches: MAIN
CVS tags: HEAD
py-ecdsa: updated to 0.16.0

Release 0.16.0

New features:
Support for reading and writing private keys in PKCS#8 format.

New API:
`to_pem` and `to_der` now accept new parameter, `format`, to specify
the format of the encoded files, either the dafault, legacy "ssleay", or
the new `pkcs8` to use PKCS#8. Note that only unencrypted PKCS#8 files are
supported.
Add `allow_truncate` to `verify` in `VerifyingKey`, it defaults to True,
when specified as False, use of large hashes smaller than curves will be
disallowed (as it was in 0.14.1 and earlier).

Bug fix:
Correctly calculate signatures for private keys equal to n-1.
Make `PointJacobi` and thus `SigningKey` and `VerifyingKey` pickleable.

Doc fixes:
`to_pem` functions return `bytes` not `str`, document them as such.
`from_pem` and `from_pem` in `SigningKey` returns `SigningKey`, document them
as such.

Maintenance:
Ensure that version checks will work with Python 4.
Format the source with black.
Fix uses of `assert_` in test suite.
Use newer Ubuntu in Travis to test against OpenSSL 1.1.1 (and thus
test the interoperability of ECDH code in Travis).

$NetBSD: distinfo,v 1.9 2020/10/03 06:13:27 adam Exp $

SHA1 (ecdsa-0.16.0.tar.gz) = 52b4b3e423662f90c4bbbbdcf0fd6bcf52fdee01
RMD160 (ecdsa-0.16.0.tar.gz) = 4fdfc7188776539ce64f482936f6454da8ca4595
SHA512 (ecdsa-0.16.0.tar.gz) = 94ccefe19899a5e56393bb0e6624e9af66bdc60ad370d65900a24a0465c430a3a001ed9c25970e48834cb25ca730bc9279af98d17ecd3ad66189c64c8f864b42
Size (ecdsa-0.16.0.tar.gz) = 125851 bytes

CVSweb <webmaster@jp.NetBSD.org>