[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / py-denyhosts

File: [cvs.NetBSD.org] / pkgsrc / security / py-denyhosts / Makefile (download)

Revision 1.18, Fri Apr 26 13:14:12 2019 UTC (6 months, 3 weeks ago) by maya
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.17: +2 -2 lines

Omit mentions of python 34 and 35, after those were removed.

- Includes some whitespace changes, to be handled in a separate commit.

# $NetBSD: Makefile,v 1.18 2019/04/26 13:14:12 maya Exp $

VER=		2.6
DISTNAME=	DenyHosts-${VER}
PKGNAME=	${PYPKGPREFIX}-denyhosts-${VER}
PKGREVISION=	5
CATEGORIES=	sysutils
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=denyhosts/}
LICENSE=	gnu-gpl-v2

MAINTAINER=	he@NetBSD.org
HOMEPAGE=	http://denyhosts.sourceforge.net/
COMMENT=	Watch auth log for invalid ssh login attempts and block hosts

PYDISTUTILSPKG= yes

CONF_FILES+=	${PREFIX}/share/denyhosts/denyhosts.cfg-dist \
		${PREFIX}/etc/denyhosts.conf

FILES_SUBST+=	PYTHONBIN=${PYTHONBIN:Q}

SUBST_CLASSES+=	cf
SUBST_STAGE.cf= post-configure
SUBST_VARS.cf=	VARBASE PREFIX VARBASE PKG_SYSCONFDIR PYTHONBIN
SUBST_FILES.cf=	setup.py denyhosts.cfg-dist daemon-control-dist

REPLACE_PYTHON=	daemon-control-dist plugins/test_deny.py setup.py
REPLACE_PYTHON+= scripts/restricted_from_invalid.py
REPLACE_PYTHON+= scripts/restricted_from_passwd.py

PYTHON_SELF_CONFLICT=	yes
PYTHON_VERSIONS_INCOMPATIBLE=	 36 37

RCD_SCRIPTS+=	denyhosts
SMF_NAME=	denyhost

post-configure:
	${RM} ${WRKDIR}/${DISTNAME}/scripts/*.orig

.include "../../lang/python/extension.mk"
.include "../../lang/python/application.mk"
.include "../../mk/bsd.pkg.mk"