[BACK]Return to PLIST CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / py-cryptography

File: [cvs.NetBSD.org] / pkgsrc / security / py-cryptography / PLIST (download)

Revision 1.19, Tue Jul 18 13:58:25 2017 UTC (6 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.18: +13 -2 lines

2.0:

BACKWARDS INCOMPATIBLE: Support for Python 3.3 has been dropped.
We now ship manylinux1 wheels linked against OpenSSL 1.1.0f. These wheels will be automatically used with most Linux distributions if you are running the latest pip.
Deprecated the use of signer on :class:`~cryptography.hazmat.primitives.asymmetric.rsa.RSAPrivateKey`, :class:`~cryptography.hazmat.primitives.asymmetric.dsa.DSAPrivateKey`, and :class:`~cryptography.hazmat.primitives.asymmetric.ec.EllipticCurvePrivateKey` in favor of sign.
Deprecated the use of verifier on :class:`~cryptography.hazmat.primitives.asymmetric.rsa.RSAPublicKey`, :class:`~cryptography.hazmat.primitives.asymmetric.dsa.DSAPublicKey`, and :class:`~cryptography.hazmat.primitives.asymmetric.ec.EllipticCurvePublicKey` in favor of verify.
Added support for parsing :class:`~cryptography.x509.certificate_transparency.SignedCertificateTimestamp` objects from X.509 certificate extensions.
Added support for :class:`~cryptography.hazmat.primitives.ciphers.aead.ChaCha20Poly1305`.
Added support for :class:`~cryptography.hazmat.primitives.ciphers.aead.AESCCM`.
Added :class:`~cryptography.hazmat.primitives.ciphers.aead.AESGCM`, a "one shot" API for AES GCM encryption.
Added support for :doc:`/hazmat/primitives/asymmetric/x25519`.
Added support for serializing and deserializing Diffie-Hellman parameters with :func:`~cryptography.hazmat.primitives.serialization.load_pem_parameters`, :func:`~cryptography.hazmat.primitives.serialization.load_der_parameters`, and :meth:`~cryptography.hazmat.primitives.asymmetric.dh.DHParameters.parameter_bytes` .
The extensions attribute on :class:`~cryptography.x509.Certificate`, :class:`~cryptography.x509.CertificateSigningRequest`, :class:`~cryptography.x509.CertificateRevocationList`, and :class:`~cryptography.x509.RevokedCertificate` now caches the computed Extensions object. There should be no performance change, just a performance improvement for programs accessing the extensions attribute multiple times.

@comment $NetBSD: PLIST,v 1.19 2017/07/18 13:58:25 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/cryptography/__about__.py
${PYSITELIB}/cryptography/__about__.pyc
${PYSITELIB}/cryptography/__about__.pyo
${PYSITELIB}/cryptography/__init__.py
${PYSITELIB}/cryptography/__init__.pyc
${PYSITELIB}/cryptography/__init__.pyo
${PYSITELIB}/cryptography/exceptions.py
${PYSITELIB}/cryptography/exceptions.pyc
${PYSITELIB}/cryptography/exceptions.pyo
${PYSITELIB}/cryptography/fernet.py
${PYSITELIB}/cryptography/fernet.pyc
${PYSITELIB}/cryptography/fernet.pyo
${PYSITELIB}/cryptography/hazmat/__init__.py
${PYSITELIB}/cryptography/hazmat/__init__.pyc
${PYSITELIB}/cryptography/hazmat/__init__.pyo
${PYSITELIB}/cryptography/hazmat/backends/__init__.py
${PYSITELIB}/cryptography/hazmat/backends/__init__.pyc
${PYSITELIB}/cryptography/hazmat/backends/__init__.pyo
${PYSITELIB}/cryptography/hazmat/backends/interfaces.py
${PYSITELIB}/cryptography/hazmat/backends/interfaces.pyc
${PYSITELIB}/cryptography/hazmat/backends/interfaces.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/__init__.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/__init__.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/__init__.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/aead.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/aead.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/aead.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/backend.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/backend.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/backend.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/ciphers.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/ciphers.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/ciphers.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/cmac.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/cmac.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/cmac.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/decode_asn1.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/decode_asn1.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/decode_asn1.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/dh.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/dh.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/dh.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/dsa.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/dsa.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/dsa.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/ec.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/ec.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/ec.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/encode_asn1.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/encode_asn1.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/encode_asn1.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/hashes.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/hashes.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/hashes.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/hmac.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/hmac.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/hmac.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/rsa.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/rsa.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/rsa.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/utils.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/utils.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/utils.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/x25519.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/x25519.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/x25519.pyo
${PYSITELIB}/cryptography/hazmat/backends/openssl/x509.py
${PYSITELIB}/cryptography/hazmat/backends/openssl/x509.pyc
${PYSITELIB}/cryptography/hazmat/backends/openssl/x509.pyo
${PYSITELIB}/cryptography/hazmat/bindings/__init__.py
${PYSITELIB}/cryptography/hazmat/bindings/__init__.pyc
${PYSITELIB}/cryptography/hazmat/bindings/__init__.pyo
${PLIST.py2x}${PYSITELIB}/cryptography/hazmat/bindings/_constant_time.so
${PLIST.py2x}${PYSITELIB}/cryptography/hazmat/bindings/_openssl.so
${PLIST.py2x}${PYSITELIB}/cryptography/hazmat/bindings/_padding.so
${PLIST.py3x}${PYSITELIB}/cryptography/hazmat/bindings/_constant_time.abi3.so
${PLIST.py3x}${PYSITELIB}/cryptography/hazmat/bindings/_openssl.abi3.so
${PLIST.py3x}${PYSITELIB}/cryptography/hazmat/bindings/_padding.abi3.so
${PYSITELIB}/cryptography/hazmat/bindings/openssl/__init__.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/__init__.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/__init__.pyo
${PYSITELIB}/cryptography/hazmat/bindings/openssl/_conditional.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/_conditional.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/_conditional.pyo
${PYSITELIB}/cryptography/hazmat/bindings/openssl/binding.py
${PYSITELIB}/cryptography/hazmat/bindings/openssl/binding.pyc
${PYSITELIB}/cryptography/hazmat/bindings/openssl/binding.pyo
${PYSITELIB}/cryptography/hazmat/primitives/__init__.py
${PYSITELIB}/cryptography/hazmat/primitives/__init__.pyc
${PYSITELIB}/cryptography/hazmat/primitives/__init__.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/__init__.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/__init__.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/__init__.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/dh.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/dh.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/dh.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/dsa.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/dsa.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/dsa.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/ec.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/ec.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/ec.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/padding.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/padding.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/padding.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/rsa.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/rsa.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/rsa.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/utils.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/utils.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/utils.pyo
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/x25519.py
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/x25519.pyc
${PYSITELIB}/cryptography/hazmat/primitives/asymmetric/x25519.pyo
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/__init__.py
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/__init__.pyc
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/__init__.pyo
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/aead.py
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/aead.pyc
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/aead.pyo
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/algorithms.py
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/algorithms.pyc
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/algorithms.pyo
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/base.py
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/base.pyc
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/base.pyo
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/modes.py
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/modes.pyc
${PYSITELIB}/cryptography/hazmat/primitives/ciphers/modes.pyo
${PYSITELIB}/cryptography/hazmat/primitives/cmac.py
${PYSITELIB}/cryptography/hazmat/primitives/cmac.pyc
${PYSITELIB}/cryptography/hazmat/primitives/cmac.pyo
${PYSITELIB}/cryptography/hazmat/primitives/constant_time.py
${PYSITELIB}/cryptography/hazmat/primitives/constant_time.pyc
${PYSITELIB}/cryptography/hazmat/primitives/constant_time.pyo
${PYSITELIB}/cryptography/hazmat/primitives/hashes.py
${PYSITELIB}/cryptography/hazmat/primitives/hashes.pyc
${PYSITELIB}/cryptography/hazmat/primitives/hashes.pyo
${PYSITELIB}/cryptography/hazmat/primitives/hmac.py
${PYSITELIB}/cryptography/hazmat/primitives/hmac.pyc
${PYSITELIB}/cryptography/hazmat/primitives/hmac.pyo
${PYSITELIB}/cryptography/hazmat/primitives/interfaces.py
${PYSITELIB}/cryptography/hazmat/primitives/interfaces.pyc
${PYSITELIB}/cryptography/hazmat/primitives/interfaces.pyo
${PYSITELIB}/cryptography/hazmat/primitives/kdf/__init__.py
${PYSITELIB}/cryptography/hazmat/primitives/kdf/__init__.pyc
${PYSITELIB}/cryptography/hazmat/primitives/kdf/__init__.pyo
${PYSITELIB}/cryptography/hazmat/primitives/kdf/concatkdf.py
${PYSITELIB}/cryptography/hazmat/primitives/kdf/concatkdf.pyc
${PYSITELIB}/cryptography/hazmat/primitives/kdf/concatkdf.pyo
${PYSITELIB}/cryptography/hazmat/primitives/kdf/hkdf.py
${PYSITELIB}/cryptography/hazmat/primitives/kdf/hkdf.pyc
${PYSITELIB}/cryptography/hazmat/primitives/kdf/hkdf.pyo
${PYSITELIB}/cryptography/hazmat/primitives/kdf/kbkdf.py
${PYSITELIB}/cryptography/hazmat/primitives/kdf/kbkdf.pyc
${PYSITELIB}/cryptography/hazmat/primitives/kdf/kbkdf.pyo
${PYSITELIB}/cryptography/hazmat/primitives/kdf/pbkdf2.py
${PYSITELIB}/cryptography/hazmat/primitives/kdf/pbkdf2.pyc
${PYSITELIB}/cryptography/hazmat/primitives/kdf/pbkdf2.pyo
${PYSITELIB}/cryptography/hazmat/primitives/kdf/scrypt.py
${PYSITELIB}/cryptography/hazmat/primitives/kdf/scrypt.pyc
${PYSITELIB}/cryptography/hazmat/primitives/kdf/scrypt.pyo
${PYSITELIB}/cryptography/hazmat/primitives/kdf/x963kdf.py
${PYSITELIB}/cryptography/hazmat/primitives/kdf/x963kdf.pyc
${PYSITELIB}/cryptography/hazmat/primitives/kdf/x963kdf.pyo
${PYSITELIB}/cryptography/hazmat/primitives/keywrap.py
${PYSITELIB}/cryptography/hazmat/primitives/keywrap.pyc
${PYSITELIB}/cryptography/hazmat/primitives/keywrap.pyo
${PYSITELIB}/cryptography/hazmat/primitives/mac.py
${PYSITELIB}/cryptography/hazmat/primitives/mac.pyc
${PYSITELIB}/cryptography/hazmat/primitives/mac.pyo
${PYSITELIB}/cryptography/hazmat/primitives/padding.py
${PYSITELIB}/cryptography/hazmat/primitives/padding.pyc
${PYSITELIB}/cryptography/hazmat/primitives/padding.pyo
${PYSITELIB}/cryptography/hazmat/primitives/serialization.py
${PYSITELIB}/cryptography/hazmat/primitives/serialization.pyc
${PYSITELIB}/cryptography/hazmat/primitives/serialization.pyo
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/__init__.py
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/__init__.pyc
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/__init__.pyo
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/hotp.py
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/hotp.pyc
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/hotp.pyo
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/totp.py
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/totp.pyc
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/totp.pyo
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/utils.py
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/utils.pyc
${PYSITELIB}/cryptography/hazmat/primitives/twofactor/utils.pyo
${PYSITELIB}/cryptography/utils.py
${PYSITELIB}/cryptography/utils.pyc
${PYSITELIB}/cryptography/utils.pyo
${PYSITELIB}/cryptography/x509/__init__.py
${PYSITELIB}/cryptography/x509/__init__.pyc
${PYSITELIB}/cryptography/x509/__init__.pyo
${PYSITELIB}/cryptography/x509/base.py
${PYSITELIB}/cryptography/x509/base.pyc
${PYSITELIB}/cryptography/x509/base.pyo
${PYSITELIB}/cryptography/x509/certificate_transparency.py
${PYSITELIB}/cryptography/x509/certificate_transparency.pyc
${PYSITELIB}/cryptography/x509/certificate_transparency.pyo
${PYSITELIB}/cryptography/x509/extensions.py
${PYSITELIB}/cryptography/x509/extensions.pyc
${PYSITELIB}/cryptography/x509/extensions.pyo
${PYSITELIB}/cryptography/x509/general_name.py
${PYSITELIB}/cryptography/x509/general_name.pyc
${PYSITELIB}/cryptography/x509/general_name.pyo
${PYSITELIB}/cryptography/x509/name.py
${PYSITELIB}/cryptography/x509/name.pyc
${PYSITELIB}/cryptography/x509/name.pyo
${PYSITELIB}/cryptography/x509/oid.py
${PYSITELIB}/cryptography/x509/oid.pyc
${PYSITELIB}/cryptography/x509/oid.pyo