[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / py-certbot

File: [cvs.NetBSD.org] / pkgsrc / security / py-certbot / Makefile.common (download)

Revision 1.63, Thu Mar 17 12:23:31 2022 UTC (2 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.62: +4 -2 lines

py-acme py-certbot: updated to 1.25.0

Certbot 1.25.0

Changed

Dropped 32 bit support for the Windows beta installer
Windows beta installer is now distributed as "certbot-beta-installer-win_amd64.exe".
Users of the Windows beta should uninstall the old version before running this.
Added a check whether OCSP stapling is supported by the installer when requesting a
certificate with the run subcommand in combination with the --must-staple option.
If the installer does not support OCSP and the --must-staple option is used, Certbot
will raise an error and quit.
Certbot and its acme module now depend on josepy>=1.13.0 due to better type annotation
support.

Fixed

Updated dependencies to use new version of cryptography that uses OpenSSL 1.1.1n, in
response to https://www.openssl.org/news/secadv/20220315.txt.


Certbot 1.24.0

Added

When the --debug-challenges option is used in combination with -v, Certbot
now displays the challenge URLs (for http-01 challenges) or FQDNs (for
dns-01 challenges) and their expected return values.

Changed

Support for Python 3.6 was removed.
All Certbot components now require setuptools>=41.6.0.
The acme library now requires requests>=2.20.0.
Certbot and its acme library now require pytz>=2019.3.
certbot-nginx now requires pyparsing>=2.2.1.
certbot-dns-route53 now requires boto3>=1.15.15.

Fixed

Nginx plugin now checks included files for the singleton server_names_hash_bucket_size directive.

# $NetBSD: Makefile.common,v 1.63 2022/03/17 12:23:31 adam Exp $
# used by security/py-acme/Makefile
# used by security/py-certbot/Makefile
# used by security/py-certbot-apache/Makefile
# used by security/py-certbot-dns-digitalocean/Makefile
# used by security/py-certbot-dns-dnsimple/Makefile
# used by security/py-certbot-dns-dnsmadeeasy/Makefile
# used by security/py-certbot-dns-gehirn/Makefile
# used by security/py-certbot-dns-google/Makefile
# used by security/py-certbot-dns-linode/Makefile
# used by security/py-certbot-dns-luadns/Makefile
# used by security/py-certbot-dns-nsone/Makefile
# used by security/py-certbot-dns-ovh/Makefile
# used by security/py-certbot-dns-rfc2136/Makefile
# used by security/py-certbot-dns-route53/Makefile
# used by security/py-certbot-dns-sakuracloud/Makefile
# used by security/py-certbot-nginx/Makefile

CERTBOT_VERSION=	1.25.0

PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES?=	security python

MAINTAINER=	adam@NetBSD.org
HOMEPAGE=	https://github.com/certbot/certbot
LICENSE=	apache-2.0

DEPENDS+=	${PYPKGPREFIX}-setuptools>=41.6.0:../../devel/py-setuptools

USE_LANGUAGES=	# none

PYTHON_VERSIONS_INCOMPATIBLE=	27

do-test:
	cd ${WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX} tests