File:  [cvs.NetBSD.org] / pkgsrc / security / py-asn1 / distinfo
Revision 1.19: download - view: text, annotated - select for diffs
Sat Aug 3 04:36:59 2019 UTC (5 years, 4 months ago) by adam
Branches: MAIN
CVS tags: HEAD
py-asn1: updated to 0.4.6

Revision 0.4.6:
- Added previously missing SET OF ANY construct encoding/decoding support.
- Added omitEmptyOptionals option which is respected by Sequence
  and Set encoders. When omitEmptyOptionals is set to True, empty
  initialized optional components are not encoded. Default is False.
- New elements to SequenceOf/SetOf objects can now be added at any
  position - the requirement for the new elements to reside at the end
  of the existing ones (i.e. s[len(s)] = 123) is removed.
- List-like slicing support added to SequenceOf/SetOf objects.
- Removed default initializer from SequenceOf/SetOf types to ensure
  consistent behaviour with the rest of ASN.1 types. Before this change,
  SequenceOf/SetOf instances immediately become value objects behaving
  like an empty list. With this change, SequenceOf/SetOf objects
  remain schema objects unless a component is added or .clear() is
  called.
  This change can potentially cause incompatibilities with existing
  pyasn1 objects which assume SequenceOf/SetOf instances are value
  objects right upon instantiation.
  The behaviour of Sequence/Set types depends on the componentType
  initializer: if on componentType is given, the behaviour is the
  same as SequenceOf/SetOf have. IF componentType is given, but
  neither optional nor defaulted components are present, the created
  instance remains schema object, If, however, either optional or
  defaulted component isi present, the created instance immediately
  becomes a value object.
- Added .reset() method to all constructed types to turn value object
  into a schema object.
- Added PyAsn1UnicodeDecodeError/PyAsn1UnicodeDecodeError exceptions
  to help the caller treating unicode errors happening internally
  to pyasn1 at the upper layers.
- Added support for subseconds CER/DER encoding edge cases in
  GeneralizedTime codec.
- Fixed 3-digit fractional seconds value CER/DER encoding of
  GeneralizedTime.
- Fixed AnyDecoder to accept possible TagMap as asn1Spec
  to make dumping raw value operational

$NetBSD: distinfo,v 1.19 2019/08/03 04:36:59 adam Exp $

SHA1 (pyasn1-0.4.6.tar.gz) = 694d02197abe07dfc250eb02d9ed2adf5453592d
RMD160 (pyasn1-0.4.6.tar.gz) = 59eab7ca1193fb290152494b7e7d4ad3c78f1855
SHA512 (pyasn1-0.4.6.tar.gz) = 0d7dba175f292a136a34df0dadb90392bff1dac93ab2d04697fcd3e03f5bb8367a8e68dbfcc536ea9effd6292a459f24766f29f512161724fa405accb86617c5
Size (pyasn1-0.4.6.tar.gz) = 128216 bytes

CVSweb <webmaster@jp.NetBSD.org>