[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / py-acme-tiny

File: [cvs.NetBSD.org] / pkgsrc / security / py-acme-tiny / Makefile (download)

Revision 1.3, Sat Sep 8 18:52:18 2018 UTC (5 years, 6 months ago) by schmonz
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.2: +3 -4 lines

Update to 4.0.4. From the git log:

- Make regular expression accept a whitespace after CN.
- Don't fail on openssl 1.1 output
- Add documentation and support for Red Hat openssl directories
- fix parsing of new (?) openssl output format
- Fix broken Markdown headings
- FIX CN parsing to work with OpenSSL 1.1
- Make acme_tiny.py executable in index
- Minor tweak that makes deploying a tiny bit easier
- OpenSSL output seems to have changed another time.
- fixed changing error message
- fixed more error message case changes
- Fix typos
- switched to grabbing the agreement url from /directory, addresses #145, #148, #172, #189
- damn python3 bytes-to-strings encoding gets you again...
- added python 3.6 to test coverage
- update SSL config
- mostly working ACMEv2, except for letsencrypt/boulder#3367
- deprecated CA url in favor of using the direct certificate authority directory url
- added badNonce retries
- consolidated external commandline execution error handling to bring back under 200 lines of code
- removed challenge payload that is no longer needed in new acme spec
- updated test coverage to ignore new setup.py file (setup install still gets tested via test_install.py)
- updated readme to note that ACME v2 certificate downloads now include the intermediate certificate
- added optional contact details
- fixed buffer to unicode decoding for tests
- cleaned up help and copyright text
- Readme: Only needs access to private account key
- added tiny user agent
- don't skip ValueError when urlopen(Request(nonvalid, ...))

# $NetBSD: Makefile,v 1.3 2018/09/08 18:52:18 schmonz Exp $

DISTNAME=	acme-tiny-4.0.4
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	security
MASTER_SITES=	${MASTER_SITE_GITHUB:=diafygi/}

MAINTAINER=	khorben@defora.org
HOMEPAGE=	https://github.com/diafygi/acme-tiny/
COMMENT=	Tiny script to issue and renew TLS certs from Let's Encrypt
LICENSE=	mit

GITHUB_PROJECT=	acme-tiny
GITHUB_TAG=	${PKGVERSION_NOREV}

NO_BUILD=	yes
INSTALLATION_DIRS=bin share/doc/${PYPKGPREFIX}-acme-tiny
PLIST_SUBST+=	PYPKGPREFIX=${PYPKGPREFIX}

REPLACE_PYTHON=	acme_tiny.py

do-install:
	${INSTALL} -m 0755 ${WRKSRC}/acme_tiny.py ${DESTDIR}${PREFIX}/bin/acme_tiny
	${INSTALL} -m 0644 ${WRKSRC}/README.md ${DESTDIR}${PREFIX}/share/doc/${PYPKGPREFIX}-acme-tiny/README.md

.include "../../lang/python/application.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"