[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / py-OpenSSL

File: [cvs.NetBSD.org] / pkgsrc / security / py-OpenSSL / Makefile (download)

Revision 1.63, Sun Jan 15 19:40:14 2023 UTC (15 months ago) by abs
Branch: MAIN
Changes since 1.62: +2 -2 lines

Updated security/py-OpenSSL to 23.0.0

The previous py-OpenSSL-22.1.0 would abort at runtime against
py-cryptography-39.0.x which broke py-certbot and similar.

changes:
- Add OpenSSL.SSL.X509StoreFlags.PARTIAL_CHAIN constant to allow
  for users to perform certificate verification on partial certificate
  chains. #1166
- cryptography maximum version has been increased to 39.0.x.

# $NetBSD: Makefile,v 1.63 2023/01/15 19:40:14 abs Exp $

DISTNAME=	pyOpenSSL-23.0.0
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:S/py//}
CATEGORIES=	security python
MASTER_SITES=	${MASTER_SITE_PYPI:=p/pyOpenSSL/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://pyopenssl.org/
COMMENT=	Python interface to the OpenSSL library
LICENSE=	apache-2.0

DEPENDS+=	${PYPKGPREFIX}-cryptography>=38.0.0:../../security/py-cryptography
TEST_DEPENDS+=	${PYPKGPREFIX}-flaky-[0-9]*:../../devel/py-flaky
TEST_DEPENDS+=	${PYPKGPREFIX}-pretend-[0-9]*:../../devel/py-pretend
TEST_DEPENDS+=	${PYPKGPREFIX}-test-runner-[0-9]*:../../devel/py-test-runner

# https://github.com/pyca/pyopenssl/issues/656
PYSETUPTESTTARGET=	pytest

# test status as of 22.0.0
# 4 failed, 521 passed, 1 skipped, 6 warnings

PYTHON_VERSIONS_INCOMPATIBLE=	27

.include "../../lang/python/egg.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"