[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / pgpenvelope

File: [cvs.NetBSD.org] / pkgsrc / security / pgpenvelope / Makefile (download)

Revision 1.18, Thu May 29 23:37:25 2014 UTC (4 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.17: +2 -2 lines

Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

# $NetBSD: Makefile,v 1.18 2014/05/29 23:37:25 wiz Exp $
#

DISTNAME=		pgpenvelope-2.10.2
PKGREVISION=		11
CATEGORIES=		security mail
MASTER_SITES=		${MASTER_SITE_SOURCEFORGE:=pgpenvelope/}

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://pgpenvelope.sourceforge.net/
COMMENT=		GnuPG and Pine/Procmail integration tool

DEPENDS+=		p5-AppConfig>=1.52:../../devel/p5-AppConfig
DEPENDS+=		p5-Class-MakeMethods>=1.010:../../devel/p5-Class-MakeMethods
DEPENDS+=		p5-GnuPG-Interface>=0.34nb2:../../security/p5-GnuPG-Interface
DEPENDS+=		p5-String-Approx>=3.13:../../textproc/p5-String-Approx
DEPENDS+=		p5-Term-ReadKey>=2.14:../../devel/p5-Term-ReadKey
DEPENDS+=		{perl>=5.8.1,p5-Term-ReadLine>=1.01}:../../devel/p5-Term-ReadLine

PERL5_PACKLIST=		auto/pgpenvelope/.packlist

pre-configure:
	cd ${WRKSRC}/lib/PGPEnvelope && for f in *.pm; do \
		${SED} -e 's/use Class::MethodMaker/use Class::MakeMethods::Emulator::MethodMaker/' $$f > $$f.new && \
		${MV} -f $$f.new $$f; \
	done

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"