[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / pgpenvelope

File: [cvs.NetBSD.org] / pkgsrc / security / pgpenvelope / Makefile (download)

Revision 1.16, Fri May 31 12:41:57 2013 UTC (10 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.15: +2 -2 lines

Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

# $NetBSD: Makefile,v 1.16 2013/05/31 12:41:57 wiz Exp $
#

DISTNAME=		pgpenvelope-2.10.2
PKGREVISION=		9
CATEGORIES=		security mail
MASTER_SITES=		${MASTER_SITE_SOURCEFORGE:=pgpenvelope/}

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://pgpenvelope.sourceforge.net/
COMMENT=		GnuPG and Pine/Procmail integration tool

DEPENDS+=		p5-AppConfig>=1.52:../../devel/p5-AppConfig
DEPENDS+=		p5-Class-MakeMethods>=1.010:../../devel/p5-Class-MakeMethods
DEPENDS+=		p5-GnuPG-Interface>=0.34nb2:../../security/p5-GnuPG-Interface
DEPENDS+=		p5-String-Approx>=3.13:../../textproc/p5-String-Approx
DEPENDS+=		p5-Term-ReadKey>=2.14:../../devel/p5-Term-ReadKey
DEPENDS+=		p5-Term-ReadLine>=1.01:../../devel/p5-Term-ReadLine

PERL5_PACKLIST=		auto/pgpenvelope/.packlist

pre-configure:
	cd ${WRKSRC}/lib/PGPEnvelope && for f in *.pm; do \
		${SED} -e 's/use Class::MethodMaker/use Class::MakeMethods::Emulator::MethodMaker/' $$f > $$f.new && \
		${MV} -f $$f.new $$f; \
	done

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"