[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / pgp2

Annotation of pkgsrc/security/pgp2/Makefile, Revision 1.33

1.33    ! jschauma    1: # $NetBSD: Makefile,v 1.32 2003/03/14 19:37:55 jlam Exp $
1.1       tv          2: # FreeBSD Id: Makefile,v 1.20 1997/08/27 13:06:01 ache Exp
                      3: #
                      4:
1.3       frueauf     5: DISTNAME=      pgp263is
                      6: WRKSRC=                ${WRKDIR}/src
                      7: CATEGORIES=    security
                      8: MASTER_SITES=  ftp://ftp.ifi.uio.no/pub/pgp/2.x/src/ \
                      9:                ftp://ftp.kiarchive.ru/pub/unix/crypto/pgp/
                     10:
1.33    ! jschauma   11: MAINTAINER=    tech-pkg@netbsd.org
1.12      tsarna     12: HOMEPAGE=      http://www.pgpi.com/
1.28      wiz        13: COMMENT=       Public-Key encryption and digital signature utility
1.4       agc        14:
1.25      fredb      15: CRYPTO=                yes
1.26      fredb      16: USE_RSAREF2=   NO
1.27      itojun     17:
                     18: # use of IDEA as crypto function
                     19: LICENCE=       fee-based-commercial-use
1.25      fredb      20:
1.9       agc        21: .include "../../mk/bsd.prefs.mk"
1.3       frueauf    22:
1.1       tv         23: .if defined(USE_RSAREF2) && ${USE_RSAREF2} == YES
1.3       frueauf    24: PKGNAME=       pgp-2.6.3a
1.21      abs        25: DEPENDS+=      rsaref-2.0p3:../../security/rsaref
1.1       tv         26: RSAINC=                -I${PREFIX}/include
1.32      jlam       27: RSALIBS=       -Wl,${RPATH_FLAG}${PREFIX}/lib -L${PREFIX}/lib -lrsaref
1.1       tv         28: RSAOBJS=       rsaglue2.o
                     29: CFLAGS=                -DUSA
                     30: .else
1.3       frueauf    31: PKGNAME=       pgp-2.6.3ia
1.1       tv         32: RSAINC=
                     33: RSALIBS=
                     34: RSAOBJS=       rsaglue1.o
                     35: CFLAGS=
                     36: .endif
1.32      jlam       37:
                     38: FIX_RPATH+=    RSALIBS
1.24      hubertf    39:
1.14      kim        40: PGPLIB=                ${PREFIX}/share/pgp
1.1       tv         41: CFLAGS+=       -DPGP_SYSTEM_DIR=\\\"${PGPLIB}/\\\"
                     42:
1.29      tron       43: .if (${MACHINE_ARCH} == "i386")
1.1       tv         44: OBJS_EXT=      _80386.o _zmatch.o
                     45: ASMFLAG=       -DASM
1.29      tron       46: .elif (${MACHINE_ARCH} == "m68k")
1.11      is         47: .ifdef M68060
                     48: OBJS_EXT=
1.13      frueauf    49: ASMFLAG=       -m68060 -DPORTABLE -DMPORTABLE
1.11      is         50: .else
1.1       tv         51: OBJS_EXT=      mc68020.o
                     52: ASMFLAG=
1.11      is         53: .endif
1.29      tron       54: .elif (${MACHINE_ARCH} == "sparc") && (${OPSYS} != SunOS)
1.1       tv         55: OBJS_EXT=      sparc.o
                     56: ASMFLAG=
                     57: .else
                     58: OBJS_EXT=
                     59: ASMFLAG=       -DPORTABLE -DMPORTABLE
1.31      grant      60: .endif
                     61:
                     62: .include "../../mk/endian.mk"
                     63:
                     64: .if (${MACHINE_ENDIAN} == "big")
                     65: CFLAGS+=        -DHIGHFIRST
1.1       tv         66: .endif
1.20      agc        67:
                     68: BUILD_DEFS+=   USE_RSAREF2 M68060 ASMFLAG
1.1       tv         69:
                     70: .if !defined(USE_RSAREF2) || ${USE_RSAREF2} != YES && ${USE_RSAREF2} != NO
                     71: pre-fetch:
1.2       tv         72:        @${ECHO}
                     73:        @${ECHO} The variable USE_RSAREF2 must be set to either YES or NO
1.8       hubertf    74:        @${ECHO} in order to build this package.  USA residents that are
                     75:        @${ECHO} no licensees of the RSA algorithm MUST set this variable
                     76:        @${ECHO} to YES.  Users outside the USA MUST set this variable to
                     77:        @${ECHO} NO.  Licensees may choose -- NO is faster.
1.2       tv         78:        @${FALSE}
1.1       tv         79: .endif
                     80:
                     81: post-extract:
1.17      mycroft    82:        cd ${WRKDIR} && ${GTAR} xf pgp263ii.tar && ${RM} -f pgp263ii.tar
1.1       tv         83:
                     84: do-build:
1.23      mycroft    85:        cd ${WRKSRC} && ${MAKE} all CC="${CC}" LD="${CC}" \
                     86:                OBJS_EXT="${OBJS_EXT}" \
1.3       frueauf    87:                CFLAGS="${CFLAGS} ${RSAINC} ${ASMFLAG} -O2 -DUNIX -DIDEA32 \
                     88:                -DMAX_NAMELEN=255" RSALIBS="${RSALIBS}" RSAOBJS="${RSAOBJS}"
1.1       tv         89:
                     90: do-install:
                     91:        ${INSTALL_PROGRAM} ${WRKSRC}/pgp ${PREFIX}/bin
                     92:        ${INSTALL_DATA} ${WRKDIR}/doc/pgp.1 ${PREFIX}/man/man1
1.30      hubertf    93:        ${INSTALL_DATA_DIR} ${PGPLIB}
1.1       tv         94:        cd ${WRKDIR}/doc && ${INSTALL_DATA} pgpdoc1.txt pgpdoc2.txt ${PGPLIB}
                     95:        cd ${WRKDIR} && \
                     96:                ${INSTALL_DATA} de.hlp en.hlp es.hlp fr.hlp pgp.hlp ${PGPLIB}
                     97:        [ -f ${PGPLIB}/language.txt ] || \
                     98:                ${INSTALL_DATA} ${WRKDIR}/language.txt ${PGPLIB}
                     99:        [ -f ${PGPLIB}/config.txt ] || \
                    100:                ${INSTALL_DATA} ${WRKDIR}/config.txt ${PGPLIB}
                    101:        [ -f ${PGPLIB}/pgp.hlp ] || \
                    102:                ${INSTALL_DATA} ${WRKDIR}/en.hlp ${PGPLIB}/pgp.hlp
                    103:
1.5       agc       104: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>