The NetBSD Project

CVS log for pkgsrc/security/pcsc-tools/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / security / pcsc-tools

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.26 / (download) - annotate - [select for diffs], Mon Jan 1 11:41:38 2024 UTC (2 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.25: +3 -3 lines
Diff to previous 1.25 (colored)

pcsc-tools: updated to 1.7.1

1.7.1
Bug fixes

Revision 1.25 / (download) - annotate - [select for diffs], Wed Oct 18 15:39:54 2023 UTC (5 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4
Changes since 1.24: +4 -13 lines
Diff to previous 1.24 (colored)

pcsc-tools: updated to 1.7.0

1.7.0
Fix make distclean
Do not fail if the po/*.gmo files do not exist.
11 new ATRs
Update pcsc_scan manpage
Document -c, -d and -p arguments
configure: do not fail if gettext is not found
If gettext is not installed then just do not use it.

Revision 1.24 / (download) - annotate - [select for diffs], Tue Feb 21 16:34:14 2023 UTC (13 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.23: +12 -10 lines
Diff to previous 1.23 (colored)

pcsc-tools: updated to 1.6.2

1.6.2 - 22 January 2023, Ludovic ROUSSEAU
- 18 new ATRs
- smartcard_list.txt moved to https://pcsc-tools.apdu.fr/smartcard_list.txt

1.6.1 - 30 December 2022, Ludovic ROUSSEAU
- 196 new ATRs
- use colors on NetBSD ("wsvt25" terminal)
- pcsc_scan: always print the version in verbose mode

1.6.0 - 29 January 2022, Ludovic ROUSSEAU
- 48 new ATRs
- pcsc_scan:
 . drastically reduce the number of SCardGetStatusChange() calls
 . faster spinning animation
 . handle Ctrl-C on macOS

1.5.8 - 7 November 2021, Ludovic ROUSSEAU
- 360 new ATRs
- ATR_analysis:
 . fix TB2 parsing error
 . misc spelling fixes
- pcsc_scan:
 . add maxtime option -t
 . add the option -c to list cards only once
 . no spinner in quiet mode (-q)
 . turn off colour if redirected output
 . Exit if no reader is found and -c or -r is used

1.5.7 - 7 July 2020, Ludovic ROUSSEAU
- 116 new ATRs
- ATR_analysis: Update URL of the online parser

1.5.6 - 8 March 2020, Ludovic ROUSSEAU
- 62 new ATRs
- pcsc_scan: better support of Windows

1.5.5 - 4 January 2020, Ludovic ROUSSEAU
- 353 new ATRs
- scriptor: add -u option to make stdout unbuffered

1.5.4 - 12 December 2018, Ludovic ROUSSEAU
- 213 new ATRs
- pcsc_scan: display the number of events
- gscriptor: port from Gtk+2 to Gtk+3

1.5.3 - 15 April 2018, Ludovic ROUSSEAU
- 253 new ATRs
- pcsc_scan (thanks to Pascal J. Bourguignon):
 . add -v argument (default) for verbose
 . add -q argument for quiet
 . add -r argument to display the reader list
 . allow to use Control-C to break execution

1.5.2 - 28 May 2017, Ludovic ROUSSEAU
- include gscriptor.desktop and test.script in the archive

1.5.1 - 28 May 2017, Ludovic ROUSSEAU
- rename the archive pcsc-tools

1.5.0 - 28 May 2017, Ludovic ROUSSEAU
- 221 new ATRs
- pcsc_scan:
  . add APDU stress mode (-s) (send "Select MF" APDU in a loop)
  . display an animation while waiting for a card or reader event
- use autoconf/automake
  . macOS support with no change
  . Windows support (using MSYS2 http://www.msys2.org/)

Revision 1.23 / (download) - annotate - [select for diffs], Tue Jun 28 11:35:50 2022 UTC (21 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

*: recursive bump for perl 5.36

Revision 1.22 / (download) - annotate - [select for diffs], Mon May 24 19:54:05 2021 UTC (2 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

*: recursive bump for perl 5.34

Revision 1.21 / (download) - annotate - [select for diffs], Mon Aug 31 18:11:20 2020 UTC (3 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

*: bump PKGREVISION for perl-5.32.

Revision 1.20 / (download) - annotate - [select for diffs], Sun Aug 11 13:22:59 2019 UTC (4 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Bump PKGREVISIONs for perl 5.30.0

Revision 1.19 / (download) - annotate - [select for diffs], Wed Aug 22 09:46:28 2018 UTC (5 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.18: +2 -1 lines
Diff to previous 1.18 (colored)

Recursive bump for perl5-5.28.0

Revision 1.18 / (download) - annotate - [select for diffs], Wed Jul 4 13:40:35 2018 UTC (5 years, 8 months ago) by jperkin
Branch: MAIN
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

*: Move SUBST_STAGE from post-patch to pre-configure

Performing substitutions during post-patch breaks tools such as mkpatches,
making it very difficult to regenerate correct patches after making changes,
and often leading to substituted string replacements being committed.

Revision 1.17 / (download) - annotate - [select for diffs], Thu Feb 16 14:47:56 2017 UTC (7 years, 1 month ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.16: +2 -3 lines
Diff to previous 1.16 (colored)

Update to 1.4.27

Summary of upstream changelog:

    bug fixes
    many new ATRs

    ATR_analysis: propose to submit the ATR if not known
      We propose to submit the ATR at http://smartcard-atr.appspot.com/ when
      the ATR is not found in the list.
      The message is always displayed for an unknown ATR, not just after the
      list has been updated.

    ATR_analysis: correctly use wget to store the ATR list

Revision 1.16 / (download) - annotate - [select for diffs], Sat Jul 9 06:38:56 2016 UTC (7 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.15: +2 -1 lines
Diff to previous 1.15 (colored)

Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.

Revision 1.15 / (download) - annotate - [select for diffs], Mon Sep 7 19:37:17 2015 UTC (8 years, 6 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.14: +2 -3 lines
Diff to previous 1.14 (colored)

Update to 1.4.24.

1.4.24 - 7 August 2015, Ludovic ROUSSEAU
    - 253 new ATRs
    - ATR_analysis: better update of the local cache

1.4.23 - 13 September 2014, Ludovic ROUSSEAU
    - 137 new ATRs

Revision 1.14 / (download) - annotate - [select for diffs], Mon Jul 13 09:54:20 2015 UTC (8 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.13: +3 -4 lines
Diff to previous 1.13 (colored)

Adapt for p5-pcsc name change. Bump PKGREVISION.

Revision 1.13 / (download) - annotate - [select for diffs], Fri Jun 12 10:51:09 2015 UTC (8 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.

Revision 1.12 / (download) - annotate - [select for diffs], Thu May 29 23:37:25 2014 UTC (9 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.11: +2 -1 lines
Diff to previous 1.11 (colored)

Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

Revision 1.11 / (download) - annotate - [select for diffs], Tue Feb 25 18:02:36 2014 UTC (10 years, 1 month ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.10: +2 -3 lines
Diff to previous 1.10 (colored)

Update to 1.4.22.

http://ludovicrousseau.blogspot.fr/2014/01/new-version-of-pcsc-tools-1422.html
Changes:
1.4.22 - 17 January 2014, Ludovic ROUSSEAU
    - 215 new ATRs
    - Fetch a new ATR file if it was not upgraded in the last 10
      hours.
    - Propose to use http://smartcard-atr.appspot.com/parse to submit a
      new ATR
    - minor fixes

Revision 1.10 / (download) - annotate - [select for diffs], Fri May 31 12:41:57 2013 UTC (10 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.9: +2 -1 lines
Diff to previous 1.9 (colored)

Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

Revision 1.9 / (download) - annotate - [select for diffs], Fri Feb 1 22:21:11 2013 UTC (11 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

Reset MAINTAINER/OWNER (became observers)

Revision 1.8 / (download) - annotate - [select for diffs], Sat Dec 15 00:53:26 2012 UTC (11 years, 3 months ago) by pettai
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.7: +2 -3 lines
Diff to previous 1.7 (colored)

1.4.21
    - Do not log the time every second on "old" PC/SC without support of
      \\?PnP?\Notification like on Mac OS X.
    - 79 new ATRS
    - minor fixes

1.4.20 - 16 June 2012, Ludovic ROUSSEAU
    - Makefile: Add arguments to CFLAGS instead of overwritting them
    - 3 new ATRs

1.4.19
    - ATR_analysis: use XDG_CACHE_HOME env variable
      The smartcard_list.txt file is now searched in ~/.cache/ by default
    - 115 new ATRs

1.4.18
    - gscriptor: Display hex dumps in lines of 16 bytes instead of 17
    - gscriptor: Display bytes of value 0x20 as ' ' instead of '.'
    - scriptor: Display lines of 16 bytes instead of 24
    - 223 new ATRs
    - pcsc_scan: Correctly detect reader Plug and Play support

1.4.17
    - 153 new ATRs
    - Allow to build with pcsc-lite >= 1.6.2

1.4.16
    - 153 new ATR
    - pcsc_scan.c: check for PnP support at run time instead of using a
      #define
    - ATR_analysis: use curl instead of wget on Darwin
    - gscriptor: ReaderConfig(): escape metacharacters []() in
      the reader name when using reader name as a pattern matching

Revision 1.7 / (download) - annotate - [select for diffs], Tue Oct 23 18:16:49 2012 UTC (11 years, 5 months ago) by asau
Branch: MAIN
Changes since 1.6: +1 -3 lines
Diff to previous 1.6 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.6 / (download) - annotate - [select for diffs], Wed Oct 3 21:57:33 2012 UTC (11 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.

Revision 1.5 / (download) - annotate - [select for diffs], Thu May 26 13:32:26 2011 UTC (12 years, 10 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.4: +8 -7 lines
Diff to previous 1.4 (colored)

* LICENSE=gnu-gpl-v2 # or later
* honor PKGMANDIR
* add user-destdir installation support
* use ${PERL5} as shebang, not /usr/bin/env.

Bump PKGREVISION.

Revision 1.4 / (download) - annotate - [select for diffs], Sun Nov 28 10:47:40 2010 UTC (13 years, 4 months ago) by shattered
Branch: MAIN
CVS Tags: pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4
Changes since 1.3: +3 -2 lines
Diff to previous 1.3 (colored)

Install manpages in man/, not share/man/

Revision 1.3 / (download) - annotate - [select for diffs], Mon Mar 16 19:14:08 2009 UTC (15 years ago) by hasso
Branch: MAIN
CVS Tags: pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1
Changes since 1.2: +3 -3 lines
Diff to previous 1.2 (colored)

Update to version 1.4.15. Many small fixes and new ATRs in the list. See
Changelog in the source tarball for full commit log.

Revision 1.2 / (download) - annotate - [select for diffs], Thu Apr 10 07:56:09 2008 UTC (15 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Fix path in DEPENDS line.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Tue Mar 4 11:32:15 2008 UTC (16 years ago) by shannonjr
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2008Q1-base, pkgsrc-2008Q1
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Provides several tools that are useful when working
with smart cards: csc_scan regularly scans every
PC/SC reader connected to the host and reports when
a card is inserted or removed. ATR_analysis is a Perl
script used to parse the smart card ATR. The 
smartcard_list.txt contains ATR of some cards. It is
used by ATR_analysis to find a card model corresponding
to the ATR. The perl script scriptortis used to send 
commands to a smart card using a batch file or stdin.

Revision 1.1 / (download) - annotate - [select for diffs], Tue Mar 4 11:32:15 2008 UTC (16 years ago) by shannonjr
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>