[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / pakemon

File: [cvs.NetBSD.org] / pkgsrc / security / pakemon / Makefile (download)

Revision 1.18, Fri Jan 28 23:35:59 2005 UTC (19 years, 2 months ago) by adrianp
Branch: MAIN
Changes since 1.17: +3 -1 lines

Force all current packages using the libnet 1.0.x tree to use a
verision of libnet <= 1.0.1b.  This will prevent the case where the user
has installed the libnet 1.1.x branch and then tries to install an application
that is not compatible with the 1.1.x tree.

Over time the list of these applications that require the 1.0.x branch
will be reduced as they are updated to later versions that support the
libnet 1.1.x branch.

This addresses PR# 29056 opened by diro (at) nixsys.bz, thanks for the PR !

# $NetBSD: Makefile,v 1.18 2005/01/28 23:35:59 adrianp Exp $

DISTNAME=	pakemon-0.3.1
PKGREVISION=	3
CATEGORIES=	security
MASTER_SITES=	http://www.sfc.keio.ac.jp/~keiji/ids/pakemon/ \
		http://www.binarii.com/files/security/ \
		http://www.mirrors.wiretapped.net/security/network-intrusion-detection/pakemon/

MAINTAINER=	tech-pkg@NetBSD.org
HOMEPAGE=	http://web.sfc.keio.ac.jp/~keiji/backup/ids/pakemon/index.html
COMMENT=	Packet monster, an Open Source Intrusion Detection System

USE_BUILDLINK3=	yes
GNU_CONFIGURE=	yes

BUILDLINK_DEPENDS.libnet+=	libnet<=1.0.1b

post-extract:
	${CP} ${WRKSRC}/pakemon.h ${WRKSRC}/pakemon.h.in

.include "../../net/libpcap/buildlink3.mk"
.include "../../devel/libnet/buildlink3.mk"
.include "../../net/libnids/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"