[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / p5-pcsc

File: [cvs.NetBSD.org] / pkgsrc / security / p5-pcsc / Makefile (download)

Revision 1.9, Tue Oct 23 18:16:47 2012 UTC (10 years, 7 months ago) by asau
Branch: MAIN
Changes since 1.8: +1 -2 lines

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.9 2012/10/23 18:16:47 asau Exp $

DISTNAME=	pcsc-perl-1.4.12
PKGNAME=	p5-${DISTNAME}
PKGREVISION=	1
CATEGORIES=	security
MASTER_SITES=	http://ludovic.rousseau.free.fr/softwares/pcsc-perl/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	shannonjr@NetBSD.org
HOMEPAGE=	http://ludovic.rousseau.free.fr/softwares/pcsc-perl/
COMMENT=	Allows communication with a smart card from a Perl script

PERL5_MODULE_TYPE=	MakeMaker
LICENSE=		gnu-gpl-v2

SUBST_CLASSES+=		perl
SUBST_STAGE.perl=	post-patch
SUBST_FILES.perl=	Card/t/test.t examples/test_iso_error.pl examples/gsm_directory.pl t/test.t test/multiple_readers.pl test/single_reader.pl
SUBST_SED.perl=		-e 's,/usr/bin/perl,${PERL5},'

PERL5_USE_PACKLIST=	yes
MAKE_PARAMS+=		INSTALLDIRS=vendor
PERL5_PACKLIST=		auto/Chipcard/PCSC/.packlist

USE_TOOLS+=		pkg-config

.include "../../lang/perl5/module.mk"
.include "../../security/pcsc-lite/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"