[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / p5-Crypt-RSA

File: [cvs.NetBSD.org] / pkgsrc / security / p5-Crypt-RSA / Makefile (download)

Revision 1.18, Sat Mar 24 18:35:14 2007 UTC (17 years, 1 month ago) by heinz
Branch: MAIN
CVS Tags: pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.17: +5 -2 lines

Updated to version 1.58.

Pkgsrc changes:
  - Added CHECK_INTERPRETER_SKIP patterns to stop complaints about
    non-existing "/usr/bin/perl" interpreter.

Changes since version 1.57:
===========================
1.58                                                          Dec 21, 2006
 * We turn on binmode() on filehandles when reading and writing
   keys from disk, so allow safe exchange of SSH private keys
   from Windows and *nix systems. Thanks to Ulisses Gomes
   <ulisses@ibiz.com.br> for pointing this out.
 * Include a copy of the GPL in the distribution. This addresses
   bug #18771. (http://rt.cpan.org/Public/Bug/Display.html?id=18771)
 * Removed warnings from t/15-benchmark.t

# $NetBSD: Makefile,v 1.18 2007/03/24 18:35:14 heinz Exp $
#

DISTNAME=		Crypt-RSA-1.58
PKGNAME=		p5-${DISTNAME}
SVR4_PKGNAME=		p5rsa
CATEGORIES=		security perl5
MASTER_SITES=		${MASTER_SITE_PERL_CPAN:=Crypt/}

MAINTAINER=		heinz@NetBSD.org
HOMEPAGE=		http://search.cpan.org/dist/Crypt-RSA/
COMMENT=		Perl5 module of the RSA public key algorithm

DEPENDS+=		p5-Math-Pari>=2.001804:../../math/p5-Math-Pari
DEPENDS+=		p5-Crypt-Random>=0.34:../../security/p5-Crypt-Random
DEPENDS+=		p5-Crypt-Primes>=0.38:../../security/p5-Crypt-Primes
DEPENDS+=		p5-Crypt-CBC-[0-9]*:../../security/p5-Crypt-CBC
DEPENDS+=		p5-Crypt-Blowfish-[0-9]*:../../security/p5-Crypt-Blowfish
DEPENDS+=		p5-Tie-EncryptedHash-[0-9]*:../../security/p5-Tie-EncryptedHash
DEPENDS+=		p5-Convert-ASCII-Armour-[0-9]*:../../textproc/p5-Convert-ASCII-Armour
DEPENDS+=		p5-Sort-Versions-[0-9]*:../../devel/p5-Sort-Versions
DEPENDS+=		p5-Digest-SHA1-[0-9]*:../../security/p5-Digest-SHA1
DEPENDS+=		p5-Digest-MD5>=2.16:../../security/p5-Digest-MD5
DEPENDS+=		p5-Digest-MD2-[0-9]*:../../security/p5-Digest-MD2
DEPENDS+=		p5-Class-Loader>=2.00:../../devel/p5-Class-Loader
DEPENDS+=		p5-Data-Buffer-[0-9]*:../../devel/p5-Data-Buffer

PKG_INSTALLATION_TYPES=	overwrite pkgviews

USE_LANGUAGES=		# empty
PERL5_PACKLIST=		auto/Crypt/RSA/.packlist

CHECK_INTERPRETER_SKIP+=${PERL5_SUB_INSTALLVENDORLIB}/Crypt/RSA.pm
CHECK_INTERPRETER_SKIP+=${PERL5_SUB_INSTALLVENDORLIB}/Crypt/RSA/*

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"