[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / p5-Authen-PluggableCaptcha

File: [cvs.NetBSD.org] / pkgsrc / security / p5-Authen-PluggableCaptcha / Makefile (download)

Revision 1.17, Mon May 24 19:53:55 2021 UTC (2 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.16: +2 -2 lines

*: recursive bump for perl 5.34

# $NetBSD: Makefile,v 1.17 2021/05/24 19:53:55 wiz Exp $
#

DISTNAME=	Authen-PluggableCaptcha-0.05
PKGNAME=	p5-${DISTNAME}
PKGREVISION=	12
CATEGORIES=	security perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN:=Authen/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://metacpan.org/release/Authen-PluggableCaptcha
COMMENT=	Perl5 module implementing a pluggable Captcha framework
LICENSE=	${PERL5_LICENSE}

DEPENDS+=	p5-Number-Spell>=0.04:../../textproc/p5-Number-Spell
DEPENDS+=	p5-HTML-Email-Obfuscate>=0.02:../../www/p5-HTML-Email-Obfuscate

REPLACE_PERL+=	lib/Authen/PluggableCaptcha/ErrorLoggingObject.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Challenge.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Challenge/DoMath.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Challenge/TypeString.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Helpers.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/KeyManager.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Image.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Image/Imager.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Image/Imager/effects.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Image/Imager/effects/sinewarp.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Image/Imager/layers.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Image/Imager/layers/bg.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Image/Imager/layers/distraction_lines.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Image/Imager/layers/text.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Text.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Text/HTML.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/Render/Text/Plain.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/StandardAttributesObject.pm
REPLACE_PERL+=	lib/Authen/PluggableCaptcha/ValidityObject.pm

PERL5_PACKLIST=	auto/Authen/PluggableCaptcha/.packlist

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"