[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / openssl

Annotation of pkgsrc/security/openssl/Makefile, Revision 1.23

1.23    ! itojun      1: # $NetBSD: Makefile,v 1.22 2000/09/28 16:31:15 hubertf Exp $
1.1       tv          2: #
                      3:
1.13      explorer    4: DISTNAME=              openssl-0.9.5a
1.1       tv          5: CATEGORIES=            security
1.16      tron        6: MASTER_SITES=          ftp://ftp.openssl.org/source/ \
                      7:                        ftp://ftp.uni-trier.de/pub/unix/security/openssl/
1.6       tv          8:
1.3       tv          9: MAINTAINER=            packages@netbsd.org
1.1       tv         10: HOMEPAGE=              http://www.openssl.org/
                     11:
1.20      wennmach   12: CONFLICTS=             SSLeay-* ssleay-* kth-krb4-*
1.1       tv         13:
1.21      fredb      14: CRYPTO=                        YES
                     15: USE_PERL5=             YES
                     16: USE_RSAREF2=           NO
1.23    ! itojun     17:
        !            18: # supplies IDEA/RC5
        !            19: LICENCE=               fee-based-commercial-use
1.17      hubertf    20:
1.22      hubertf    21: # matches what's in `Configure' (except sparc64 and alpha, see PR 10984)
                     22: ONLY_FOR_PLATFORM=     NetBSD-*-arm32 NetBSD-*-i386 \
1.7       tron       23:                        NetBSD-*-m68k NetBSD-*-mips NetBSD-*-mipseb \
1.8       simonb     24:                        NetBSD-*-mipsel NetBSD-*-ns32k NetBSD-*-powerpc \
1.14      veego      25:                        NetBSD-*-sparc NetBSD-*-vax \
                     26:                        SunOS-*
1.1       tv         27:
1.9       erh        28: CONFIGURE_ARGS=                -fPIC -DPIC --openssldir=${PREFIX} --prefix=${PREFIX} \
                     29:                        ${LDFLAGS}
1.1       tv         30: #CONFIGURE_ENV=                PREFIX=${PREFIX}
1.14      veego      31:
                     32: .include "../../mk/bsd.prefs.mk"
                     33:
                     34: PATCHDIR=              ${WRKDIR}/.patches
                     35: .if ${OPSYS} == "NetBSD"
1.1       tv         36: MAKE_ENV=              LD_LIBRARY_PATH=${WRKSRC} MAKELIB=${FILESDIR}/makelib
1.14      veego      37: .endif
1.1       tv         38:
1.14      veego      39: PLIST_SRC=             ${WRKDIR}/.PLIST_SRC
1.10      erh        40:
1.14      veego      41: .if ${OPSYS} == "NetBSD" && !exists(/usr/libexec/ld.elf_so) && !exists(/usr/libexec/ld.so)
1.18      hubertf    42: IGNORE=                        ${PKGNAME} requires shared object support
1.1       tv         43: .endif
                     44:
                     45: .if defined(USE_RSAREF2) && ${USE_RSAREF2} == YES
1.11      abs        46: DEPENDS=               rsaref-2.0p3:../../security/rsaref
1.9       erh        47: CONFIGURE_ARGS+=       rsaref
1.14      veego      48: PLIST_RSAREF=          ${PKGDIR}/PLIST.rsaref
1.1       tv         49: .endif
                     50:
1.14      veego      51: pre-patch:
                     52:        ${MKDIR} ${WRKDIR}/.patches
                     53:        @${CP} ${.CURDIR}/patches/patch-* ${WRKDIR}/.patches
                     54: .if ${OPSYS} == "NetBSD"
                     55:        for FILE in ${.CURDIR}/patches/patch.netbsd-*; do \
1.15      veego      56:                ${CP} $$FILE ${PATCHDIR}/patch-$${FILE##*-}; \
1.14      veego      57:        done
                     58: .endif
                     59:
1.1       tv         60: # The Perl stuff doesn't work yet (nor did it work properly in SSLeay...)
                     61: do-configure:
1.19      jlam       62:        @cd ${WRKSRC} && ${PERL5} util/perlpath.pl ${LOCALBASE}/bin
1.1       tv         63:        @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./config ${CONFIGURE_ARGS}
1.19      jlam       64: #      @cd ${WRKSRC}/perl && ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
1.1       tv         65:
                     66: #post-build:
                     67: #      @cd ${WRKSRC}/perl && ${MAKE}
                     68:
                     69: do-install:
                     70:        ${INSTALL_PROGRAM} ${WRKSRC}/apps/openssl ${PREFIX}/bin/
                     71:        @cd ${PREFIX}/bin && \
                     72:        for file in asn1parse base64 bf bf-cbc bf-cfb bf-ecb bf-ofb ca \
                     73:        cast cast-cbc cast5-cbc cast5-cfb cast5-ecb cast5-ofb ciphers crl \
                     74:        crl2pkcs7 des des-cbc des-cfb des-ecb des-ede des-ede-cbc des-ede-cfb \
                     75:        des-ede-ofb des-ede3 des-ede3-cbc des-ede3-cfb des-ede3-ofb \
                     76:        des-ofb des3 desx dgst dh dsa dsaparam enc errstr gendh gendsa \
                     77:        genrsa idea idea-cbc idea-cfb idea-ecb idea-ofb md2 mdc2 nseq \
1.9       erh        78:        pkcs12 pkcs7 pkcs8 rc2 rc2-cbc rc2-cfb rc2-ecb rc2-ofb rc4 rc5 \
                     79:        rc5-cbc rc5-cfb rc5-ecb rc5-ofb req rmd160 rsa s_client s_server \
                     80:        s_time sess_id sha sha1 speed verify version x509; do \
1.1       tv         81:                ${LN} -sf openssl $$file; \
                     82:        done
                     83:        cd ${WRKSRC}/tools && ${INSTALL_SCRIPT} \
                     84:                c_hash c_info c_issuer c_name c_rehash ${PREFIX}/bin/
                     85:        ${SED} -e s,/usr/local,${PREFIX}, ${WRKSRC}/apps/der_chop >${WRKDIR}/der_chop && \
                     86:                ${INSTALL_SCRIPT} ${WRKDIR}/der_chop ${PREFIX}/bin/
                     87:        cd ${WRKSRC}/apps && ${INSTALL_SCRIPT} CA.sh CA.pl ${PREFIX}/bin/
                     88:        ${INSTALL_DATA} ${WRKSRC}/apps/openssl.cnf ${PREFIX}/etc/openssl.cnf.example
1.14      veego      89:        cd ${WRKSRC} && ${INSTALL_DATA} libcrypto.a libssl.a ${PREFIX}/lib/
                     90: .if ${OPSYS} == "NetBSD"
                     91:        cd ${WRKSRC} && ${INSTALL_DATA} libcrypto.so.?.0 libssl.so.?.0 ${PREFIX}/lib/
                     92: .endif
1.12      fredb      93: .if exists(/usr/bin/ranlib)
                     94:        /usr/bin/ranlib ${PREFIX}/lib/libcrypto.a
                     95:        /usr/bin/ranlib ${PREFIX}/lib/libssl.a
                     96: .endif
1.10      erh        97: .if defined(USE_RSAREF2) && ${USE_RSAREF2} == YES
                     98:        # libRSAglue.a is only useful if you are using the RSAREF2 library.
                     99:        cd ${WRKSRC} && ${INSTALL_DATA} libRSAglue.a ${PREFIX}/lib/
                    100: .endif
1.1       tv        101:        ${INSTALL_DATA_DIR} ${PREFIX}/include/openssl
1.9       erh       102:        cd ${WRKSRC}/include/openssl && \
                    103:        for file in \
                    104:        asn1.h asn1_mac.h bio.h blowfish.h bn.h buffer.h cast.h comp.h conf.h \
                    105:        crypto.h des.h dh.h dsa.h e_os.h e_os2.h ebcdic.h err.h evp.h hmac.h \
                    106:        idea.h lhash.h md2.h md5.h mdc2.h objects.h opensslconf.h opensslv.h \
                    107:        pem.h pem2.h pkcs12.h pkcs7.h rand.h rc2.h rc4.h rc5.h ripemd.h rsa.h \
                    108:        safestack.h sha.h ssl.h ssl2.h ssl23.h ssl3.h stack.h tls1.h tmdiff.h \
                    109:        txt_db.h x509.h x509_vfy.h x509v3.h ; do \
1.1       tv        110:                ${INSTALL_DATA} $$file ${PREFIX}/include/openssl/; \
                    111:        done
                    112: #      @cd ${WRKSRC}/perl && ${MAKE} install
                    113:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/openssl
1.13      explorer  114:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/openssl/apps
                    115:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/openssl/crypto
                    116:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/openssl/ssl
                    117:        ${INSTALL_DATA} ${WRKSRC}/doc/apps/* \
                    118:                ${PREFIX}/share/doc/openssl/apps/
                    119:        ${INSTALL_DATA} ${WRKSRC}/doc/crypto/* \
                    120:                ${PREFIX}/share/doc/openssl/crypto/
                    121:        ${INSTALL_DATA} ${WRKSRC}/doc/ssl/* \
                    122:                ${PREFIX}/share/doc/openssl/ssl/
                    123:        for file in README c-indentation.el openssl.txt openssl_button.gif \
                    124:        openssl_button.html ssleay.txt ; do \
                    125:                ${INSTALL_DATA} ${WRKSRC}/doc/$$file \
                    126:                        ${PREFIX}/share/doc/openssl/; \
                    127:        done
1.14      veego     128:        ${INSTALL_DATA_DIR} ${PREFIX}/certs
                    129:        ${INSTALL_DATA_DIR} ${PREFIX}/private
1.1       tv        130:        @if [ ! -f ${PREFIX}/etc/openssl.cnf ]; then \
                    131:                ${CP} -p ${PREFIX}/etc/openssl.cnf.example ${PREFIX}/etc/openssl.cnf; \
                    132:        fi
1.14      veego     133:
                    134: post-install:
                    135:        ${CAT} ${PKGDIR}/PLIST.common ${PKGDIR}/PLIST.${LOWER_OPSYS} \
                    136:                ${PLIST_RSAREF} > ${PLIST_SRC}
1.1       tv        137:
                    138: .include  "../../mk/bsd.pkg.mk"
                    139:
                    140: test: all
                    141:        @cd ${WRKSRC}/test && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} ${MAKE} tests
                    142:        @${ECHO} "*** Tests successful. ***"

CVSweb <webmaster@jp.NetBSD.org>