[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / openssl

Annotation of pkgsrc/security/openssl/Makefile, Revision 1.1

1.1     ! tv          1: # $NetBSD: Makefile,v 1.14 1998/08/26 02:42:02 kim Exp $
        !             2: #
        !             3:
        !             4: DISTNAME=              openssl-0.9.2b
        !             5: CATEGORIES=            security
        !             6: MASTER_SITES=          ftp://ftp.openssl.org/source/
        !             7:
        !             8: PATCH_SITES=           ${MASTER_SITES}
        !             9: PATCHFILES=            openssl-0.9.2b-rsaoaep.patch
        !            10:
        !            11: MAINTAINER=            packages@NetBSD.ORG
        !            12: HOMEPAGE=              http://www.openssl.org/
        !            13:
        !            14: CONFLICTS=             SSLeay-* ssleay-*
        !            15:
        !            16: USE_PERL5=             yes
        !            17:
        !            18: RESTRICTED=            "Crypto; export-controlled"
        !            19: MIRROR_DISTFILE=       no
        !            20: # matches what's in `Configure' (except sparc64)
        !            21: ONLY_FOR_ARCHS=                alpha arm32 i386 m68k mips mipse[bl] ns32k powerpc \
        !            22:                        sparc vax
        !            23:
        !            24: CONFIGURE_ARGS=                -fPIC -DPIC ${LDFLAGS}
        !            25: #CONFIGURE_ENV=                PREFIX=${PREFIX}
        !            26: MAKE_ENV=              LD_LIBRARY_PATH=${WRKSRC} MAKELIB=${FILESDIR}/makelib
        !            27:
        !            28: .if !exists(/usr/libexec/ld.elf_so) && !exists(/usr/libexec/ld.so)
        !            29: IGNORE=                        requires shared object support
        !            30: .endif
        !            31:
        !            32: .include "../../mk/bsd.prefs.mk"
        !            33:
        !            34: .if defined(USE_RSAREF2) && ${USE_RSAREF2} == YES
        !            35: DEPENDS=               rsaref-2.0:../../security/rsaref
        !            36: CONFIGURE_ARGS+=       -DRSAref -L${PREFIX}/lib -lrsaref ${LDFLAGS}
        !            37: .endif
        !            38:
        !            39: fetch-depends:
        !            40: .if !defined(USE_RSAREF2) || ${USE_RSAREF2} != YES && ${USE_RSAREF2} != NO
        !            41:        @${ECHO}
        !            42:        @${ECHO} The variable USE_RSAREF2 must be set to either YES or NO
        !            43:        @${ECHO} in order to build this package.  People with no RSA
        !            44:        @${ECHO} license MUST set this variable to YES.  Users outside
        !            45:        @${ECHO} the USA MUST set this variable to NO.  RSA licensees may
        !            46:        @${ECHO} choose -- NO is faster.
        !            47:        @${FALSE}
        !            48: .endif
        !            49:
        !            50: # The Perl stuff doesn't work yet (nor did it work properly in SSLeay...)
        !            51: do-configure:
        !            52:        @cd ${WRKSRC} && ${LOCALBASE}/bin/perl util/perlpath.pl ${LOCALBASE}/bin
        !            53:        @cd ${WRKSRC} && ${LOCALBASE}/bin/perl util/ssldir.pl ${PREFIX}
        !            54:        @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./config ${CONFIGURE_ARGS}
        !            55: #      @cd ${WRKSRC}/perl && ${SETENV} ${CONFIGURE_ENV} ${LOCALBASE}/bin/perl \
        !            56: #              Makefile.PL
        !            57:
        !            58: #post-build:
        !            59: #      @cd ${WRKSRC}/perl && ${MAKE}
        !            60:
        !            61: do-install:
        !            62:        ${INSTALL_PROGRAM} ${WRKSRC}/apps/openssl ${PREFIX}/bin/
        !            63:        @cd ${PREFIX}/bin && \
        !            64:        for file in asn1parse base64 bf bf-cbc bf-cfb bf-ecb bf-ofb ca \
        !            65:        cast cast-cbc cast5-cbc cast5-cfb cast5-ecb cast5-ofb ciphers crl \
        !            66:        crl2pkcs7 des des-cbc des-cfb des-ecb des-ede des-ede-cbc des-ede-cfb \
        !            67:        des-ede-ofb des-ede3 des-ede3-cbc des-ede3-cfb des-ede3-ofb \
        !            68:        des-ofb des3 desx dgst dh dsa dsaparam enc errstr gendh gendsa \
        !            69:        genrsa idea idea-cbc idea-cfb idea-ecb idea-ofb md2 mdc2 nseq \
        !            70:        pkcs7 rc2 rc2-cbc rc2-cfb rc2-ecb rc2-ofb rc4 rc5 rc5-cbc rc5-cfb \
        !            71:        rc5-ecb rc5-ofb req rmd160 rsa s_client s_server s_time sess_id \
        !            72:        sha sha1 verify x509 ssleay; do \
        !            73:                ${LN} -sf openssl $$file; \
        !            74:        done
        !            75:        cd ${WRKSRC}/tools && ${INSTALL_SCRIPT} \
        !            76:                c_hash c_info c_issuer c_name c_rehash ${PREFIX}/bin/
        !            77:        ${SED} -e s,/usr/local,${PREFIX}, ${WRKSRC}/apps/der_chop >${WRKDIR}/der_chop && \
        !            78:                ${INSTALL_SCRIPT} ${WRKDIR}/der_chop ${PREFIX}/bin/
        !            79:        cd ${WRKSRC}/apps && ${INSTALL_SCRIPT} CA.sh CA.pl ${PREFIX}/bin/
        !            80:        ${INSTALL_DATA} ${WRKSRC}/apps/openssl.cnf ${PREFIX}/etc/openssl.cnf.example
        !            81:        cd ${WRKSRC} && \
        !            82:                ${INSTALL_DATA} libcrypto.so.?.0 libssl.so.?.0 ${PREFIX}/lib/
        !            83:        ${INSTALL_DATA_DIR} ${PREFIX}/include/openssl
        !            84:        cd ${WRKSRC}/include && \
        !            85:        for file in asn1.h asn1_mac.h bio.h blowfish.h bn.h buffer.h \
        !            86:        cast.h comp.h conf.h cryptall.h crypto.h des.h dh.h dsa.h err.h \
        !            87:        evp.h hmac.h idea.h lhash.h md2.h md5.h mdc2.h objects.h \
        !            88:        opensslv.h pem.h pem2.h pkcs7.h rand.h rc2.h rc4.h rc5.h ripemd.h \
        !            89:        rsa.h sha.h ssl.h ssl2.h ssl23.h ssl3.h stack.h tls1.h tmdiff.h \
        !            90:        txt_db.h x509.h x509_vfy.h x509v3.h; do \
        !            91:                ${INSTALL_DATA} $$file ${PREFIX}/include/openssl/; \
        !            92:        done
        !            93: #      @cd ${WRKSRC}/perl && ${MAKE} install
        !            94:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/openssl
        !            95:        ${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/openssl
        !            96:        ${INSTALL_DATA_DIR} ${PREFIX}/certs ${PREFIX}/private
        !            97:        @if [ ! -f ${PREFIX}/etc/openssl.cnf ]; then \
        !            98:                ${CP} -p ${PREFIX}/etc/openssl.cnf.example ${PREFIX}/etc/openssl.cnf; \
        !            99:        fi
        !           100:
        !           101: .include  "../../mk/bsd.pkg.mk"
        !           102:
        !           103: test: all
        !           104:        @cd ${WRKSRC}/test && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} ${MAKE} tests
        !           105:        @${ECHO} "*** Tests successful. ***"

CVSweb <webmaster@jp.NetBSD.org>