[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / openssh

Annotation of pkgsrc/security/openssh/Makefile, Revision 1.173

1.173   ! taca        1: # $NetBSD: Makefile,v 1.172 2006/10/31 03:31:19 taca Exp $
1.1       christos    2:
1.172     taca        3: DISTNAME=              openssh-4.4p1
                      4: PKGNAME=               openssh-4.4.1
1.173   ! taca        5: PKGREVISION=           1
1.57      veego       6: SVR4_PKGNAME=          ossh
1.1       christos    7: CATEGORIES=            security
1.111     grant       8: MASTER_SITES=          ftp://ftp.openssh.com/pub/OpenBSD/OpenSSH/portable/ \
                      9:                        ftp://ftp7.usa.openbsd.org/pub/os/OpenBSD/OpenSSH/portable/ \
1.98      grant      10:                        ftp://ftp.stealth.net/pub/mirrors/ftp.openssh.com/pub/OpenBSD/OpenSSH/portable/ \
1.96      grant      11:                        http://public.planetmirror.com.au/pub/OpenBSD/OpenSSH/portable/ \
                     12:                        ftp://gd.tuwien.ac.at/opsys/OpenBSD/OpenSSH/portable/ \
1.93      seb        13:                        ftp://ftp.openssh.com/pub/OpenBSD/OpenSSH/portable/old/
1.20      wiz        14: # Don't delete the last entry -- it's there if the pkgsrc version is not
                     15: # up-to-date and the mirrors already removed the old distfile.
1.1       christos   16:
1.165     jlam       17: MAINTAINER=            pkgsrc-users@NetBSD.org
1.6       wiz        18: HOMEPAGE=              http://www.openssh.com/
1.39      wiz        19: COMMENT=               Open Source Secure shell client and server (remote login program)
1.46      wennmach   20:
1.56      jlam       21: CONFLICTS=             sftp-[0-9]*
1.140     grant      22: CONFLICTS+=            ssh-[0-9]* ssh6-[0-9]*
                     23: CONFLICTS+=            ssh2-[0-9]* ssh2-nox11-[0-9]*
1.103     jwise      24: CONFLICTS+=            openssh+gssapi-[0-9]*
1.149     wiz        25: CONFLICTS+=            lsh>2.0
1.1       christos   26:
1.152     jlam       27: USE_TOOLS+=            perl
1.8       fredb      28:
1.28      fredb      29: CRYPTO=                        yes
                     30:
1.99      jmmv       31: # retain the following line, for IPv6-ready pkgsrc webpage
1.7       itojun     32: BUILD_DEFS+=           USE_INET6
1.1       christos   33:
1.172     taca       34: BUILD_DEFS+=           OPENSSH_CHROOT OPENSSH_GROUP OPENSSH_USER
                     35: BUILD_DEFS+=           VARBASE
                     36:
1.61      jlam       37: INSTALL_TARGET=                install-nokeys
                     38: PLIST_SRC=             # empty
1.147     tv         39:
1.150     reed       40: .include "options.mk"
                     41:
1.147     tv         42: .if ${OPSYS} == "Interix"
                     43:
1.154     reed       44: # OpenSSH on Interix has some important caveats
1.147     tv         45: MESSAGE_SRC=           ${.CURDIR}/MESSAGE.Interix
                     46: BUILDLINK_PASSTHRU_DIRS+= /usr/local/include/bind /usr/local/lib/bind
                     47: CONFIGURE_ENV+=                ac_cv_func_openpty=no
                     48: CONFIGURE_ENV+=                ac_cv_type_struct_timespec=yes
                     49: CPPFLAGS+=             -I/usr/local/include/bind
                     50: LDFLAGS+=              -L/usr/local/lib/bind
                     51: LIBS+=                 -lbind -ldb -lcrypt
                     52:
                     53: .else # not Interix
                     54:
1.168     jlam       55: PKG_GROUPS=             ${OPENSSH_GROUP}
1.167     jlam       56: PKG_USERS=             ${OPENSSH_USER}:${OPENSSH_GROUP}
                     57:
                     58: PKG_GECOS.${OPENSSH_USER}=     sshd privsep pseudo-user
                     59: PKG_HOME.${OPENSSH_USER}=      ${OPENSSH_CHROOT}
1.89      grant      60:
1.147     tv         61: .endif
                     62:
1.145     xtraeme    63: SSH_PID_DIR=           ${VARBASE}/run  # default directory for PID files
1.35      wiz        64:
1.76      jlam       65: PKG_SYSCONFSUBDIR=     ssh
1.82      jlam       66:
1.18      jlam       67: GNU_CONFIGURE=         yes
1.122     xtraeme    68: CONFIGURE_ARGS+=       --with-mantype=man
1.162     rillig     69: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR:Q}
                     70: CONFIGURE_ARGS+=       --with-pid-dir=${SSH_PID_DIR:Q}
                     71: CONFIGURE_ARGS+=       --with-ssl-dir=${SSLBASE:Q}
1.88      jlam       72: CONFIGURE_ARGS+=       --with-tcp-wrappers=${BUILDLINK_PREFIX.tcp_wrappers}
1.147     tv         73:
                     74: .if ${OPSYS} != "Interix"
1.162     rillig     75: CONFIGURE_ARGS+=       --with-privsep-path=${OPENSSH_CHROOT:Q}
                     76: CONFIGURE_ARGS+=       --with-privsep-user=${OPENSSH_USER:Q}
1.147     tv         77: .endif
1.112     jschauma   78:
1.160     grant      79: # pkgsrc already enforces a "secure" version of zlib via dependencies,
                     80: # so skip this bogus version check.
                     81: CONFIGURE_ARGS+=       --without-zlib-version-check
                     82:
1.119     grant      83: # the openssh configure script finds and uses ${LD} if defined and
                     84: # defaults to ${CC} if not. we override LD here, since running the
                     85: # linker directly results in undefined symbols for obvious reasons.
                     86: #
1.121     jlam       87: CONFIGURE_ENV+=                LD=${CC:Q}
1.114     grant      88:
1.133     jlam       89: # Enable S/Key support on NetBSD, Darwin, and Solaris.
                     90: .if (${OPSYS} == "NetBSD") || (${OPSYS} == "Darwin") || (${OPSYS} == "SunOS")
1.126     wiz        91: .  include "../../security/skey/buildlink3.mk"
1.88      jlam       92: CONFIGURE_ARGS+=       --with-skey=${BUILDLINK_PREFIX.skey}
                     93: .else
                     94: CONFIGURE_ARGS+=       --without-skey
1.85      grant      95: .endif
1.54      kim        96:
1.132     jlam       97: .if (${OPSYS} == "NetBSD") && exists(/usr/include/utmpx.h)
1.129     markd      98: # if we have utmpx et al do not try to use login()
                     99: CONFIGURE_ARGS+=       --disable-libutil
                    100: .endif
1.132     jlam      101: .if (${OPSYS} == "SunOS") && (${OS_VERSION} == "5.8" || ${OS_VERSION} == "5.9")
1.128     markd     102: CONFIGURE_ARGS+=       --disable-utmp --disable-wtmp
                    103: .endif
1.136     xtraeme   104: .if ${OPSYS} == "Linux"
                    105: CONFIGURE_ARGS+=       --enable-md5-password
                    106: .endif
1.128     markd     107:
1.27      jlam      108: # The ssh-askpass program is in ${X11BASE}/bin or ${X11PREFIX}/bin depending
                    109: # on if it's part of the X11 distribution, or if it's installed from pkgsrc
1.61      jlam      110: # (security/ssh-askpass).
1.21      jlam      111: #
1.27      jlam      112: .if exists(${X11BASE}/bin/ssh-askpass)
1.61      jlam      113: ASKPASS_PROGRAM=       ${X11BASE}/bin/ssh-askpass
1.27      jlam      114: .else
1.61      jlam      115: ASKPASS_PROGRAM=       ${X11PREFIX}/bin/ssh-askpass
1.27      jlam      116: .endif
1.161     rillig    117: CONFIGURE_ENV+=                ASKPASS_PROGRAM=${ASKPASS_PROGRAM:Q}
                    118: MAKE_ENV+=             ASKPASS_PROGRAM=${ASKPASS_PROGRAM:Q}
1.12      itojun    119:
1.144     grant     120: # do the same for xauth
                    121: .if exists(${X11BASE}/bin/xauth)
                    122: CONFIGURE_ARGS+=       --with-xauth=${X11BASE}/bin/xauth
                    123: .else
                    124: CONFIGURE_ARGS+=       --with-xauth=${X11PREFIX}/bin/xauth
                    125: .endif
                    126:
1.155     jlam      127: CONFS=                 ssh_config sshd_config moduli
1.52      tron      128:
1.61      jlam      129: .if exists(/dev/urandom)
1.139     reed      130: .  if ${OPSYS} == "NetBSD"
1.61      jlam      131: MESSAGE_SRC+=          ${.CURDIR}/MESSAGE.urandom
1.139     reed      132: .  endif
1.61      jlam      133: .else
                    134: CONFIGURE_ARGS+=       --without-random
                    135: CONFS+=                        ssh_prng_cmds
                    136: PLIST_SRC+=            ${.CURDIR}/PLIST.prng
1.34      tron      137: .endif
1.54      kim       138:
1.61      jlam      139: EGDIR=                 ${PREFIX}/share/examples/${PKGBASE}
                    140: CONF_FILES=            # empty
1.172     taca      141: .for f in ${CONFS}
                    142: CONF_FILES+=           ${EGDIR}/${f} ${PKG_SYSCONFDIR}/${f}
1.61      jlam      143: .endfor
1.89      grant     144: OWN_DIRS=              ${OPENSSH_CHROOT}
1.61      jlam      145: RCD_SCRIPTS=           sshd
                    146:
                    147: PLIST_SRC+=            ${.CURDIR}/PLIST
1.161     rillig    148: FILES_SUBST+=          SSH_PID_DIR=${SSH_PID_DIR:Q}
1.107     jlam      149:
1.172     taca      150: SUBST_CLASSES+=                patch
                    151: SUBST_STAGE.patch=     pre-configure
                    152: SUBST_FILES.patch=     session.c
                    153: SUBST_SED.patch=       -e '/channel_input_port_forward_request/s/0/ROOTUID/'
                    154: SUBST_MESSAGE.patch=   More patch a file.
                    155:
1.132     jlam      156: .include "../../devel/zlib/buildlink3.mk"
                    157: .include "../../security/openssl/buildlink3.mk"
                    158: .include "../../security/tcp_wrappers/buildlink3.mk"
                    159:
1.5       hubertf   160: post-install:
1.61      jlam      161:        ${INSTALL_DATA_DIR} ${EGDIR}
1.155     jlam      162:        cd ${WRKSRC}; for file in ${CONFS}; do                          \
1.61      jlam      163:                ${INSTALL_DATA} $${file}.out ${EGDIR}/$${file};         \
1.52      tron      164:        done
1.157     reed      165: .if !empty(PKG_OPTIONS:Mpam) && ${OPSYS} == "Linux"
1.138     reed      166:        ${INSTALL_DATA} ${WRKSRC}/contrib/sshd.pam.generic ${EGDIR}/sshd.pam
                    167: .endif
1.1       christos  168:
                    169: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>