[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / openssh

Annotation of pkgsrc/security/openssh/Makefile, Revision 1.147

1.147   ! tv          1: # $NetBSD: Makefile,v 1.146 2004/12/28 02:47:49 reed Exp $
1.1       christos    2:
1.142     wiz         3: DISTNAME=              openssh-3.9p1
                      4: PKGNAME=               openssh-3.9.1
1.147   ! tv          5: PKGREVISION=           5
1.57      veego       6: SVR4_PKGNAME=          ossh
1.1       christos    7: CATEGORIES=            security
1.111     grant       8: MASTER_SITES=          ftp://ftp.openssh.com/pub/OpenBSD/OpenSSH/portable/ \
                      9:                        ftp://ftp7.usa.openbsd.org/pub/os/OpenBSD/OpenSSH/portable/ \
1.98      grant      10:                        ftp://ftp.stealth.net/pub/mirrors/ftp.openssh.com/pub/OpenBSD/OpenSSH/portable/ \
1.96      grant      11:                        http://public.planetmirror.com.au/pub/OpenBSD/OpenSSH/portable/ \
                     12:                        ftp://gd.tuwien.ac.at/opsys/OpenBSD/OpenSSH/portable/ \
1.93      seb        13:                        ftp://ftp.openssh.com/pub/OpenBSD/OpenSSH/portable/old/
1.20      wiz        14: # Don't delete the last entry -- it's there if the pkgsrc version is not
                     15: # up-to-date and the mirrors already removed the old distfile.
1.1       christos   16:
1.102     grant      17: MAINTAINER=            tech-pkg@NetBSD.org
1.6       wiz        18: HOMEPAGE=              http://www.openssh.com/
1.39      wiz        19: COMMENT=               Open Source Secure shell client and server (remote login program)
1.46      wennmach   20:
1.56      jlam       21: CONFLICTS=             sftp-[0-9]*
1.140     grant      22: CONFLICTS+=            ssh-[0-9]* ssh6-[0-9]*
                     23: CONFLICTS+=            ssh2-[0-9]* ssh2-nox11-[0-9]*
1.103     jwise      24: CONFLICTS+=            openssh+gssapi-[0-9]*
1.1       christos   25:
1.84      jlam       26: USE_PERL5=             build
1.8       fredb      27:
1.28      fredb      28: CRYPTO=                        yes
                     29:
1.99      jmmv       30: # retain the following line, for IPv6-ready pkgsrc webpage
1.7       itojun     31: BUILD_DEFS+=           USE_INET6
1.1       christos   32:
1.145     xtraeme    33: .include "options.mk"
1.1       christos   34:
1.61      jlam       35: INSTALL_TARGET=                install-nokeys
                     36: PLIST_SRC=             # empty
1.147   ! tv         37:
        !            38: .if ${OPSYS} == "Interix"
        !            39:
        !            40: # normal MESSAGE does not apply, as privsep is not in use
        !            41: MESSAGE_SRC=           ${.CURDIR}/MESSAGE.Interix
        !            42: BUILDLINK_PASSTHRU_DIRS+= /usr/local/include/bind /usr/local/lib/bind
        !            43: CONFIGURE_ENV+=                ac_cv_func_openpty=no
        !            44: CONFIGURE_ENV+=                ac_cv_type_struct_timespec=yes
        !            45: CPPFLAGS+=             -I/usr/local/include/bind
        !            46: LDFLAGS+=              -L/usr/local/lib/bind
        !            47: LIBS+=                 -lbind -ldb -lcrypt
        !            48:
        !            49: .else # not Interix
        !            50:
1.61      jlam       51: MESSAGE_SRC=           ${.CURDIR}/MESSAGE
1.89      grant      52: PKG_USERS=             ${OPENSSH_USER}:${OPENSSH_GROUP}:${OPENSSH_UID}:sshd\\ privsep:${OPENSSH_CHROOT}:${NOLOGIN}
                     53: PKG_GROUPS=             ${OPENSSH_GROUP}:${OPENSSH_GID}
                     54:
1.147   ! tv         55: .endif
        !            56:
1.145     xtraeme    57: SSH_PID_DIR=           ${VARBASE}/run  # default directory for PID files
1.35      wiz        58:
1.76      jlam       59: PKG_SYSCONFSUBDIR=     ssh
1.82      jlam       60: MANDIR=                        man
                     61:
                     62: PLIST_SUBST+=          MANDIR=${MANDIR}
                     63:
1.126     wiz        64: USE_BUILDLINK3=                yes
1.94      jlam       65: USE_PKGINSTALL=                yes
1.18      jlam       66: GNU_CONFIGURE=         yes
1.122     xtraeme    67: CONFIGURE_ARGS+=       --with-mantype=man
1.76      jlam       68: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR}
1.82      jlam       69: CONFIGURE_ARGS+=       --mandir=${PREFIX}/${MANDIR}
1.61      jlam       70: CONFIGURE_ARGS+=       --with-pid-dir=${SSH_PID_DIR}
1.88      jlam       71: CONFIGURE_ARGS+=       --with-ssl-dir=${SSLBASE}
                     72: CONFIGURE_ARGS+=       --with-tcp-wrappers=${BUILDLINK_PREFIX.tcp_wrappers}
1.147   ! tv         73:
        !            74: .if ${OPSYS} != "Interix"
1.89      grant      75: CONFIGURE_ARGS+=       --with-privsep-path=${OPENSSH_CHROOT}
                     76: CONFIGURE_ARGS+=       --with-privsep-user=${OPENSSH_USER}
1.147   ! tv         77: .endif
1.112     jschauma   78:
1.119     grant      79: # the openssh configure script finds and uses ${LD} if defined and
                     80: # defaults to ${CC} if not. we override LD here, since running the
                     81: # linker directly results in undefined symbols for obvious reasons.
                     82: #
1.121     jlam       83: CONFIGURE_ENV+=                LD=${CC:Q}
1.114     grant      84:
1.133     jlam       85: # Enable S/Key support on NetBSD, Darwin, and Solaris.
                     86: .if (${OPSYS} == "NetBSD") || (${OPSYS} == "Darwin") || (${OPSYS} == "SunOS")
1.126     wiz        87: .  include "../../security/skey/buildlink3.mk"
1.88      jlam       88: CONFIGURE_ARGS+=       --with-skey=${BUILDLINK_PREFIX.skey}
                     89: .else
                     90: CONFIGURE_ARGS+=       --without-skey
1.85      grant      91: .endif
1.54      kim        92:
1.132     jlam       93: .if (${OPSYS} == "NetBSD") && exists(/usr/include/utmpx.h)
1.129     markd      94: # if we have utmpx et al do not try to use login()
                     95: CONFIGURE_ARGS+=       --disable-libutil
                     96: .endif
1.132     jlam       97: .if (${OPSYS} == "SunOS") && (${OS_VERSION} == "5.8" || ${OS_VERSION} == "5.9")
1.128     markd      98: CONFIGURE_ARGS+=       --disable-utmp --disable-wtmp
                     99: .endif
1.136     xtraeme   100: .if ${OPSYS} == "Linux"
                    101: CONFIGURE_ARGS+=       --enable-md5-password
                    102: .endif
1.128     markd     103:
1.27      jlam      104: # The ssh-askpass program is in ${X11BASE}/bin or ${X11PREFIX}/bin depending
                    105: # on if it's part of the X11 distribution, or if it's installed from pkgsrc
1.61      jlam      106: # (security/ssh-askpass).
1.21      jlam      107: #
1.27      jlam      108: .if exists(${X11BASE}/bin/ssh-askpass)
1.61      jlam      109: ASKPASS_PROGRAM=       ${X11BASE}/bin/ssh-askpass
1.27      jlam      110: .else
1.61      jlam      111: ASKPASS_PROGRAM=       ${X11PREFIX}/bin/ssh-askpass
1.27      jlam      112: .endif
1.61      jlam      113: CONFIGURE_ENV+=                ASKPASS_PROGRAM=${ASKPASS_PROGRAM}
                    114: MAKE_ENV+=             ASKPASS_PROGRAM=${ASKPASS_PROGRAM}
1.12      itojun    115:
1.144     grant     116: # do the same for xauth
                    117: .if exists(${X11BASE}/bin/xauth)
                    118: CONFIGURE_ARGS+=       --with-xauth=${X11BASE}/bin/xauth
                    119: .else
                    120: CONFIGURE_ARGS+=       --with-xauth=${X11PREFIX}/bin/xauth
                    121: .endif
                    122:
1.61      jlam      123: CONFS=                 ssh_config sshd_config
                    124: SUPPS=                 moduli
1.52      tron      125:
1.61      jlam      126: .if exists(/dev/urandom)
1.139     reed      127: .  if ${OPSYS} == "NetBSD"
1.61      jlam      128: MESSAGE_SRC+=          ${.CURDIR}/MESSAGE.urandom
1.139     reed      129: .  endif
1.61      jlam      130: .else
                    131: CONFIGURE_ARGS+=       --without-random
                    132: CONFS+=                        ssh_prng_cmds
                    133: PLIST_SRC+=            ${.CURDIR}/PLIST.prng
1.34      tron      134: .endif
1.54      kim       135:
1.61      jlam      136: EGDIR=                 ${PREFIX}/share/examples/${PKGBASE}
                    137: CONF_FILES=            # empty
                    138: .for FILE in ${CONFS}
1.76      jlam      139: CONF_FILES+=           ${EGDIR}/${FILE} ${PKG_SYSCONFDIR}/${FILE}
1.61      jlam      140: .endfor
                    141: SUPPORT_FILES=         # empty
                    142: .for FILE in ${SUPPS}
1.76      jlam      143: SUPPORT_FILES+=                ${EGDIR}/${FILE} ${PKG_SYSCONFDIR}/${FILE}
1.61      jlam      144: .endfor
1.89      grant     145: OWN_DIRS=              ${OPENSSH_CHROOT}
1.61      jlam      146: RCD_SCRIPTS=           sshd
                    147:
                    148: PLIST_SRC+=            ${.CURDIR}/PLIST
                    149: FILES_SUBST+=          SSH_PID_DIR=${SSH_PID_DIR}
                    150: MESSAGE_SUBST+=                EGDIR=${EGDIR}
1.89      grant     151: MESSAGE_SUBST+=                OPENSSH_USER=${OPENSSH_USER}
                    152: MESSAGE_SUBST+=                OPENSSH_GROUP=${OPENSSH_GROUP}
1.107     jlam      153:
                    154: INSTALL_EXTRA_TMPL+=   ${.CURDIR}/INSTALL
1.83      jlam      155:
1.132     jlam      156: .include "../../devel/zlib/buildlink3.mk"
                    157: .include "../../security/openssl/buildlink3.mk"
                    158: .include "../../security/tcp_wrappers/buildlink3.mk"
                    159:
1.5       hubertf   160: post-install:
1.61      jlam      161:        ${INSTALL_DATA_DIR} ${EGDIR}
                    162:        cd ${WRKSRC}; for file in ${CONFS} ${SUPPS}; do                 \
                    163:                ${INSTALL_DATA} $${file}.out ${EGDIR}/$${file};         \
1.52      tron      164:        done
1.145     xtraeme   165: .if !empty(PKG_OPTIONS:MPAM) && ${OPSYS} == "Linux"
1.138     reed      166:        ${INSTALL_DATA} ${WRKSRC}/contrib/sshd.pam.generic ${EGDIR}/sshd.pam
                    167: .endif
1.1       christos  168:
                    169: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>