The NetBSD Project

CVS log for pkgsrc/security/oath-toolkit/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / security / oath-toolkit

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.31 / (download) - annotate - [select for diffs], Wed Nov 8 13:20:48 2023 UTC (3 weeks ago) by wiz
Branch: MAIN
CVS Tags: HEAD
Changes since 1.30: +2 -2 lines
Diff to previous 1.30 (colored)

*: recursive bump for icu 74.1

Revision 1.30 / (download) - annotate - [select for diffs], Tue Oct 24 22:10:53 2023 UTC (5 weeks, 1 day ago) by wiz
Branch: MAIN
Changes since 1.29: +2 -1 lines
Diff to previous 1.29 (colored)

*: bump for openssl 3

Revision 1.29 / (download) - annotate - [select for diffs], Tue Jul 25 13:59:57 2023 UTC (4 months ago) by sborrill
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Changes since 1.28: +2 -3 lines
Diff to previous 1.28 (colored)

oath-toolkit: update to 2.6.9

Changes since 2.6.7:

Version 2.6.9 (released 2023-07-09)
    Improve compatibility with recent libxmlsec.
    Update gnulib files, dropping gnulib self-tests.

Version 2.6.8 (released 2023-07-09)
    libpskc: Fixes for recent libxmlsec releases.
    pam_oath: Provide fallback pam_modutil_getpwnam implementation. Fixes https://gitlab.com/oath-toolkit/oath-toolkit/-/issues/26 on Mac OS.
    pam_oath: Don't fail authentication when pam_modutil_getpwnam doesn't
    Regression introduced in previous release.
    pam_oath: Self-test improvements.
    liboath: Builds on Windows. The oath_authenticate_usersfile function is just a stub that returns an error. This allows for use of the rest of the library on Windows.
    Disable PAM self-tests on Mac. Fix --enable-root-tests logic.
    Don't ship gtk-doc PDFs in tarball.
    Use gitlog-to-changelog instead of git2cl.
    Codespell typo fixes.

Revision 1.28 / (download) - annotate - [select for diffs], Tue Jun 6 12:42:14 2023 UTC (5 months, 3 weeks ago) by riastradh
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

Mass-change BUILD_DEPENDS to TOOL_DEPENDS outside mk/.

Almost all uses, if not all of them, are wrong, according to the
semantics of BUILD_DEPENDS (packages built for target available for
use _by_ tools at build-time) and TOOL_DEPEPNDS (packages built for
host available for use _as_ tools at build-time).

No change to BUILD_DEPENDS as used correctly inside buildlink3.

As proposed on tech-pkg:
https://mail-index.netbsd.org/tech-pkg/2023/06/03/msg027632.html

Revision 1.27 / (download) - annotate - [select for diffs], Wed Apr 19 08:11:23 2023 UTC (7 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

revbump after textproc/icu update

Revision 1.26 / (download) - annotate - [select for diffs], Wed Nov 23 16:21:01 2022 UTC (12 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.25: +2 -1 lines
Diff to previous 1.25 (colored)

massive revision bump after textproc/icu update

Revision 1.25 / (download) - annotate - [select for diffs], Sat Nov 12 09:10:24 2022 UTC (12 months, 2 weeks ago) by nikita
Branch: MAIN
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

archivers/fastjar, archivers/lzip, audio/tcd, cross/avrdude, devel/guile-lib,
devel/libjit, devel/m17n-lib, devel/quilt, devel/treecc, emulators/simulavr,
fonts/jomolhari-ttf, graphics/dvipng, graphics/freetype2, graphics/libotf,
ham/xlog, misc/color-theme, misc/m17n-db, multimedia/flvstreamer,
net/mimms, print/chktex, security/oath-toolkit, sysutils/attr,
sysutils/pidof, sysutils/renameutils, textproc/lout:

change MASTER_SITES from http://download.savannah.gnu.org to https://download.savannah.gnu.org

Revision 1.24 / (download) - annotate - [select for diffs], Mon Aug 22 07:42:52 2022 UTC (15 months, 1 week ago) by sborrill
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.23: +6 -6 lines
Diff to previous 1.23 (colored)

oath-toolkit: update to 2.6.7

Changes since 2.4.1:

Version 2.6.7 (released 2021-05-01)

    pam_oath: Support variables in usersfile string parameter.  the
usersfile string in the pam_oath configuration file.  The placeholder values
allow the user credentials file to be stored in a file path that is relative
to the user, and mimics similar behavior found in
google-authenticator-libpam.

The motivation for these changes is to allow for non-privileged processes to
use pam_oath (e.g., for 2FA with xscreensaver).  Non-privileged and non-suid
programs are unable to use pam_oath.  These changes are a proposed
alternative to a suid helper binary as well.

Thanks to Jason Graham for the patch.  See
https://gitlab.com/oath-toolkit/oath-toolkit/-/merge_requests/12.

    doc: Fix project URL in man pages.  Thanks to Jason Graham
for the patch.  Fixes
https://gitlab.com/oath-toolkit/oath-toolkit/-/issues/19.

    build: Drop use of libxml's AM_PATH_XML2 in favor of pkg-config.

    build: Modernize autotools usage.  Most importantly, no longer use
-Werror with AM_INIT_AUTOMAKE to make rebuilding from source more safe with
future automake versions.

    Updated gnulib files.

Version 2.6.6 (released 2021-01-20)

    oathtool: Handle HOTP --counter values larger than 0x7FFFFFFFFFFFFFFF.
Thanks to Jason Lai for report.

    doc: GTK-DOC manual improvements.

    Updated gnulib files.  Fixes test-parse-datetime self-check.  Fixes
https://gitlab.com/oath-toolkit/oath-toolkit/-/issues/20.

Version 2.6.5 (released 2020-12-29)

    oathtool: Support for reading KEY and OTP from standard input or
filename.  KEY and OTP may now be given as - to mean stdin, or @FILE to read
from a particular file.  This is recommended on multi-user systems, since
secrets as command line parameters leak.  Based on a patch from Ian Jackson.
Fixes #6.

    pam_oath: Fix unlikely logic fail on out of memory conditions.  Patch
from Matthias Gerstner.

    Doc fixes.

Version 2.6.4 (released 2020-11-11)

    libpskc: New --with-xmlsec-crypto-engine to hard-code crypto engine.
Fixes https://gitlab.com/oath-toolkit/oath-toolkit/-/issues/16.  Use it like
--with-xmlsec-crypto-engine=gnutls or --with-xmlsec-crypto-engine=openssl if
the default dynamic loading fails because of runtime linker search path
issues.

    oathtool --totp --verbose now prints TOTP hash mode.  Fixes
https://gitlab.com/oath-toolkit/oath-toolkit/-/issues/4.

    oathtool: Hash names (e.g., SHA256) for --totp are now upper case.
Fixes https://gitlab.com/oath-toolkit/oath-toolkit/-/issues/3.  Lower/mixed
case hash names are supported for compatibility.

    pam_oath: Fail gracefully for missing users.  Fixes
https://savannah.nongnu.org/support/index.php?109111.  This allows you to
incrementally add support for OATH authentication instead of forcing it on
all users.  See updated pam_oath/README on the [user_unknown=ignore
success=ok] parameter that can now be supplied to PAM configuration.  Patch
by Antoine Beaupra

    Fix libpskc memory corruption bug.  Fixes
https://savannah.nongnu.org/support/?108736.  Thanks to David Woodhouse and
Jaroslav A karvada for report, self check and patch.

    Fix man pages.  Fixes https://savannah.nongnu.org/support/?108312.
Thanks to Jaroslav A karvada for the patch.

    Build fixes.

Version 2.6.3 (released 2020-11-07)

    pam_oath: Fix self-tests.

    build: Update gnulib. Fix compiler warnings.

    Doc fixes.

Version 2.6.2 (released 2016-08-27)

    doc: Version controlled source code repository moved to GitLab.

Version 2.6.1 (released 2015-07-31)

    liboath: Fix make check on 32-bit systems.  Report and patch by
Christian Hesse.

Version 2.6.0 (released 2015-05-19)

    liboath: Support TOTP with HMAC-SHA256 and HMAC-SHA512.  This adds new
APIs oath_totp_generate2, oath_totp_validate4 and
oath_totp_validate4_callback.

    oathtool: The --totp parameter now take an optional argument to specify
MAC.  For example use --totp=sha256 to use HMAC-SHA256.  When --totp is used
the default HMAC-SHA1 is used, as before.

    pam_oath: Mention in README that you shouldn???t use insecure keys.
Suggested by Robin.

    pam_oath: Check return value from strdup.  Patch by Eero Hakkinen.

    The files gdoc and expect.oath are now included in the tarball.
Suggested by Jaroslav A karvada.

Revision 1.23 / (download) - annotate - [select for diffs], Mon Apr 18 19:12:00 2022 UTC (19 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

revbump for textproc/icu update

Revision 1.22 / (download) - annotate - [select for diffs], Wed Dec 8 16:06:20 2021 UTC (23 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

revbump for icu and libffi

Revision 1.21 / (download) - annotate - [select for diffs], Wed Apr 21 11:42:36 2021 UTC (2 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

revbump for textproc/icu

Revision 1.20 / (download) - annotate - [select for diffs], Mon Jan 11 02:22:19 2021 UTC (2 years, 10 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.19: +2 -1 lines
Diff to previous 1.19 (colored)

(security/oath-toolkit) Add TOOL_DEPENDS+= gtk-doc-[0-9]*

Revision 1.19 / (download) - annotate - [select for diffs], Thu Nov 5 09:09:03 2020 UTC (3 years ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

*: Recursive revbump from textproc/icu-68.1

Revision 1.18 / (download) - annotate - [select for diffs], Tue Jun 2 08:24:41 2020 UTC (3 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

Revbump for icu

Revision 1.17 / (download) - annotate - [select for diffs], Sat Jan 18 23:35:10 2020 UTC (3 years, 10 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.

Revision 1.16 / (download) - annotate - [select for diffs], Sat Jan 18 21:50:41 2020 UTC (3 years, 10 months ago) by jperkin
Branch: MAIN
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

*: Recursive revision bump for openssl 1.1.1.

Revision 1.15 / (download) - annotate - [select for diffs], Sat Mar 5 11:29:22 2016 UTC (7 years, 8 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Bump PKGREVISION for security/openssl ABI bump.

Revision 1.14 / (download) - annotate - [select for diffs], Tue Sep 23 19:39:50 2014 UTC (9 years, 2 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.13: +2 -1 lines
Diff to previous 1.13 (colored)

Sync PLIST with reality adding various man pages. Bump revision.

Revision 1.13 / (download) - annotate - [select for diffs], Mon Mar 10 00:58:51 2014 UTC (9 years, 8 months ago) by pettai
Branch: MAIN
CVS Tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.12: +2 -3 lines
Diff to previous 1.12 (colored)

Version 2.4.1 (released 2014-02-12)

* liboath: Fix usersfile bug that caused it to update the wrong line.
When an usersfile contain multiple lines for the same user but with an
unparseable token type (e.g., HOTP vs TOTP), the code would update the
wrong line of the file.  Since the then updated line could be a
commented out line, this can lead to the same OTP being accepted
multiple times which is a security vulnerability. CVE-2013-7322
CVs: ----------------------------------------------------------------------

Revision 1.12 / (download) - annotate - [select for diffs], Wed Feb 12 23:18:34 2014 UTC (9 years, 9 months ago) by tron
Branch: MAIN
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Recursive PKGREVISION bump for OpenSSL API version bump.

Revision 1.11 / (download) - annotate - [select for diffs], Sun Jan 5 21:41:37 2014 UTC (9 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.10: +7 -5 lines
Diff to previous 1.10 (colored)

Run autoreconf to avoid issues with automake version number mismatches.
Fixes build after automake-1.14.1 update.

Make automake a build dependency. Bump PKGREVISION.

Revision 1.10 / (download) - annotate - [select for diffs], Wed Jan 1 11:52:33 2014 UTC (9 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.9: +2 -1 lines
Diff to previous 1.9 (colored)

Recursive PKGREVISION bump for libgcrypt-1.6.0 shlib major bump.

Revision 1.9 / (download) - annotate - [select for diffs], Sat Sep 14 07:46:33 2013 UTC (10 years, 2 months ago) by pettai
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.8: +6 -2 lines
Diff to previous 1.8 (colored)

Version 2.4.0 (released 2013-07-21)

* liboath: Add new API methods for validating TOTP OTPs
  The new methods (oath_totp_validate3 and oath_totp_validate3_callback)
  introduce a new parameter *otp_counter, which is set to the actual
  counter used to calculate the OTP (unless it is a NULL pointer). This
  allows for easier OTP replay detection in applications using liboath.
  Patch from Fabian Gr├╝nbichler <fabian.gruenbichler@tuwien.ac.at>.

Version 2.2.0 (released 2013-07-07)

* libpskc: Add functions for setting PSKC data.
  The new functions are pskc_add_keypackage and all pskc_set_* functions
  (see libpskc/include/pskc/keypackage.h).  This allow you to write
  programs that generate new PSKC structures.
* liboath: Permit different passwords for different tokens for the same user.
  Thanks to Christian Hesse <list@eworm.de>.
* build: Improve building from git with most recent automake and gengetopt.
  Thanks to Christian Hesse <list@eworm.de>.
* build: Valgrind is not enabled by default.
  It causes too much false positives.  For developers who want, use
  --enable-valgrind-tests.  It is still enabled by default when building
  from the version controlled sources (see cfg.mk).  Thanks to Christian
  Hesse <list@eworm.de>.
* liboath: Make header file usable from C++ (extern "C" guard).
  Reported by Alan Markus <alan.markus@gmail.com>.

Revision 1.8 / (download) - annotate - [select for diffs], Sat Mar 16 20:52:38 2013 UTC (10 years, 8 months ago) by pettai
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.7: +4 -2 lines
Diff to previous 1.7 (colored)

Version 2.0.2 (released 2013-01-08)

* oathtool: Base32 decoding of keys are now more liberal in what accepts.
  It can now accept keys on the "gr6d 5br7 25s6 vnck v4vl hlao re"
  format, i.e., base32 data delimited using SPC and without padding.
  The old proper base32 format is still supported.
* liboath: oath_base32_decode now ignores SPC and adds pad characters.
* liboath: If password in usersfile is + then ignore supplied password.
  This enables the pam_oath module to be used with external password
  verification.  Based on patch from Ilkka Virta <itvirta@iki.fi>.
* tests: Fixed expiry date of some certificates used in the test suite.
  The last release would only complete 'make check' during a 30 day window.
* API and ABI is backwards compatible with the previous version.

Version 2.0.1 (released 2012-10-24)

* libpskc, pskctool: Support sign and verify of PSKC data using XML DigSig.
* libpskc: XML Schema validation modified.
  The entire PSKC schema is now supported (before the XML Digital
  Signatures and Encryption parts were removed).  The code now assumes
  that the schema is available in the local XML catalog.  Thanks to Liam
  Quin for hints about XML catalogs.
* pskctool: the --check (-c) parameter was renamed to --info (-i).
* API and ABI is backwards compatible with the previous version.

Version 2.0.0 (released 2012-10-10)

* libpskc, pskctool: New components.
  The OATH Toolkit now supports the Portable Symmetric Key Container
  (PSKC) data format specified in RFC 6030 for dealing with key
  provisioning.  There is a new low-level library libpskc for managing
  PSKC data for application developers and a new command line tool
  pskctool for interacting with PSKC data for users.  The PSKC
  functionality depends on Libxml2 <http://xmlsoft.org/>.  It can be
  disabled unconditionally using the ./configure-parameter
  --disable-pskc.
* liboath: Add manpages for library API.
* API and ABI is backwards compatible with the previous version.

Revision 1.7 / (download) - annotate - [select for diffs], Sun Nov 18 02:25:38 2012 UTC (11 years ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.6: +1 -3 lines
Diff to previous 1.6 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.6 / (download) - annotate - [select for diffs], Sat Nov 10 18:07:44 2012 UTC (11 years ago) by pettai
Branch: MAIN
Changes since 1.5: +3 -1 lines
Diff to previous 1.5 (colored)

Version 1.12.6 (released 2012-09-04)

* liboath: The usersfile is now fflush'ed and fsync'ed.
* liboath: A memory leak fixed.
* oathtool: The --counter parameter now works on 32-bit platforms.
* API and ABI is backwards compatible with the previous version.
  OATH_FILE_FLUSH_ERROR: Added.
  OATH_FILE_SYNC_ERROR: Added.
  OATH_FILE_CLOSE_ERROR: Added.
  OATH_LAST_ERROR: Added.

Version 1.12.5 (released 2012-08-19)

* oathtool: The --counter parameter now supports larger values.
  Before it used an 'int' type and now it uses a 'longlong' type.
  Needed for eSecuTech tokens as they use a 64-bit value for their
  initial counter. see <https://savannah.nongnu.org/support/?108114>.
* Added gnulib self-tests.
* API and ABI is backwards compatible with the previous version.

Version 1.12.4 (released 2012-06-17)

* liboath: Usersfile code handles multiple lines for a single user.
  This can be used when a single user carries multiple tokens (with
  different OATH secrets) and any of them should be permitted.
* API and ABI is backwards compatible with the previous version.

Version 1.12.3 (released 2012-05-31)

* pam_oath: Fix "try_first_pass".
* API and ABI is backwards compatible with the previous version.

Version 1.12.2 (released 2012-04-04)

* liboath: usersfile function now works on FreeBSD.
* tests: liboath usersfile self-test is skipped if there is no datefudge.
* API and ABI is backwards compatible with the previous version.

Version 1.12.1 (released 2012-04-01)

* liboath, oathtool: Base32 decoding now permit lowercase characters.
* API and ABI is backwards compatible with the previous version.

Version 1.12.0 (released 2012-04-01)

* oathtool: Added --base32 parameter to decode base32 keys.
* oathtool: Verbose output (-v) now print key data in base32 format too.
* liboath: Added base32 functions.  Added hex encoding function.
  The new APIs are oath_bin2hex, oath_base32_decode, and
  oath_base32_encode.
* liboath: Gnulib's snprintf is used for better portability.
  The system snprintf is known to have bugs on some systems, see the
  Gnulib manual for more information.
* API and ABI is backwards compatible with the previous version.
  oath_bin2hex: New function.
  oath_base32_decode: New function.
  oath_base32_encode: New function.
  OATH_INVALID_BASE32: New error code.
  OATH_BASE32_OVERFLOW: New error code.
  OATH_MALLOC_ERROR: New error code.

Revision 1.5 / (download) - annotate - [select for diffs], Tue Oct 23 18:16:37 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
Changes since 1.4: +1 -3 lines
Diff to previous 1.4 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.4 / (download) - annotate - [select for diffs], Sat Apr 7 22:34:13 2012 UTC (11 years, 7 months ago) by dholland
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.3: +2 -1 lines
Diff to previous 1.3 (colored)

Add missing pam.bl3.mk

Revision 1.3 / (download) - annotate - [select for diffs], Thu Jan 12 20:17:47 2012 UTC (11 years, 10 months ago) by pettai
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base, pkgsrc-2012Q1
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Version 1.10.5

* Build fixes from Linus Nordberg and Arno Hautala.
* Update gnulib files.

Revision 1.2 / (download) - annotate - [select for diffs], Wed Dec 14 09:04:13 2011 UTC (11 years, 11 months ago) by pettai
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Version 1.10.4

* liboath: Fix build so that OATH_VERSION_NUMBER is actually defined.
It was an empty value in the last release due to a bug in the build
scripts.

Version 1.10.3

* liboath: Allow strcmp callback to return negative to signal errors.
* Fix bugs in build scripts for generating version numbers.
* Update gnulib files.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Mon Dec 5 09:51:20 2011 UTC (11 years, 11 months ago) by pettai
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

The OATH Toolkit contains a shared library, command line tool and a PAM module
that makes it possible to build one-time password authentication systems.
Supported technologies include the event-based HOTP algorithm and the
time-based TOTP algorithm.
OATH is the Open AuTHentication organization which specify the algorithms.

Revision 1.1 / (download) - annotate - [select for diffs], Mon Dec 5 09:51:20 2011 UTC (11 years, 11 months ago) by pettai
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>