[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / nessus-plugins

File: [cvs.NetBSD.org] / pkgsrc / security / nessus-plugins / Attic / Makefile (download)

Revision 1.18, Mon Apr 4 09:32:02 2005 UTC (19 years ago) by adam
Branch: MAIN
Changes since 1.17: +3 -2 lines

Changes 2.2.4:
* Fixed several bugs which may impact scanning performance
* Reduced CPU usage
* A new SMB API to log into the remote Windows host

# $NetBSD: Makefile,v 1.18 2005/04/04 09:32:02 adam Exp $

.include	"../nessus/Makefile.common"

DISTNAME=	nessus-plugins-GPL-${VERS}
PKGNAME=	nessus-plugins-${VERS}

COMMENT=	Plugins for the Nessus Network Security Scanner

DEPENDS+=	nmap>=2.0:../../net/nmap

WRKSRC=		${WRKDIR}/nessus-plugins
USE_BUILDLINK3=		yes
GNU_CONFIGURE=		yes

CONFIGURE_ARGS+=	--localstatedir=${VARBASE}

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "NetBSD"
CONFIGURE_ARGS+=	--with-fetchcmd=/usr/bin/ftp
.else
CONFIGURE_ARGS+=	--with-fetchcmd=${PREFIX}/bin/ftp
.endif

SUBST_CLASSES+=		fetch
SUBST_STAGE.fetch=	post-configure
SUBST_FILES.fetch=	nessus-update-plugins
SUBST_SED.fetch=	-e "s|fetch_args=\"\"|fetch_args=\"-o -\"|g"
SUBST_MESSAGE.fetch=	"Fixing fetch parameters."

PLIST_SRC=	${WRKDIR}/PLIST PLIST

# auto-generate PLIST of plug-ins
post-install:
	${RM} -f ${WRKDIR}/PLIST
	cd ${PREFIX} && \
	${FIND} lib/nessus/plugins -type f -print >>${WRKDIR}/PLIST

.include "../../security/nessus-core/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"