File:  [cvs.NetBSD.org] / pkgsrc / security / libgpg-error / Makefile
Revision 1.56: download - view: text, annotated - select for diffs
Thu Jan 19 18:52:23 2017 UTC (8 years, 1 month ago) by agc
Branches: MAIN
CVS tags: HEAD
Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

# $NetBSD: Makefile,v 1.56 2017/01/19 18:52:23 agc Exp $

DISTNAME=	libgpg-error-1.26
CATEGORIES=	security
MASTER_SITES=	ftp://ftp.gnupg.org/gcrypt/libgpg-error/
MASTER_SITES+=	ftp://ftp.ring.gr.jp/pub/net/gnupg/libgpg-error/
MASTER_SITES+=	ftp://mirror.switch.ch/mirror/gnupg/libgpg-error/
MASTER_SITES+=	ftp://ftp.freenet.de/pub/ftp.gnupg.org/gcrypt/libgpg-error/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	minskim@NetBSD.org
HOMEPAGE=	http://www.gnupg.org/
COMMENT=	Definitions of common error values for all GnuPG components
LICENSE=	gnu-gpl-v2 AND gnu-lgpl-v2.1

USE_LIBTOOL=		yes
USE_TOOLS+=		gmake
USE_PKGLOCALEDIR=	yes
GNU_CONFIGURE=		yes
MAKE_ENV+=		LC_ALL="C"
MAKE_JOBS_SAFE=		no
INFO_FILES=		yes

.include "../../mk/bsd.prefs.mk"

.if !empty(USE_CROSS_COMPILE:M[yY][eE][sS])
CONFIGURE_ENV+=		CC_FOR_BUILD=${NATIVE_CC:Q}
.else
CONFIGURE_ENV+=		CC_FOR_BUILD=${CC:Q}\ ${CFLAGS:M*:Q}
.endif

# XXX See HACKS
.if ${OPSYS} == "IRIX" || !empty(MACHINE_PLATFORM:MNetBSD-[3-9]*)
USE_TOOLS+=		awk
.else
USE_TOOLS+=		gawk
.endif

.if !empty(MACHINE_PLATFORM:MSunOS-5.10-*)
LIBS+=	-lrt
.endif

# On Dragonfly i386, Pkgsrc libintl segfaults on bindtextdomain function
# while locking a thread.  Until that's resolved, stop libgpg-error from
# using NLS which invokes that function during initialization.
PLIST_VARS+=	nls
.if ${OPSYS} == "DragonFly" && ${MACHINE} == "i386"
CONFIGURE_ARGS+=	--disable-nls
.else
PLIST.nls=	yes
.endif

TEST_TARGET=		check

.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>