[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / heimdal

Annotation of pkgsrc/security/heimdal/Makefile, Revision 1.154

1.154   ! wiz         1: # $NetBSD: Makefile,v 1.153 2022/04/18 19:10:04 adam Exp $
1.1       jlam        2:
1.147     wiz         3: DISTNAME=      heimdal-7.7.0
1.154   ! wiz         4: PKGREVISION=   5
1.15      jlam        5: CATEGORIES=    security
1.147     wiz         6: MASTER_SITES=  ${MASTER_SITE_GITHUB:=heimdal/}
1.149     wiz         7: GITHUB_RELEASE=        ${DISTNAME}
1.15      jlam        8:
1.79      wiz         9: MAINTAINER=    pkgsrc-users@NetBSD.org
1.65      jlam       10: HOMEPAGE=      http://www.h5l.org/
1.15      jlam       11: COMMENT=       Kerberos 5 implementation
1.73      wiz        12: LICENSE=       modified-bsd
1.1       jlam       13:
1.147     wiz        14: BUILD_DEPENDS+=        p5-JSON-[0-9]*:../../converters/p5-JSON
                     15:
1.51      wiz        16: CONFLICTS+=    arla-[0-9]*
1.15      jlam       17: CONFLICTS+=    mit-krb5-[0-9]*
1.52      wiz        18: CONFLICTS+=    openafs-[0-9]*
1.56      jlam       19: CONFLICTS+=    gss-[0-9]*
1.92      cheusov    20: CONFLICTS+=    kth-krb4-[0-9]*
1.3       jlam       21:
1.1       jlam       22: USE_LIBTOOL=           yes
1.147     wiz        23: USE_TOOLS+=            bison flex:run perl
1.65      jlam       24: PKGCONFIG_OVERRIDE+=   tools/heimdal-gssapi.pc.in
1.45      jlam       25: MAKE_ENV+=             INSTALL_CATPAGES=no
1.1       jlam       26:
1.147     wiz        27: BUILD_DEFS+=           VARBASE
                     28:
                     29: WRKSRC=                ${WRKDIR}/${DISTNAME}
1.138     rillig     30:
1.65      jlam       31: .include "options.mk"
                     32:
                     33: HEIMDAL_HDB_DIR=       ${VARBASE}/heimdal
1.1       jlam       34:
                     35: GNU_CONFIGURE=         yes
1.136     rillig     36: GNU_CONFIGURE_STRICT=  no # has multiple configure scripts
1.80      adam       37: CONFIGURE_ARGS+=       --enable-kcm
                     38: CONFIGURE_ARGS+=       --enable-pthread-support
1.1       jlam       39: CONFIGURE_ARGS+=       --includedir=${PREFIX}/include/krb5
1.80      adam       40: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR}
1.88      shattere   41: CONFIGURE_ARGS+=       --with-hdbdir=${HEIMDAL_HDB_DIR}
1.80      adam       42: CONFIGURE_ARGS+=       --with-sqlite3=${BUILDLINK_PREFIX.sqlite3}
1.1       jlam       43: CONFIGURE_ARGS+=       --without-x
1.65      jlam       44: CONFIGURE_ARGS+=       ${ABI:D--with-mips-abi=${ABI}}
                     45: CONFIGURE_ENV+=                COMPILE_ET=no   # build Heimdal's compile_et(1)
1.1       jlam       46:
1.101     adam       47: .include "../../mk/bdb.buildlink3.mk"
                     48:
                     49: # XXX Don't detect db1 when a newer version is available; otherwise build fails
                     50: .if ${BDB_TYPE} != "db1"
                     51: CONFIGURE_ENV+=                ac_cv_funclib_dbopen=no
                     52: .endif
                     53:
1.45      jlam       54: CFLAGS.Darwin+=                -DBIND_8_COMPAT
1.39      yyamano    55:
1.121     jperkin    56: # Newer illumos has extended functions in glob(3C) but it's easier to
                     57: # say it doesn't for simpler PLIST.glob handling.
                     58: CONFIGURE_ENV.SunOS+=  ac_cv_func_glob_working=no
                     59:
1.44      rillig     60: # Though Solaris has a <vis.h> header, it does something very unrelated
                     61: # to the BSD <vis.h> header.
                     62: CONFIGURE_ENV.SunOS+=  ac_cv_header_vis_h=no
                     63:
1.100     jperkin    64: .include "../../mk/readline.buildlink3.mk"
                     65:
1.99      ryoon      66: CONFIGURE_ARGS+=       --with-readline=${BUILDLINK_PREFIX.editlinereadline}
1.1       jlam       67:
1.148     wiz        68: PLIST_VARS+=           glob vis afskauth
1.131     tnn        69:
1.103     richard    70: .if ${OPSYS} == "SunOS"
                     71: PLIST.vis=     yes
                     72: PLIST.glob=    yes
                     73: .endif
1.102     joerg      74:
1.63      rillig     75: .if ${OPSYS} == "IRIX"
1.69      jlam       76: PLIST.afskauth=                yes
1.63      rillig     77: .endif
1.89      fhajny     78:
1.83      sbd        79: OWN_DIRS_PERMS=                ${HEIMDAL_HDB_DIR} ${REAL_ROOT_USER} ${REAL_ROOT_GROUP} 0700
1.65      jlam       80: SPECIAL_PERMS+=                ${PREFIX}/bin/otp ${SETUID_ROOT_PERMS}
1.147     wiz        81: SPECIAL_PERMS+=                ${PREFIX}/bin/${KRB5_PREFIX}su ${SETUID_ROOT_PERMS}
1.45      jlam       82: RCD_SCRIPTS=           kadmind kcm kdc kpasswdd
1.72      shattere   83: INFO_FILES=            yes
1.1       jlam       84:
1.86      asau       85: TEST_TARGET=           check
                     86:
1.80      adam       87: # remove manpages conficting with OpenSSL keeping only the important ones
                     88: pre-configure:
                     89:        cd ${WRKSRC}/doc/doxyout/hcrypto && \
                     90:        ${GREP} -e /hcrypto_ -e /page_ manpages > manpages.new && \
                     91:        mv manpages.new manpages
                     92:
                     93: .include "../../databases/sqlite3/buildlink3.mk"
1.109     obache     94:
1.131     tnn        95: # Linux does not have include/vis.h and expected include/glob.h.
                     96: .if ${OPSYS} == "Linux"
1.134     rillig     97: PLIST.vis=             yes
                     98: PLIST.glob=            yes
1.131     tnn        99: # Without this I get undefined references to pthread_getspecific
                    100: PTHREAD_AUTO_VARS=     yes
                    101: .endif
                    102:
1.111     bsiegert  103: .if ${OPSYS} == "MirBSD"
                    104: PLIST.vis=             yes
                    105: # all of the tools need to link against pthread, force it.
                    106: PTHREAD_AUTO_VARS=     yes
                    107: .endif
                    108:
1.128     sevan     109: .if ${OPSYS} == "Minix"
                    110: # all of the tools need to link against pthread, force it.
                    111: PTHREAD_AUTO_VARS=     yes
                    112: .endif
                    113:
1.104     roy       114: .include "../../mk/termcap.buildlink3.mk"
1.80      adam      115: .include "../../mk/pthread.buildlink3.mk"
1.101     adam      116: .include "../../mk/readline.buildlink3.mk"
1.147     wiz       117: .include "../../security/openssl/buildlink3.mk"
                    118: # integrated editline configure script that always runs checks for this
                    119: .include "../../mk/curses.buildlink3.mk"
1.1       jlam      120: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>